“Spooler Subsystem App Has Encountered a Problem and Needs to Close”(后台处理程序子系统应用程序遇到了问题,需要关闭)和“Operation Could Not Be Completed”(无法完成操作)错误消息

文章翻译 文章翻译
文章编号: 324757 - 查看本文应用于的产品
重要说明:本文包含有关修改注册表的信息。修改注册表之前,一定要先进行备份,并且一定要知道在发生问题时如何还原注册表。有关如何备份、还原和编辑注册表的信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
256986 Microsoft Windows 注册表说明
展开全部 | 关闭全部

症状

您可能会在基于 Microsoft Windows XP 的计算机中遇到下列两个症状之一:
  • 在启动计算机、尝试启动后台打印程序服务、尝试停止后台打印程序服务、或在单击“开始”然后单击“打印机和传真”时,您可能会收到下面的错误消息:
    Spooler subsystem app has encountered a problem and needs to close.
  • 在单击“开始”,然后单击“打印机和传真”尝试查看打印机时,虽然您已经安装了打印机,但未出现任何打印机。如果单击“添加打印机”,或者尝试打印,可能会收到以下错误消息:
    操作无法完成。
    因此,无法添加打印机。

原因

如果安装的第三方打印机驱动程序或服务妨碍您添加打印机,或者第三方打印机驱动程序或服务对新安装的打印机的功能有影响,则可能出现此问题。

例如,如果在尝试添加另一台打印机之前,您的计算机上已经安装了 Lexmark 打印服务(LexBce Server 服务)并且该服务正在运行,则可能出现此问题。

解决方案

警告:注册表编辑器使用不当可导致严重问题,可能需要重新安装操作系统。Microsoft 不能保证可以解决因注册表编辑器使用不当而导致的问题。使用注册表编辑器需要您自担风险。

要解决此问题,请按照下列步骤操作:
  1. 如果您的计算机上安装了 Lexmark 打印服务,请关闭 LexBce Server 服务。为此,请按照下列步骤操作:
    1. 单击“开始”,右键单击“我的电脑”,然后单击“管理”。
    2. 展开“服务和应用程序”,然后单击“服务”。
    3. 在右窗格中,右键单击“LexBce Server”,然后单击“属性”。
    4. 在“常规”选项卡的“启动类型”列表中,单击“已禁用”。
    5. 在“服务状态”下,单击“停止”,然后单击“确定”。
    6. 右键单击“Print Spooler”服务,然后单击“启动”(如果它已停止)。
    7. 退出“计算机管理”。
  2. 测试此问题是否已解决。如果此问题得到解决,则不必执行其余步骤。如果问题未得到解决,请执行步骤 3,然后执行其余步骤。
  3. 在安全模式下启动计算机。

    有关如何以安全模式启动计算机的其他信息,请单击“开始”,单击“帮助和支持”,在“搜索”框中键入安全模式,按 Enter 键,然后单击“以安全模式启动 Windows”主题。
  4. 启动 Microsoft Windows 资源管理器,然后删除下面两个文件夹中的所有文件和文件夹(其中 C:是 Windows XP 安装到的驱动器):
    • C:\Windows\System32\Spool\Printers
    • C:\Windows\System32\Spool\Drivers\w32x86
  5. 启动注册表编辑器。为此,请单击“开始”,单击“运行”,在“打开”框中键入 regedit,然后单击“确定”。
  6. 找到并展开以下注册表项:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows NT x86
    查看子项列表。列表中应该仅包含以下子项:
    • Drivers
    • Print Processors
  7. 如果除了步骤 6 中列出的子项外,列表中还有其他子项,请按照下列步骤操作:
    1. 在“文件”菜单上,单击“导出”。
    2. 在“文件名”框中,为此项键入一个描述性名称(例如,键入 WindowsNTx86regkey),然后单击“保存”。

      如果在完成此过程后遇到任何问题,则可以使用
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows NT x86
      注册表项的这一备份来还原该项。
    3. 删除步骤 6 中列出的子项以外的其他所有子项。为此,请右键单击列表中未包含的每个子项,然后单击“删除”。当提示您确认删除时,请单击“是”。
  8. 找到然后展开下面的注册表项:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows NT x86\Drivers
    计算机上安装的打印机驱动程序的注册表项存储在“Version-x”子项中,其中 x 是一个数字(通常为 2 或 3)。
  9. 展开“Version-x”子项,然后删除打印机驱动程序项。为此,请右键单击每个打印机驱动程序子项,然后单击“删除”。当提示您确认删除时,请单击“是”。
  10. 找到然后展开下面的注册表项:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors
    查看子项列表。列表中应该仅有默认打印监视程序的下列子项:
    • BJ Language Monitor
    • Local Port
    • PJL Language Monitor
    • Standard TCP/IP Port
    • USB Monitor
  11. 如果除了步骤 10 中列出的子项外,列表中还有其他子项,请按照下列步骤操作:
    1. 在“文件”菜单上,单击“导出”。
    2. 在“文件名”框中,键入此项的描述性名称,例如,键入 MonitorsRegkey,然后单击“保存”。

      如果在完成此过程后遇到任何问题,则可以使用
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors
      注册表项的这一备份来还原该项。
    3. 删除步骤 10 中列出的子项以外的其他所有子项。为此,请右键单击列表中未包含的每个子项,然后单击“删除”。当提示您确认删除时,请单击“是”。
  12. 如果连接有本地打印机,则从计算机上断开该打印机电缆,然后重新启动计算机。
  13. 验证打印后台处理程序服务是否正在运行。为此,请按照下列步骤操作:
    1. 单击“开始”,右键单击“我的电脑”,然后单击“管理”。
    2. 展开“服务和应用程序”,然后单击“服务”。
    3. 在右窗格中,右键单击“后台打印程序”服务,然后单击“启动”(如果该服务已停止)。
    4. 退出“计算机管理”。
  14. 如果连接有本地打印机,则将该打印机电缆重新连接到计算机上,添加所需的打印机,然后尝试打印一张测试页。要添加打印机,请按照下列步骤操作:
    1. 单击“开始”,然后单击“打印机和传真”。
    2. 单击“添加打印机”。

      “添加打印机向导”将启动。
    3. 按照“添加打印机向导”中的说明安装所需的打印机。

更多信息

有关如何手动删除打印机驱动程序的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
135406 手动删除和重新安装打印机驱动程序的步骤
有关如何解决 Windows XP 中打印问题的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
314085 解决 Windows XP 中的一般打印问题
本文中提到的第三方产品由 Microsoft 以外的其他公司提供。对于这些产品的性能或可靠性,Microsoft 不作任何暗示保证或其他形式的保证。
注意:本篇“快速发布”文章是从 Microsoft 支持组织直接创建的。 文中包含的信息按原样提供,用于响应紧急问题。 由于发布仓促,材料可能包含印刷错误,并且可能随时修订,恕不另行通知。 有关其他注意事项,请参阅使用条款

属性

文章编号: 324757 - 最后修改: 2011年10月28日 - 修订: 6.0
这篇文章中的信息适用于:
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Home Edition
关键字:?
kbregistry kb3rdparty kbenv kbprint kbdriver kberrmsg kbprb KB324757
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。

提供反馈

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com