При опит на Windows XP да зареди услугата Agp440.sys възникват проблеми

Преводи на статии Преводи на статии
ID на статията: 324764 - Преглед на продукти, за които се отнася тази статия.
Разгъване на всички | Сгъване на всички

СИМПТОМИ

При инсталиране на Windows XP е възможно да възникне един или няколко от следните симптоми:
  • След рестартиране на компютъра може да се появи подкана за използване на последната известна добра конфигурация. Ако се съгласите, вашият компютър може да спре да реагира (да увисне) по време на рестартирането и след всяко последващо рестартиране.
  • Може да се появи подкана да използвате инструмента ScanDisk. Ако приемете, компютърът може да спре да отговаря (да увисне). Ако не стартирате ScanDisk, компютърът може да стартира по правилен начин. Въпреки това при всяко стартиране на компютъра ще се появява подкана за стартиране на ScanDisk. В случай, че я приемете, компютърът ще престане да реагира (ще увисне).
  • При рестартиране на компютъра той може да спре да отговаря (да увисне).
  • Ако се опитате да рестартирате компютъра в безопасен режим, той може да спре да отговаря (да увисне) при опит на Windows XP да зареди услугата Agp440.sys.

ПРИЧИНА

Този проблем може да възникне при опит на Windows XP да използва несъвместим драйвер на видеоадаптера, вграден в дънната платка.

РАЗРЕШЕНИЕ

За да разрешите този проблем, изпълнете стъпките по-долу, чрез които ще деактивирате услугата Agp440.sys.

Важно За да изпълните тази процедура докрай, е необходимо да знаете администраторската парола. Ако не знаете тази парола, свържете се с вашия системен администратор. След завършването на тази процедура всички инсталирани видеоадаптери ще бъдат деактивирани и Windows XP ще използва подразбиращите се VGA драйвери.
  1. Поставете компактдиска с Windows XP в CD-ROM или DVD-ROM устройството и рестартирайте компютъра от CD-ROM устройството.

    Забележка Някои компютри могат да изискват модифициране на настройките на базовата входно/изходна система (BIOS), преди да позволят стартиране на компютъра от CD-ROM устройството. Вижте документацията към компютъра за информация как да модифицирате BIOS.
  2. При появяване на екрана Welcome to Setup ("Добре дошли в инсталационната програма") натиснете R, за да стартирате конзолата за възстановяване.
  3. Натиснете цифровия клавиш, съответстващ на инсталацията, която искате да поправите, след което натиснете ENTER.
  4. Въведете администраторската паролата за тази инсталация и натиснете клавиша ENTER. Появява се подкана дял:WINDOWS>, където дял е делът, на който е инсталирана операционната система Windows XP.
  5. Въведете listsvc и натиснете ENTER.
  6. Уверете се, че услугата Agp440 присъства в списъка и че типът на стартиране е "Boot" ("Зареждане").
  7. Натиснете ESC.
  8. Въведете disable agp440 и натиснете ENTER.
  9. Повява се съобщение, че е открита настройка на системния регистър за тази услуга и че текущото й състояние по отношение на стартиране е "service_disabled".
  10. Въведете exit и натиснете ENTER.
  11. Ако се появи подкана да стартирате в безопасен режим или в нормален режим, стартирайте компютъра в нормален режим.
  12. Влезте в операционната система на компютъра.
Windows XP включва подразбиращите се видеодрайвери, които осигуряват функционирането на монитора. Някои функции могат да функционират различно от очакваното с тези подразбиращи се драйвери. Актуализирайте периодично драйверите на видеоадаптера, вграден в дънната платка. За тази цел посетете уеб сайта на производителя на компютъра и изтеглете най-новите драйвери за видеоадаптера.

ДОПЪЛНИТЕЛНА ИНФОРМАЦИЯ

За допълнителна информация относно подобна тема щракнете върху следния номер на статия в базата знания на Microsoft:
307654 Как да инсталирате и използвате конзолата за възстановяване в Windows XP (Тази връзка може да сочи към съдържание, което е отчасти или изцяло на английски)

Свойства

ID на статията: 324764 - Последна рецензия: 12 юни 2007 г. - Редакция: 2.0
ВАЖИ ЗА
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Ключови думи: 
kbdisplay kbenv kbprb KB324764

Изпратете обратна информация

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com