Windows XP が Agp440.sys サービスを読み込もうとするときの問題

文書翻訳 文書翻訳
文書番号: 324764 - 対象製品
すべて展開する | すべて折りたたむ

現象

Windows XP をインストールした場合、次のいずれかまたは複数の現象が発生することがあります。
  • コンピュータの再起動時、前回正常起動時の構成の使用を確認する画面が表示されることがある。その構成を使用して再起動すると、再起動中にコンピュータが応答を停止 (ハング) することがあり、その後、再起動するたびに同じ現象が発生することがあります。
  • ScanDisk の実行を求められることがある。ScanDisk を実行すると、コンピュータが応答を停止 (ハング) することがあります。ScanDisk を実行しないと、コンピュータが正常に起動することがあります。しかし、コンピュータを起動するたびに ScanDisk の実行を求められ、ScanDisk を実行すると、コンピュータが応答を停止 (ハング) することがあります。
  • コンピュータを再起動すると、コンピュータが応答を停止 (ハング) する。
  • コンピュータをセーフ モードで再起動しようとすると、Windows XP が Agp440.sys サービスを読み込もうとするときに、コンピュータが応答を停止 (ハング) することがある。

原因

起動時に Windows XP が互換性のないマザーボード チップ セットのビデオ ドライバを使用しようとした場合に、この問題が発生することがあります。

解決方法

この問題を解決するには、次の手順を実行して Agp440.sys サービスを無効にします。

重要 : 次の手順を完了するには、Administrator のパスワードが必要です。Administrator のパスワードがわからない場合は、システム管理者に問い合わせてください。この手順を完了後、インストールされているビデオ ドライバはすべて無効になり、Windows XP はデフォルトの VGA ドライバを使用します。
  1. Windows XP CD-ROM をコンピュータの CD-ROM ドライブまたは DVD-ROM ドライブに挿入し、コンピュータを CD-ROM から再起動します。

    : コンピュータによっては、CD-ROM からコンピュータを起動するために BIOS (Basic Input/Output System) 設定の修正が必要な場合があります。BIOS の修正方法については、コンピュータに付属のマニュアルを参照してください。
  2. [セットアップの開始] 画面が表示されたら、R キーを押して回復コンソールを起動します。
  3. 修復するインストールの数字に対応した数字キーを押して、次に Enter キーを押します。
  4. そのインストールに対する Administrator アカウントのパスワードを入力して、Enter キーを押します。drive:WINDOWS> プロンプトが表示されます。ここで、drive は Windows XP をインストールしたドライブです。
  5. listsvc と入力し、Enter キーを押します。
  6. Agp440 サービスが一覧にあること、およびスタートアップの種類が "ブート" であることを確認します。
  7. Esc キーを押します。
  8. disable agp440 と入力し、Enter キーを押します。
  9. このサービスに対するレジストリ設定が見つかったこと、および現在のスタートアップ状態が "SERVICE_DISABLED" であることを示すメッセージが表示されます。
  10. exit と入力し、Enter キーを押します。
  11. セーフ モードまたは通常モードのどちらで起動するかどうかの確認を求めるプロンプトが表示された場合は、通常モードで起動します。
  12. コンピュータにログオンします。
Windows XP には、モニタの動作を可能にするデフォルトのビデオ ドライバが含まれています。しかし、デフォルトのドライバでは一部の機能が正しく動作しないことがあります。定期的にマザーボード チップ セットのビデオ ドライバを更新してください。そのためには、コンピュータ製造元の Web サイトを参照し、ビデオ アダプタ用の最新のドライバをダウンロードします。

詳細

関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
307654 Windows XP での回復コンソールのインストールおよび使用方法

プロパティ

文書番号: 324764 - 最終更新日: 2006年3月10日 - リビジョン: 2.0
この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
キーワード:?
kbdisplay kbenv kbprb KB324764
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com