Artikel-ID: 324906 - Geändert am: Dienstag, 27. Juni 2006 - Version: 3.0

Office-Programm kann nach der Installation von Service Pack 3 (SP3) für Windows 2000 nicht gestartet werden

Dieser Artikel wurde zuvor veröffentlicht unter D324906
Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
324906  (http://support.microsoft.com/kb/324906/EN-US/ ) Cannot Start an Office Program After You Install Service Pack 3 (SP3) for Windows 2000
Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, dass nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachigen Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.

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Problembeschreibung

Wenn Sie versuchen, ein Microsoft Office-Programm zu starten, nachdem Sie Ihren Computer mit Service Pack 3 (SP3) für Windows 2000 aktualisiert haben, wird Ihnen möglicherweise eine der folgenden Fehlermeldungen angezeigt:
Auf den Windows Installer-Dienst konnte nicht zugegriffen werden.
Dies kann auftreten, wenn Windows im abgesicherten Modus ausgeführt wird oder wenn der Windows Installer nicht korrekt installiert wurde. Wenden Sie sich an den Support.
-oder-
Dieses Anwendungsprogramm muss installiert sein, damit es ausgeführt werden kann. Führen Sie das Setupprogramm von der Stelle aus, von der Sie die Anwendung ursprünglich installiert haben.
-oder-
Das Patchpaket konnte nicht geöffnet werden. Stellen Sie sicher, dass das Paket vorhanden ist und Sie darauf zugreifen können, oder wenden Sie sich an den Hersteller der Anwendung, um sicherzustellen, dass es sich um ein gültiges Windows-Installationspaket handelt.
-oder-
Das System kann das angegebene Gerät oder die angegebene Datei nicht öffnen.
Eventuell werden Sie aufgefordert, den Pfad zu der Datei "Proplus.msi" einzugeben. Nachdem Sie den Pfad eingegeben haben, wird weiterhin dieselbe Fehlermeldung angezeigt.

Unter Umständen ist es in dieser Situation nicht möglich, ein Office-Programm zu starten.

Ursache

Dieses Verhalten kann aus einem der folgenden Gründe auftreten:
  • Die standardmäßige Identitätswechselebene für DCOM ist auf Anonym festgelegt.
  • Das SYSTEM-Konto verfügt nicht über die Berechtigung des Typs Vollzugriff für einen Ordner, auf den der Windows Installer zuzugreifen versucht.

    Anmerkung: Dieses Verhalten tritt nur beim NTFS-Dateisystem auf.
  • Die Dateninformationen der Windows Installer-Version 1. x werden nicht auf die Windows Installer-Version 2. x übertragen, die SP3 auf dem Computer installiert. Der Windows Installer kann nicht erkennen, dass Office auf dem Computer installiert ist, weil SP3 Ihren Windows Installer von der Version 1. x auf die Version 2. x aktualisiert hat. Deshalb hat SP3 alle Ihre Windows Installer-Datendateien, in denen Office-Produkte enthalten waren, aus den Windows Installer-Registrierungsschlüsseln der Version 1. x nach Windows Installer 2.0 verschoben.

    Anmerkung: Dieses Verhalten tritt nur beim NTFS-Dateisystem auf.
Die Windows Installer-Version 2, die in SP3 für Windows 2000 enthalten ist, funktioniert nicht, wenn die standardmäßige Identitätswechselebene für DCOM auf Anonym festgelegt ist.

Lösung

Wenden Sie die folgenden Verfahren in der angegebenen Reihenfolge an, bis dieses Problem behoben ist.

1. Verfahren: Ändern Sie die standardmäßige Identitätswechselebene für DCOM auf "Identifizieren"

Ändern Sie die standardmäßige Identitätswechselebene für DCOM auf Identifizieren, entfernen Sie die Datei "Msisip.dll" und installieren Sie anschließend SP3 für Windows 2000 neu. Gehen Sie hierzu folgendermaßen vor:
  1. Klicken Sie auf Start, klicken Sie auf Ausführen, geben Sie dcomcnfg ein und klicken Sie anschließend auf OK.
  2. Klicken Sie auf die Registerkarte Standardeigenschaften.
  3. Klicken Sie in der Liste Standardauthentifizierungsebene auf Verbinden.
  4. Klicken Sie in der Liste Standardidentitätswechselebene auf Identifizieren und dann auf OK.
  5. Klicken Sie auf Start, auf Ausführen, geben Sie %systemroot%\system32\drivers\ ein und klicken Sie auf OK.
  6. Benennen Sie die Datei "Msisip.dll" um zu "Msisip.old".
  7. Installieren Sie das neueste verteilbare MSI 2.0-Paket. Besuchen Sie hierzu folgende Webseite von Microsoft:
    http://www.microsoft.com/downloads/details.aspx?familyid=4B6140F9-2D36-4977-8FA1-6F8A0F5DCA8F (http://www.microsoft.com/downloads/details.aspx?familyid=4B6140F9-2D36-4977-8FA1-6F8A0F5DCA8F)
  8. Starten Sie den Computer neu.
  9. Installieren Sie SP3 neu, falls es nicht bereits installiert ist. (Mithilfe von "Winver.exe" können Sie feststellen, ob SP3 bereits installiert ist.)

2. Verfahren: Gewähren Sie dem SYSTEM-Konto die Berechtigung "Vollzugriff"

  1. Starten Sie den Windows-Explorer, klicken Sie mit der rechten Maustaste auf die Stammfestplatte des Computers und anschließend mit der linken Maustaste auf Eigenschaften.
  2. Klicken Sie auf die Registerkarte Sicherheit und dann auf Hinzufügen.
  3. Klicken Sie im Dialogfeld Benutzer, Computer oder Gruppen auswählen auf das Konto SYSTEM, klicken Sie auf Hinzufügen und anschließend auf OK.
  4. Aktivieren Sie unter Zulassen das Kontrollkästchen Vollzugriff. Klicken Sie anschließend auf OK.

3. Verfahren: Hotfix installieren

Sie müssen den Hotfix "Msiregmv.exe" installieren. Dieser Hotfix verschiebt alle Datenregistrierungsschlüssel der Windows Installer-Version 1. x in die Registrierung der Windows Installer-Version 2. x.

Status

Microsoft hat bestätigt, dass es sich hierbei um ein Problem bei den in diesem Artikel genannten Microsoft-Produkten handelt.

Weitere Informationen

Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
319624  (http://support.microsoft.com/kb/319624/DE/ ) PRB: Incorrect Default DCOM Settings Cause Windows Installer to Stop Responding

Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows 2000 Service Pack 3
Keywords: 
kbappcompatibility kbprb KB324906
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