コンピュータの再起動後、エラー メッセージが表示される、ドライブ文字が変更される、またはダイナミック ディスクがベーシック ディスクとして表示される

文書翻訳 文書翻訳
文書番号: 325040 - 対象製品
この資料は、アーカイブされました。これは "現状のまま" で提供され、更新されることはありません。
すべて展開する | すべて折りたたむ

目次

現象

"ディスクの管理" で、以前は "ダイナミック" と表示されていたディスクが "ベーシック" と表示されるようになります。また、ダイナミック ディスクがないことが示される場合もあります。そのダイナミック ディスク上にあったボリュームにアクセスできなくなり、エラーが表示されることもあります。

この問題は、"ディスクの管理" から "ディスクの再スキャン" を実行した場合に発生することもあります。

原因

この問題は、ハード ディスクが SCSI ドライブの場合に発生することがあります。起動プロセス実行中、またはディスクの管理からディスクの再スキャン中に、オペレーティング システムが、PartitionLength の代わりに SectorCount を断続的に読み込んで、ドライブ指定またはドライブ署名を決定している場合があります。また、PartitionLength はグローバル変数であるため、2 つのスレッドがほぼ同時に PartitionLength を使用して、PartitionLength が予想より 512 倍も大きくなる時期があります。この問題が発生した場合、通常のドライブ指定とは異なるドライブ指定がドライブに割り当てられている可能性があります。

解決方法

これらの問題の再発を防ぐには、ここに記載されている最新の Windows 2000 Service Pack をインストールするか、「修正プログラムの情報」に記載されている修正プログラムを適用します。既に発生している問題を修正するには、「回避策」に記載されている手順を実行します。

Service Pack の情報

この問題を解決するには、Microsoft Windows 2000 の最新の Service Pack を入手します。関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
260910 最新の Windows 2000 Service Pack の入手方法

修正プログラムの情報

マイクロソフトでは、現在この問題を修正する修正プログラムを提供中ですが、修正プログラムはこの資料に記載された問題のみを修正することを目的としており、障害があったコンピュータに対してのみ適用することを推奨します。この修正プログラムは、今後さらにテストを行う場合があります。この問題で深刻な影響を受けていない場合は、この修正プログラムが含まれる次の Windows 2000 Service Pack がリリースされるまで待つことを推奨します。

この問題を解決するには、Microsoft Product Support Services にお問い合わせのうえ、修正プログラムを入手してください。Microsoft Product Support Services の電話番号一覧およびサポート料金については、次のマイクロソフト Web ページを参照してください。
http://support.microsoft.com/contactus/?ws=support
: Microsoft Support 担当者が、特定の更新プログラムを適用することにより問題が解決されると判断した場合、まれに通常サポート依頼にかかる料金が免除されることがあります。ただし、特定の更新プログラムの対象とならない追加の質問および問題については、通常のサポート料金が適用されます。

修正プログラム (英語版) のファイル属性は次表のとおりです。ただし、これより新しい修正プログラムがリリースされている可能性もあります。各ファイルの日付および時刻は、世界協定時刻 (UTC) で示されています。ファイル情報に表示される時刻は、ローカル時刻に変換されています。UTC とローカル時刻との時差を確認するには、コントロール パネルの [日付と時刻] の [タイム ゾーン] タブを使用してください。
 日付          時刻   バージョン       サイズ  ファイル名
 -------------------------------------------------------
 25-JUN-2002 11:33 5.0.2195.5912 34,384 Classpnp.sys 

回避策

この問題を回避するには、以下の手順を実行します。
  1. "ディスクの管理" を使用して、影響を受けているボリュームに正しいドライブ文字を再度割り当てます。ブート ボリュームのドライブ文字が影響を受けている場合は、ブート ボリュームのドライブ文字を変更します。

    関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
    249321 ブート ドライブ文字が変更されているとログオンできない
  2. Windows を起動するには、F8 キーを押し、方向キーを使用して [ディレクトリ サービス復元モード] を選択します。
  3. ディスクの管理を使用して、Active Directory ボリュームに正しいドライブ文字を再度割り当てます。
  4. ベーシックとして表示されるダイナミック ディスクの修復でヘルプが必要な場合は、Microsoft Product Support Services にお問い合わせください。問い合わせ方法については、次のマイクロソフト Web サイトを参照してください。
    http://support.microsoft.com/contactus/?ws=support

状況

マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。 この問題は、Microsoft Windows 2000 Service Pack 4 で最初に修正されました。

詳細

Windows 2000 Datacenter Server 用の修正プログラムを入手する方法の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
265173 Datacenter Program と Windows 2000 Datacenter Server
複数の修正プログラムのインストールを 1 回の再起動のみで行う方法の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
296861 複数の Windows 更新プログラムまたは修正プログラムを同時にインストールし、再起動を 1 回で済ませる方法

プロパティ

文書番号: 325040 - 最終更新日: 2014年2月14日 - リビジョン: 3.4
この資料は以下の製品について記述したものです。
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional
キーワード:?
kbnosurvey kbarchive kbhotfixserver kbhotfixserver kbqfe kbwin2ksp4fix kbprb kbbug kbfix kbwin2000presp4fix KB325040
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com