After You Restart Your Computer, an Error Message Occurs, or a Drive Letter Changes, or a Dynamic Disk Is Displayed As BASIC

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Article ID: 325040 - View products that this article applies to.
This article was previously published under Q325040
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Symptoms

In Disk Management, a disk that formerly appeared as "Dynamic" now appears as "BASIC." Disk Management may also indicate that a Dynamic disk is missing. Any volumes that were located on that Dynamic disk are now inaccessible and may appear as failed.

You may also experience this problem if you perform Rescan Disks from Disk Management.

Cause

This problem may occur if your hard disk is a SCSI drive. During the startup process or ScanDisk from Disk Management, the operating system may very intermittently read the SectorCount instead of the PartitionLength to determine drive designations or drive signatures. Also, there is a timing that two threads uses PartitionLength at the almost same time because it is a global variable, PartitionLength would be 512 times bigger than expected. When this problem occurs, a drive designation that is different from the usual drive designation may be assigned to your drives.

Resolution

To prevent these problems from recurring, install the latest Windows 2000 service pack that is described in this section, or apply the fix that is described in the "Hotfix Information" section later in this article. To correct any problems that have already occurred, use the procedure that is described in the "Workaround" section later in this article.

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
260910 How to obtain the latest Windows 2000 service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size    File name
   -------------------------------------------------------
   25-JUN-2002  11:33  5.0.2195.5912  34,384  Classpnp.sys  

Workaround

To work around this problem, follow these steps:
  1. Use Disk Management to reassign the correct drive letters to the affected volumes. If the boot volume drive letter is affected, change the boot volume drive letter.

    For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
    249321 Unable to log on if the boot partition drive letter has changed
  2. To start Windows, press F8, and then use the arrow keys to select Active Directory restore mode.
  3. Use Disk Management to reassign the correct drive letter back to the Active Directory volume.
  4. Call Microsoft Product Support Services for help with the repair of the Dynamic disk that is reported as BASIC. For information about how to contact Product Support Services, visit the following Microsoft Web site:
    http://support.microsoft.com/contactus/?ws=support

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows 2000 Service Pack 4.

More information

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the following article number to view the article in the Microsoft Knowledge Base:
265173 The Datacenter Program and Windows 2000 Datacenter Server product
For additional information about how to install multiple hotfixes with only one restart, click the following article number to view the article in the Microsoft Knowledge Base:
296861 How to install multiple Windows updates or hotfixes with only one reboot

Properties

Article ID: 325040 - Last Review: November 2, 2013 - Revision: 4.0
Applies to
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
Keywords: 
kbnosurvey kbarchive kbautohotfix kbhotfixserver kbqfe kbwin2ksp4fix kbprb kbbug kbfix kbwin2000presp4fix KB325040

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