Recibe un mensaje de error cuando intenta abrir un documento de Office

Síntomas

Al intentar abrir un archivo en cualquier programa de Microsoft Office que aparezca en la sección Se aplica a, recibirá uno de los siguientes mensajes de error:

El nombre de archivo no es válido.

No se ha podido obtener acceso al archivo.

La ruta que ha especificado, 'filename', es demasiado larga. Escriba una ruta de acceso más corta.

filename no encontrado. Compruebe la ortografía del nombre del libro y compruebe que la ubicación del archivo es correcta.

A DDE error has occurred, and a description of the error cannot be displayed because it is too long. (Se ha producido un error DDE y no se puede mostrar una descripción del error porque es demasiado largo.) Si el nombre de archivo o la ruta de acceso son largos, intente cambiar el nombre del archivo o copiarlo en otra carpeta.

Captura de pantalla del mensaje de error.

Nota:

Este problema se produce al abrir un archivo desde una unidad asignada, una ruta de acceso UNC o una dirección URL (dirección web).

Causa

Este problema se produce debido a un límite de caracteres para crear y guardar archivos en los productos de Office. Este problema se produce si la ruta de acceso del archivo que abre o guarda cumple la siguiente condición:

  • Microsoft Word, Microsoft PowerPoint y Microsoft Access: la longitud total de la ruta de acceso y el nombre de archivo, incluida la extensión de nombre de archivo, supera los 259 caracteres.

  • Microsoft Excel: la longitud total de la ruta de acceso y el nombre de archivo, incluida la extensión de nombre de archivo, supera los 218 caracteres.

Nota:

Este límite incluye los tres caracteres que representan la unidad, los caracteres de los nombres de carpeta, los caracteres de barra diagonal inversa entre los nombres de carpeta y los caracteres del propio nombre de archivo.

Solución alternativa

Para arreglar este problema, pruebe cualquiera de las soluciones alternativas siguientes.

Solución alternativa 1: Reducir el recuento de caracteres

  • Cambie el nombre del archivo para que sea más corto.
  • Cambie el nombre de una o varias carpetas que contengan el archivo para que sean más cortos.
  • Mueva el archivo a una carpeta que tenga un nombre de ruta de acceso más corto.

Solución alternativa 2: Acceso, apertura y reparación manuales

  1. Inicie Word, Excel o PowerPoint.

  2. En la pestaña Archivo, seleccione Abrir>Examinar para buscar el archivo dañado.

    Captura de pantalla del cuadro de diálogo de apertura.

  3. Seleccione el archivo, el menú Abrir en la parte inferior de la ventana y, después, Abrir y reparar.

    Captura de pantalla de la opción Abrir y reparar.

Esta opción repara los daños en el archivo y lo abre. Después de reparar el documento, el libro o la presentación, es importante comprobar que el problema se ha resuelto correctamente. Para ello, empiece a trabajar en el archivo y asegúrese de que todo funciona según lo esperado.

Solución alternativa 3: Cambiar el formato de archivo y volver a guardar

Es posible que pueda rescatar un archivo dañado si lo vuelve a guardar en otro formato de archivo y, luego, lo revierte al formato original. En este ejemplo se usa Word.

Paso 1: Guardar el archivo en otro formato

  1. Inicie Word.

  2. En el menú Archivo, seleccione Abrir y, después, busque y abra el archivo dañado.

  3. En el menú Archivo, seleccione Guardar como>Examinar.

  4. Vaya a la ubicación del archivo en la que desea guardarlo.

  5. En la lista Guardar como tipo, seleccione el formato deseado. Por ejemplo, seleccione Formato de texto enriquecido (*rtf).

    Captura de pantalla de la opción Guardar como.

  6. Seleccione Guardar y, después, Archivo>Cerrar.

Paso 2: Volver a guardar el archivo como documento de Word

  1. Seleccione Archivo>Abrir.

  2. Seleccione el nuevo archivo que se guarda como Archivo de texto enriquecido y luego seleccione Abrir.

  3. Seleccione Archivo>Guardar como.

  4. En la lista Guardar como tipo, seleccione Documento de Word.

  5. Cambie el nombre del archivo y, después, seleccione Guardar.

    Captura de pantalla de la opción Guardar una copia.

Solo tiene que hacerlo una vez para asegurarse de que el documento funcionará correctamente en el dispositivo. Sin embargo, tenga en cuenta que, al guardar el archivo como un documento nuevo, va a crear un archivo diferente. Para evitar confusiones, asigne al nuevo archivo un nombre distintivo y archive o elimine la versión dañada. Al hacerlo, no volverá a abrir por accidente el archivo original, que no ha cambiado de formato.

Solución alternativa 4: Abrir formato de archivo no reconocido

Si puede descartar que el error se deba a daños en los archivos, compruebe si hay asociaciones y formatos de archivo no reconocidos. A veces, un archivo no se abre porque el dispositivo en el que se creó utilizó un software que su dispositivo no tiene.

Por ejemplo, en Word, quiere ver un archivo PDF adjunto a un mensaje de correo electrónico. Sin embargo, no tiene instalado un visor de PDF. Por lo tanto, el dispositivo no sabe qué programa abrir para ver el archivo. En este caso, puede cambiar el formato del archivo para que coincida con un programa que sí tenga.

  1. Guarde el adjunto en su equipo. Para ello, seleccione la flecha abajo situada junto a los datos adjuntos en el mensaje y Guardar como, vaya a la ubicación deseada y, después, seleccione Guardar.

  2. En el menú Archivo, seleccione Abrir>Examinar para encontrar el archivo.

  3. Haga clic con el botón derecho en el archivo, seleccione Abrir con y seleccione otro programa para abrirlo.

  4. Si el programa deseado no está en la lista, seleccione Elegir otra aplicación para buscar otro programa.

    Nota:

    Si esto funciona y desea que el programa seleccionado siempre abra este tipo de archivo, seleccione la casilla Usar siempre esta aplicación para abrir los archivos .docx (por ejemplo). Captura de pantalla de la casilla Usar siempre esta aplicación para abrir los archivos .docx.

Para obtener más información sobre los formatos de archivo y cómo administrarlos, consulte Más información sobre los formatos de archivo.

Solución alternativa 5: Borrar espacio en disco

Es posible que no pueda abrir un archivo nuevo o guardarlo en el dispositivo si se está quedando sin espacio en el disco duro. En un disco lleno, gran parte del espacio lo ocupan elementos temporales, duplicados e innecesarios. El método más rápido y sencillo para liberar espacio en un disco duro es usar la aplicación Liberador de espacio en disco que se incluye en Windows.

  1. Seleccione Buscar y escriba Liberador de espacio en disco.

  2. En la lista de resultados, seleccione Liberador de espacio en disco.

    Captura de Liberador de espacio en disco.

  3. Se abre un cuadro de diálogo y proporciona opciones para eliminar los archivos innecesarios. Seleccione la casilla situada junto a cada categoría de elementos que desea eliminar del dispositivo y, después, Aceptar. Todo lo de esta lista se puede eliminar de forma segura.

    Captura de pantalla del Liberador de espacio en disco para el disco local (C:).

  4. Cuando se le pida, confirme que desea eliminar de forma permanente los archivos innecesarios.

    Captura de pantalla de la opción Eliminar archivos.

Los siguientes tipos de archivos son ejemplos de elementos extraíbles que puede ver en la lista del Liberador de espacio en disco:

  • Windows Update: archivos recientes descargados de Windows Update (al seleccionarlos, no se quitan las versiones de actualización instaladas en la actualidad)
  • Archivos de programa descargados: archivos de programa innecesarios, a menudo relacionados con la instalación del programa
  • Archivos temporales de Internet: archivos guardados automáticamente por los exploradores cuando visita sitios web
  • Informe de errores de Windows: archivos de informes de errores creados por el sistema
  • Papelera de reciclaje: cualquier archivo almacenado en la Papelera de reciclaje que no haya eliminado de forma manual
  • Archivos temporales: otros archivos temporales creados por programas o exploradores web
  • Historial de archivos de usuario: archivos que registran el historial de exploración (sitios web a los que ha accedido, resultados de búsqueda, etc.)

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