Recebe uma mensagem de erro quando tenta abrir um documento do Office.

Sintomas

Quando tenta abrir um ficheiro em qualquer programa do Microsoft Office listado na secção "Aplica-se a", recebe uma das seguintes mensagens de erro:

O nome de ficheiro não é válido.

Não foi possível aceder ao ficheiro.

O caminho que introduziu, "nome do ficheiro", é demasiado longo. Introduza um caminho mais curto.

não foi possível localizar o nome do ficheiro. Verifique a ortografia do nome do ficheiro e verifique se a localização do ficheiro está correta.

Ocorreu um erro DDE e não é possível apresentar uma descrição do erro porque é demasiado longo. Se o nome do ficheiro ou caminho for longo, experimente renomear o ficheiro ou copiá-lo para uma pasta diferente.

Captura de ecrã da mensagem de erro.

Nota

Este problema ocorre quando abre um ficheiro a partir de uma unidade mapeada, de um caminho UNC ou de um URL (endereço Web).

Causa

Este problema ocorre devido a um limite de carateres para criar e guardar ficheiros em produtos do Office. Este problema ocorre se o caminho do ficheiro que abre ou guarda cumprir com a seguinte condição:

  • Microsoft Word, Microsoft PowerPoint e Microsoft Access: o comprimento total do caminho e o nome do ficheiro, incluindo a extensão de nome de ficheiro, excedem os 259 carateres.

  • Microsoft Excel: o comprimento total do caminho e o nome de ficheiro, incluindo a extensão de nome de ficheiro, excedem os 218 carateres.

Nota

Este limite inclui os três carateres que representam a unidade, os carateres em nomes de pastas, carateres de barra invertida entre nomes de pastas e os carateres no próprio nome do ficheiro.

Solução

Para contornar este problema, tente uma das seguintes soluções.

Solução 1: reduza a contagem de carateres

  • Nomeie o ficheiro para que tenha um nome mais curto.
  • Nomeie uma ou mais pastas que contêm o ficheiro para que tenham nomes mais curtos.
  • Mova o ficheiro para uma pasta com um nome de caminho mais curto.

Solução 2: aceder, abrir e reparar manualmente

  1. Inicie o Word, Excel ou PowerPoint.

  2. No separador Ficheiro, selecione Abrir>Procurar para localizar o ficheiro danificado.

    Captura de ecrã a mostrar a abertura de uma caixa de diálogo.

  3. Selecione o ficheiro, selecione o menu Abrir na parte inferior da janela e, em seguida, selecione Abrir e Reparar.

    Captura de ecrã da opção Abrir e Reparar.

Esta opção repara os danos no ficheiro e, em seguida, abre o ficheiro. Depois de reparar o documento, livro ou apresentação, é importante verificar se o problema foi resolvido com êxito. Para o fazer, comece a trabalhar no ficheiro e certifique-se de que está tudo a funcionar conforme esperado.

Solução 3: alterar o formato de ficheiro e voltar a guardar

Poderá conseguir resgatar um ficheiro danificado ao salvá-lo num formato de ficheiro diferente e, em seguida, revertê-lo para o formato original. Este exemplo utiliza o Word.

Passo 1: guardar o ficheiro noutro formato

  1. Inicie o Word.

  2. No menu Ficheiro, selecione Abrir e, em seguida, localize e abra o ficheiro danificado.

  3. No menu Ficheiro, selecione Guardar como>Procurar.

  4. Navegue para a localização do ficheiro onde pretende guardar.

  5. Na lista Guardar como tipo, selecione um dos formatos desejados: Por exemplo, selecione Rich Text Format (*rtf).

    Captura de ecrã da opção Guardar Como.

  6. Selecione Guardar e selecione Ficheiro>Fechar.

Passo 2: guardar novamente o ficheiro como um documento do Word

  1. Selecione Ficheiro>Abrir.

  2. Selecione o novo ficheiro guardado como um Ficheiro rtf. Em seguida, selecione Abrir.

  3. Selecione Ficheiro>Guardar como.

  4. Na lista Guardar com, selecione Documento do Word.

  5. Renomeie o ficheiro e, em seguida, selecione Guardar.

    Captura de ecrã da opção Guardar uma Cópia.

Só tem de fazer isto uma vez para se certificar de que o documento irá funcionar corretamente no seu dispositivo. No entanto, tenha em atenção que, ao guardar o ficheiro como um novo documento, está a criar um ficheiro diferente. Para evitar confusões, renomeie o novo ficheiro e arquive ou elimine a versão danificada. Ao fazê-lo, não reabrirá acidentalmente o ficheiro original que não foi reformatado.

Solução 4: abrir formato de ficheiro não reconhecido

Se conseguir descartar a corrupção do ficheiro, verifique se existem associações de ficheiros e formatos de ficheiro não reconhecidos. Por vezes, um ficheiro não abre no seu dispositivo porque o dispositivo que o ficheiro foi criado no software utilizado que o seu dispositivo não tem.

Por exemplo, no Word, quer ver um ficheiro PDF anexado a uma mensagem de e-mail. No entanto, não tem um visualizador de PDF instalado. Por conseguinte, o seu dispositivo não sabe que programa abrir para ver o ficheiro. Neste caso, pode alterar o formato do ficheiro para corresponder ao programa que tem instalado.

  1. Guarde o anexo no seu computador. Para tal, selecione a seta para baixo junto ao anexo na mensagem, selecione Guardar como, navegue até à localização pretendida e, em seguida, selecione Guardar.

  2. No menu Ficheiro, selecione Abrir>Procurar para localizar o ficheiro.

  3. Clique com o botão direito do rato no ficheiro, aponte para Abrir com e, em seguida, selecione um programa diferente para abrir o ficheiro.

  4. Se o programa pretendido não estiver na lista, selecione "Escolher outra aplicação" para localizar um programa diferente.

    Nota

    Se isto funcionar e quiser que o programa selecionado abra sempre este tipo de ficheiro, selecione a caixa de verificação Utilizar sempre esta aplicação para abrir ficheiros .docx (por exemplo). Captura de ecrã da caixa de verificação Utilizar sempre esta aplicação para abrir .docx ficheiros.

Para obter mais informações sobre formatos de ficheiro e sobre como geri-los, consulte Saber mais sobre formatos de ficheiro.

Solução 5: Limpar algum espaço em disco

Poderá não conseguir abrir um novo ficheiro ou guardar um ficheiro no seu dispositivo se estiver a ficar sem espaço no disco rígido. Num disco cheio, a maior parte do espaço está a ser utilizada por itens temporários, duplicados e desnecessários. O método mais rápido e fácil de libertar espaço num disco rígido é utilizar a aplicação Limpeza do Disco incluída no Windows.

  1. Selecione Procurar e escreva Limpeza do Disco.

  2. Na lista de resultados, selecione Limpeza do Disco.

    Captura de ecrã da Limpeza do Disco.

  3. É aberta uma caixa de diálogo que fornece opções para eliminar ficheiros desnecessários. Selecione a caixa de verificação junto a cada categoria de itens que pretende eliminar do seu dispositivo e, em seguida, selecione OK. Todos os dados nesta lista podem ser eliminados em segurança.

    Captura de ecrã da Limpeza do Disco para Disco Local (C:).

  4. Quando lhe for pedido, confirme que pretende eliminar permanentemente os ficheiros desnecessários.

    Captura de ecrã da opção Eliminar Ficheiros.

Os seguintes tipos de ficheiro são exemplos de itens removíveis que poderá ver na lista Limpeza do Disco:

  • Windows Update: ficheiros recentes transferidos do Windows Update (selecionar estes ficheiros não remove as versões de atualização atualmente instaladas)
  • Ficheiros de Programas Transferidos: ficheiros de programa desnecessários, muitas vezes relacionados com a instalação do programa
  • Ficheiros temporários da Internet: ficheiros guardados automaticamente por browsers quando visita sites
  • Relatório de Erros do Windows: ficheiros de relatórios de erros criados pelo sistema
  • Reciclagem: todos os ficheiros que estão armazenados na Reciclagem que não eliminou manualmente
  • Ficheiros temporários: outros ficheiros temporários criados por programas ou browsers
  • Histórico de ficheiros de utilizador: ficheiros que gravam o seu histórico de navegação (sites a que acedeu, resultados da pesquisa, entre outros)

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