WD2000: Dokument s vloženým objektem stále výzvu k uložení i po nastavení vlastnosti uloženo

Překlady článku Překlady článku
ID článku: 325619 - Produkty, které se vztahují k tomuto článku.
Tento článek byl archivován. Je nabízen v takovém stavu, v jakém je, a nebude již nadále aktualizován.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Pokud vlastnost uložené v objektu Document je nastavena na hodnotu True v aplikaci Word, můžete Word zabránit zobrazení výzvy k uložení dokumentu, když dokument zavřete. K tomu dochází, i když upravit dokument. Pokud však dokument obsahuje vložené objekty (standardní objekty OLE nebo ActiveX Controls), zobrazí dialogové okno Uložit se i když vlastnost uložený na hodnotu True.

Příčina

Chování při upravit vložený objekt, ale nikoli uložit vložený objekt. Trvalá data objektu není uložena do dokumentu. Tento příznak "dirty" není vynulován False, při použití vlastnosti Document.Saved Word.

Řešení

K dispozici je podporovaná oprava hotfix od společnosti Microsoft. Tato oprava hotfix je však určena pouze k opravě problému popsanému v tomto článku. Použijte tuto opravu hotfix pouze u systémů, kde dochází k tomuto konkrétnímu problému.

Pokud je oprava hotfix k dispozici ke stažení, v horní části tohoto článku je sekce "Hotfix stažení k dispozici". Není-li tato část uvedena, vyžádejte si tuto opravu hotfix od oddělení služeb zákazníkům a podpory společnosti Microsoft.

Poznámka: Pokud vyskytnout další problémy nebo jakékoli řešení potíží je vyžadován, pravděpodobně budete muset vytvořit zvláštní požadavek na službu. Výdaje na technickou podporu se týkají dalších otázek a problémů, které nelze vyřešit pomocí této opravy konkrétní opravy hotfix. Navštivte následující web společnosti Microsoft pro získání telefonního čísla na Zákaznické centrum, nebo pokud chcete vytvořit samostatnou žádost o podporu:
http://support.microsoft.com/contactus/?ws=support
Poznámka: Zobrazí formulář "Hotfix stažení k dispozici" jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, oprava hotfix není k dispozici pro daný jazyk.Po instalaci opravy hotfix Anglická verze této opravy bude mít atributy souboru (nebo novější), které jsou uvedeny v následující tabulce. Data a časy jednotlivých souborů jsou uvedeny ve formátu UTC (Coordinated Universal Time). Pokud zobrazíte informace o souboru, bude převedena na místní čas. Rozdíl mezi místním ČASEM a najít, použijte kartu časové pásmo v ovládacím panelu Datum a čas.
   Date         Time   Size       File name
   ------------------------------------------------ 
   23-Nov-2002  14:50      1,804  Hotfix.txt 
   07-Nov-2002  19:20      2,962  Readme.txt 
   07-Nov-2002  19:05  3,667,096  Winword.msp 
   07-Nov-2002  19:41  4,684,436  Winword_admin.msp 
				
Anglická verze této opravy má následující atributy souborů nebo novější:
   Date         Time   Version     Size       File name
   ------------------------------------------------------
   02-Nov-2002  07:15  9.0.0.7031  8,826,932  Winword.exe
				

Poznámka: následující změny registru musí být provedena, aby tuto funkci povolit. Chcete-li provést změny registru, postupujte takto:
  1. Spusťte program Editor registru.
  2. Vyhledejte následující klíč registru a klikněte na něj:
    HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Word\Options
  3. V nabídce Úpravy klepněte na tlačítko Přidat hodnota a přidejte následující hodnotu registru:
    Název hodnoty: EnableSubDocPutSaved
    Typ dat: DWORD
    Hodnota dat: 0x00000001 (Povolit) nebo 0x00000000 (zakázat)
  4. Ukončete program Editor registru.
Upozornění: Použijete-li Editor registru nesprávně, můžete způsobit vážné problémy, které mohou vyžadovat přeinstalaci operačního systému. Společnost Microsoft nemůže zaručit, že potíže vzniklé v důsledku nesprávného použití Editoru registru budete moci vyřešit. Editor registru používáte na vlastní nebezpečí.

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny na začátku tohoto článku.

Další informace

Kroky pro reprodukci tohoto chování

  1. Spusťte aplikaci Microsoft Word.
  2. Zadejte řádek textu a stiskněte klávesu ENTER dvakrát.
  3. V nabídce Vložit klepněte na příkaz objekt.
  4. Na kartě Nový klepněte na položku Microsoft Excel Worksheet ze seznamu typů objektů.
  5. Klepněte na tlačítko OK objekt vložit.
  6. Zadejte hodnotu v buňce A1 vložený list a potom klepněte mimo list Excel dezaktivovat.
  7. Stiskněte klávesy ALT + F11 přístup Visual Basic for Applications (VBA) editoru.
  8. V nabídce Vložit klepněte na modul vložit nový modul.
  9. Nového modulu vložte následující kód:
    Sub SetSaved()
      Application.ActiveDocument.Saved = True
    End Sub
    					
  10. Zavřete VBA editor.
  11. V nabídce soubor klepněte na tlačítko Uložit.
  12. Uložte soubor jako C:\Test.doc.
  13. V nabídce soubor klepněte na tlačítko Zavřít zavřete dokument.
  14. V nabídce soubor klepněte na příkaz Otevřít dokument znovu otevřete.
  15. Poklepejte na listu a vložit hodnotu v buňce B1.
  16. Klepněte mimo listu jej deaktivovat.
  17. V nabídce Nástroje klepněte na příkaz makro a potom klepněte na příkaz makra....
  18. Klepnutím vyberte SetSaved a potom klepněte na příkaz Spustit makro Spustit.
  19. V nabídce soubor klepněte na tlačítko Zavřít zavřete dokument.

    Všimněte si, že budete vyzváni k uložení dokumentu.

Vlastnosti

ID článku: 325619 - Poslední aktualizace: 29. ledna 2014 - Revize: 3.2
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Word 2000 Standard Edition
Klíčová slova: 
kbnosurvey kbarchive kbmt kbautohotfix kbqfe kbhotfixserver kbbug kbfix KB325619 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:325619

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com