WD2000: continue de document avec un objet incorporé à choisir Enregistrer même après jeu enregistré, propriété

Traductions disponibles Traductions disponibles
Numéro d'article: 325619 - Voir les produits auxquels s'applique cet article
Cet article a été archivé. Il est proposé « en l'état » et ne sera plus mis à jour.
Agrandir tout | Réduire tout

Sommaire

Symptômes

Si la propriété Saved sur l'objet document est définie sur True dans Microsoft Word, vous pouvez empêcher Word de vous invitant à enregistrer le document lorsque vous fermez le document. Cela se produit même si vous modifiez le document. Toutefois, si le document contient des objets incorporés (objets OLE standard ou des contrôles ActiveX), la boîte de dialogue Enregistrer s'affiche même si vous définissez la propriété Saved sur True .

Cause

Ce problème se produit lorsque vous modifiez l'objet incorporé mais ne pas enregistrez l'objet incorporé. Les données persistantes de l'objet sont non enregistrées dans le document. Cet indicateur « sale n'est pas réinitialisé sur la valeur False lorsque vous utilisez la propriété Document.Saved de Word.

Résolution

Un correctif est disponible auprès de Microsoft. Toutefois, ce correctif est conçu pour corriger le problème décrit dans cet article. Appliquer ce correctif uniquement aux systèmes rencontrant ce problème spécifique.

Si le correctif est disponible pour le téléchargement, il est une section « téléchargement correctif disponible » en haut de cet article de la base de connaissances. Si cette section n'apparaît pas, soumettez une demande à Microsoft client service et support pour obtenir le correctif.

note Si des problèmes supplémentaires se produisent ou si n'importe quel dépannage est nécessaire, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux autres questions et problèmes non traités par ce correctif spécifique. Pour une liste complète des Microsoft client service et support numéros de téléphone ou pour créer une demande de service distincte, reportez-vous au site de Web Microsoft suivant :
http://support.microsoft.com/contactus/?ws=support
note L'écran de « téléchargement correctif disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas la langue, il est car un correctif logiciel n'est pas disponible pour cette langue. Une fois le correctif installé, la version anglaise de ce correctif va avoir les attributs de fichier (ou version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont exprimées en coordinated universal temps (UTC). Lorsque vous affichez les informations de fichier, il est convertie en heure locale. Pour connaître le décalage entre l'heure UTC et l'heure locale, utilisez l'onglet Fuseau horaire dans l'outil Date et heure du Panneau de configuration.
   Date         Time   Size       File name
   ------------------------------------------------ 
   23-Nov-2002  14:50      1,804  Hotfix.txt 
   07-Nov-2002  19:20      2,962  Readme.txt 
   07-Nov-2002  19:05  3,667,096  Winword.msp 
   07-Nov-2002  19:41  4,684,436  Winword_admin.msp 
				
La version anglaise de ce correctif doit avoir les attributs de fichier suivants ou ceux d'une version ultérieure :
   Date         Time   Version     Size       File name
   ------------------------------------------------------
   02-Nov-2002  07:15  9.0.0.7031  8,826,932  Winword.exe
				

Remarque : les modifications du Registre suivantes doivent être apportées à activer cette fonctionnalité. Pour apporter les modifications du Registre, procédez comme suit :
  1. Démarrez l'Éditeur du Registre.
  2. Recherchez et cliquez ensuite la clé de Registre suivante :
    HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Word\Options
  3. Dans le menu Edition , cliquez sur Ajouter valeur puis ajoutez la valeur de Registre suivantes :
    Nom de la valeur : EnableSubDocPutSaved
    Type de données : DWORD
    Valeur de données : 0 x 00000001 (activer) ou 0 x 00000000 (désactiver)
  4. Quittez l'Éditeur du Registre.
Avertissement : Si vous utilisez l'Éditeur du Registre de façon incorrecte, vous pouvez générer des graves problèmes pouvant vous obliger à réinstaller votre système d'exploitation. Microsoft ne peut pas garantit que vous pouvez résoudre les problèmes résultant de l'utilisation incorrecte de l'Éditeur du Registre. Utilisez l'Éditeur du Registre à vos risques et périls.

Statut

Microsoft a confirmé que c'est un problème dans les produits Microsoft répertoriés au début de cet article.

Plus d'informations

Procédure pour reproduire le comportement

  1. Démarrez Microsoft Word.
  2. Tapez une ligne de texte, puis appuyez sur ENTRÉE deux fois.
  3. Dans le menu Insertion , cliquez sur objet .
  4. Sous l'onglet Créer , cliquez sur feuille de calcul Microsoft Excel dans la liste des types d'objet.
  5. Cliquez sur OK pour insérer l'objet.
  6. Tapez une valeur dans la cellule A1 de la feuille de calcul incorporée et cliquez sur en dehors de la feuille de calcul pour désactiver Excel.
  7. Appuyez sur ALT + F11 pour accéder à Visual Basic pour Applications (VBA) éditeur.
  8. Dans le menu Insertion , cliquez sur module pour insérer un nouveau module.
  9. Collez le code suivant dans le nouveau module :
    Sub SetSaved()
      Application.ActiveDocument.Saved = True
    End Sub
    					
  10. Fermez l'éditeur VBA.
  11. Dans le menu Fichier , cliquez sur Enregistrer .
  12. Enregistrez le fichier en tant que C:\Test.doc .
  13. Dans le menu Fichier , cliquez sur Fermer pour fermer le document.
  14. Dans le menu Fichier , cliquez sur Ouvrir pour rouvrir le document.
  15. Double-cliquez sur la feuille de calcul, puis insérer une valeur dans la cellule B1.
  16. Cliquez en dehors de la feuille de calcul à désactiver.
  17. Dans le menu Outils , cliquez sur macro , puis cliquez sur macros... .
  18. Cliquez pour sélectionner SetSaved et puis cliquez sur Exécuter pour exécuter la macro.
  19. Dans le menu Fichier , cliquez sur Fermer pour fermer le document.

    Notez que vous êtes invité à enregistrer le document.

Propriétés

Numéro d'article: 325619 - Dernière mise à jour: vendredi 24 janvier 2014 - Version: 3.2
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Word 2000 Standard Edition
Mots-clés : 
kbnosurvey kbarchive kbmt kbautohotfix kbqfe kbhotfixserver kbbug kbfix KB325619 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 325619
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com