WD2000: Documento do Word com um objecto incorporado continua a pedir para guardar mesmo depois de definir guardada propriedade

Traduções de Artigos Traduções de Artigos
Artigo: 325619 - Ver produtos para os quais este artigo se aplica.
Este artigo foi arquivado. Este artigo é oferecido "tal como está" e deixará de ser actualizado.
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

Se a propriedade guardado no objecto de documento é definida como true no Microsoft Word, pode impedir que o Word pedir para guardar o documento quando fechar o documento. Isto ocorre mesmo se modificar o documento. No entanto, se o documento contiver objectos incorporados (objectos OLE padrão ou controlos ActiveX), a caixa de diálogo Guardar aparece mesmo que defina a propriedade guardado como true .

Causa

Este comportamento ocorre quando modificar o objecto incorporado, mas não guarde o objecto incorporado. Os dados persistentes do objecto não são guardados no documento. Este sinalizador "danificada" não é reposto como false quando utiliza a propriedade Document.Saved do Word.

Resolução

Está disponível a partir da Microsoft uma correcção suportada. No entanto, esta correcção destina-se a corrigir o problema descrito neste artigo. Aplique esta correcção apenas em sistemas que tenham este problema específico.

Se a correcção está disponível para transferência, existe uma secção "denominada transferência de correcção disponível" na parte superior deste artigo da base de dados de conhecimento. Se esta secção não for apresentada, submeta um pedido para o serviço de cliente do Microsoft e suporte para obter a correcção.

Nota Se ocorram problemas adicionais ou se for necessária qualquer resolução de problemas, poderá ter de criar um pedido de assistência separado. Os custos normais do suporte serão aplicados a problemas adicionais e questões de suporte que não se enquadrem esta correcção específica. Para obter uma lista completa dos números de telefone do suporte de cliente do Microsoft ou para criar um pedido serviço separado, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota O formulário "Transferência de correcção disponível" apresenta os idiomas para a qual a correcção está disponível. Se não vir o idioma, é porque uma correcção não está disponível para esse idioma.Depois de instalada a correcção, a versão inglesa desta correcção terá os atributos de ficheiro (ou posteriores) listados na seguinte tabela. As datas e horas destes ficheiros são indicadas no formato de universal hora (UTC) coordenada Coordinated. Quando visualiza as informações do ficheiro, é convertido para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize o separador fuso horário na ferramenta Data e hora no painel de controlo.
   Date         Time   Size       File name
   ------------------------------------------------ 
   23-Nov-2002  14:50      1,804  Hotfix.txt 
   07-Nov-2002  19:20      2,962  Readme.txt 
   07-Nov-2002  19:05  3,667,096  Winword.msp 
   07-Nov-2002  19:41  4,684,436  Winword_admin.msp 
				
A versão inglesa desta correcção deverá ter os seguintes atributos de ficheiro ou posteriores:
   Date         Time   Version     Size       File name
   ------------------------------------------------------
   02-Nov-2002  07:15  9.0.0.7031  8,826,932  Winword.exe
				

Nota : deverão ser efectuadas as seguintes alterações de registo para activar esta funcionalidade. Alterações do registo, siga estes passos:
  1. Inicie o Editor de registo.
  2. Localize e, em seguida, clique a seguinte chave no registo:
    HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Word\Options
  3. No menu Editar , clique em Adicionar valor e, em seguida, adicione o seguinte valor de registo:
    Nome do valor: EnableSubDocPutSaved
    Tipo de dados: DWORD
    Dados do valor: 0 x 00000001 (activar) ou 0 x 00000000 (desactivar)
  4. Saia do Editor de registo.
aviso : a utilização incorrecta do Editor de registo poderá provocar problemas graves que poderão forçar a reinstalação do sistema operativo. Microsoft não garante que os problemas resultantes da utilização incorrecta do Editor de registo possam ser resolvidos. As suas próprias risco da utilização do Editor de registo.

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados no início deste artigo.

Mais Informação

Passos para reproduzir o comportamento

  1. Inicie o Microsoft Word.
  2. Escreva uma linha de texto e, em seguida, prima ENTER duas vezes.
  3. No menu Inserir , clique em ' objecto '.
  4. No separador Criar novo , clique em Folha de cálculo do Microsoft Excel da lista de tipos de objecto.
  5. Clique em ' OK ' para inserir o objecto.
  6. Escreva um valor na célula A1 da folha de cálculo incorporada e, em seguida, clique fora da folha de cálculo a desactivar o Excel.
  7. Prima ALT+F11 para aceder o Visual Basic for Applications (VBA) editor.
  8. No menu Inserir , clique em módulo para inserir um novo módulo.
  9. Cole o seguinte código no novo módulo:
    Sub SetSaved()
      Application.ActiveDocument.Saved = True
    End Sub
    					
  10. Feche o editor de VBA.
  11. No menu ficheiro , clique em Guardar .
  12. Guarde o ficheiro como C:\Test.doc .
  13. No menu ficheiro , clique em Fechar para fechar o documento.
  14. No menu ficheiro , clique em Abrir para reabrir o documento.
  15. Faça duplo clique sobre a folha de cálculo e, em seguida, coloque um valor na célula B1.
  16. Clique fora da folha de cálculo a desactivá-lo.
  17. No menu Ferramentas , clique em ' macro ' e clique em macros... .
  18. Clique para seleccionar SetSaved e em seguida, clique em Executar para executar a macro.
  19. No menu ficheiro , clique em Fechar para fechar o documento.

    Repare que lhe for pedido para guardar o documento.

Propriedades

Artigo: 325619 - Última revisão: 11 de fevereiro de 2014 - Revisão: 3.2
A informação contida neste artigo aplica-se a:
  • Microsoft Word 2000 Standard Edition
Palavras-chave: 
kbnosurvey kbarchive kbmt kbautohotfix kbqfe kbhotfixserver kbbug kbfix KB325619 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 325619

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com