WD2000: Documento com um objeto incorporado continua a escolher salvar mesmo após você definir salva propriedade

Traduções deste artigo Traduções deste artigo
ID do artigo: 325619 - Exibir os produtos aos quais esse artigo se aplica.
Este artigo foi arquivado. É oferecido "como está" e não será mais atualizado.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Se a propriedade Saved no objeto de documento é definida como True no Microsoft Word, você pode impedir que o Word solicitando que você salvar o documento quando você fechar o documento. Isso ocorre mesmo se você modificar o documento. No entanto, se o documento contiver objetos incorporados (padrão objetos OLE ou controles ActiveX), a caixa de diálogo Salvar será exibida mesmo se você definir a propriedade Saved como True .

Causa

Esse comportamento ocorre quando você modifica o objeto incorporado, mas não salve o objeto incorporado. Os dados persistentes do objeto não é salvo no documento. Este sinalizador "sujo" não é redefinido para False quando você usa a propriedade Document.Saved do Word.

Resolução

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibido, envie uma solicitação para suporte e atendimento ao cliente Microsoft para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.Depois que o hotfix for instalado, a versão em inglês dessa correção apresenta os atributos de arquivo (ou posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas na acordo hora universal coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário na ferramenta Data e hora no painel de controle.
   Date         Time   Size       File name
   ------------------------------------------------ 
   23-Nov-2002  14:50      1,804  Hotfix.txt 
   07-Nov-2002  19:20      2,962  Readme.txt 
   07-Nov-2002  19:05  3,667,096  Winword.msp 
   07-Nov-2002  19:41  4,684,436  Winword_admin.msp 
				
A versão em inglês dessa correção deve ter os seguintes atributos de arquivo ou posteriores:
   Date         Time   Version     Size       File name
   ------------------------------------------------------
   02-Nov-2002  07:15  9.0.0.7031  8,826,932  Winword.exe
				

Observação : devem ser feitas as seguintes alterações de registro para habilitar essa funcionalidade. Para fazer as alterações do Registro, execute estas etapas:
  1. Inicie o Editor do Registro.
  2. Localize e, em seguida, clique na seguinte chave no Registro:
    HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Word\Options
  3. No menu Editar , clique em Adicionar valor e adicione o seguinte valor do Registro:
    Nome do valor: EnableSubDocPutSaved
    Tipo de dados: DWORD
    Dados do valor: 0 x 00000001 (ativar) ou 0 x 00000000 (desativar)
  4. Feche o Editor do Registro.
Aviso : se você usar o Editor do Registro incorretamente, poderá causar problemas sérios que talvez exijam a reinstalação do sistema operacional. A Microsoft não garante que você pode resolver problemas resultantes do uso incorreto do Editor do Registro. Use o Editor do registro por sua própria conta e risco.

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados no começo deste artigo.

Mais Informações

Passos para reproduzir o problema

  1. Inicie o Microsoft Word.
  2. Digite uma linha de texto e, em seguida, pressione ENTER duas vezes.
  3. No menu Inserir , clique em objeto .
  4. Na guia Criar novo , clique em Planilha do Microsoft Excel da lista de tipos de objeto.
  5. Clique em OK para inserir o objeto.
  6. Digite um valor na célula A1 da planilha incorporada e, em seguida, clique fora a planilha para desativar o Excel.
  7. Pressione ALT + F11 para acessar o Visual Basic for Applications (VBA) editor.
  8. No menu Inserir , clique em módulo para inserir um novo módulo.
  9. Cole o seguinte código no novo módulo:
    Sub SetSaved()
      Application.ActiveDocument.Saved = True
    End Sub
    					
  10. Feche o editor do VBA.
  11. No menu arquivo , clique em Salvar .
  12. Salve o arquivo como C:\test.doc .
  13. No menu arquivo , clique em Fechar para fechar o documento.
  14. No menu arquivo , clique em Abrir para reabrir o documento.
  15. Clique duas vezes na planilha e, em seguida, colocar um valor na célula B1.
  16. Clique fora da planilha a desativá-lo.
  17. No menu Ferramentas , clique em macro e clique em macros... .
  18. Clique para selecionar SetSaved e clique em Executar para executar a macro.
  19. No menu arquivo , clique em Fechar para fechar o documento.

    Observe que você precisará salvar o documento.

Propriedades

ID do artigo: 325619 - Última revisão: sábado, 26 de outubro de 2013 - Revisão: 3.2
A informação contida neste artigo aplica-se a:
  • Microsoft Word 2000 Standard Edition
Palavras-chave: 
kbnosurvey kbarchive kbmt kbautohotfix kbqfe kbhotfixserver kbbug kbfix KB325619 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 325619

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com