User Context May Not Have Sufficient Access Rights When You Use the LogonUser Property

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Article ID: 325804 - View products that this article applies to.
This article was previously published under Q325804
- Windows 2000 - Windows XP
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SYMPTOMS

When you use the LogonUser property for one user context to perform a certain function, and then you use the LogonUser property for a different user context to perform another function, the second user context may not have sufficient access rights to complete the second function. For example, if you use the LogonUser property for one user context to deploy software to a computer, and then you use the LogonUser property for a different user context to access network resources, the second user context may not have sufficient access rights to access the network resources.

For more information about the LogonUser property, visit the following Microsoft Web site:
http://msdn2.microsoft.com/en-us/library/aa369780.aspx

CAUSE

This problem may occur when you use the Logon32_Logon_New_Credentials logon type.

Note The Logon32_Logon_New_Credentials logon type allows the caller to clone its current token and to specify new credentials for outbound connections. The new logon session has the same local identity, but the new logon session uses different credentials for other network connections. This logon type is supported only by the Logon32_Provider_Winnt50 logon provider.

RESOLUTION

Windows XP

Service Pack Information

To resolve this problem, obtain the latest service pack for Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to Obtain the Latest Windows XP Service Pack

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows XP Home Edition and Windows XP Professional Edition

   Date         Time   Version      Size     File name
   ------------------------------------------------------
   05-Jul-2002  15:27  5.1.2600.48  557,056  Advapi32.dll     
   05-Jul-2002  15:27  5.1.2600.48  654,336  Lsasrv.dll       
   05-Jul-2002  15:27  5.1.2600.48   50,176  Secur32.dll
				

Windows XP 64-bit Edition

   Date         Time   Version      Size       File name      Platform
   -------------------------------------------------------------------
   05-Jul-2002  15:27  5.1.2600.48  1,560,576  Advapi32.dll   IA64
   05-Jul-2002  15:27  5.1.2600.48  2,083,328  Lsasrv.dll     IA64
   05-Jul-2002  15:27  5.1.2600.48    169,472  Secur32.dll    IA64
   05-Jul-2002  15:15  5.1.2600.48    557,056  Wadvapi32.dll  X86
   05-Jul-2002  15:16  5.1.2600.48     52,736  Wsecur32.dll   X86
				

Windows 2000

Service Pack Information

To resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
260910 How to Obtain the Latest Windows 2000 Service Pack

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size       File name
   -------------------------------------------------------------------------
   27-Sep-2002  20:24  5.0.2195.6069    124,176  Adsldp.dll       
   27-Sep-2002  20:24  5.0.2195.5781    131,344  Adsldpc.dll      
   27-Sep-2002  20:24  5.0.2195.5781     62,736  Adsmsext.dll     
   27-Sep-2002  20:24  5.0.2195.6052    358,160  Advapi32.dll     
   27-Sep-2002  20:24  5.0.2195.5265     42,256  Basesrv.dll      
   27-Sep-2002  20:24  5.0.2195.6058     49,424  Browser.dll      
   27-Sep-2002  20:24  5.0.2195.6012    135,952  Dnsapi.dll       
   27-Sep-2002  20:24  5.0.2195.6012     96,016  Dnsrslvr.dll     
   27-Sep-2002  20:24  5.0.2195.5722     45,328  Eventlog.dll     
   27-Sep-2002  20:24  5.0.2195.5907    222,992  Gdi32.dll        
   27-Sep-2002  20:24  5.0.2195.6059    146,704  Kdcsvc.dll       
   05-Sep-2002  22:18  5.0.2195.6048    200,976  Kerberos.dll     
   27-Sep-2002  20:24  5.0.2195.6011    708,880  Kernel32.dll     
   21-Aug-2002  13:27  5.0.2195.6023     71,248  Ksecdd.sys
   25-Sep-2002  23:01  5.0.2195.6072    507,664  Lsasrv.dll       
   25-Sep-2002  23:01  5.0.2195.6072     33,552  Lsass.exe        
   27-Sep-2002  20:24  5.0.2195.4733    332,560  Msgina.dll       
   27-Aug-2002  19:53  5.0.2195.6034    108,816  Msv1_0.dll       
   27-Sep-2002  20:24  5.0.2195.5979    307,472  Netapi32.dll     
   27-Sep-2002  20:24  5.0.2195.5966    360,720  Netlogon.dll     
   27-Sep-2002  20:24  5.0.2195.6048    918,800  Ntdsa.dll        
   27-Sep-2002  20:24  5.0.2195.6025    389,392  Samsrv.dll       
   27-Sep-2002  20:24  5.0.2195.5951    129,296  Scecli.dll       
   27-Sep-2002  20:24  5.0.2195.5951    302,864  Scesrv.dll       
   27-Sep-2002  20:24  5.0.2195.6048     46,864  Secur32.dll      
   10-Sep-2002  12:50  5.0.2195.6053    123,392  Sp3res.dll       
   13-Jun-2001  02:05  5.0.2195.3727      3,856  Svcpack1.dll     
   27-Sep-2002  20:24  5.0.2195.6063    380,176  User32.dll       
   27-Sep-2002  20:24  5.0.2195.5968    369,936  Userenv.dll      
   27-Sep-2002  20:24  5.0.2195.5859     48,912  W32time.dll      
   04-Jun-2002  18:32  5.0.2195.5859     57,104  W32tm.exe        
   25-Sep-2002  15:04  5.0.2195.6070  1,642,512  Win32k.sys
   12-Sep-2002  16:50  5.0.2195.6056    179,472  Winlogon.exe     
   27-Sep-2002  20:24  5.0.2195.5935    243,472  Winsrv.dll       
   27-Sep-2002  20:24  5.0.2195.6052    126,224  Wldap32.dll      
   25-Sep-2002  23:01  5.0.2195.6072    507,664  Lsasrv.dll    56-bit
   27-Sep-2002  20:24  5.0.2195.6011    708,880  Kernel32.dll  Uni-processor
   27-Sep-2002  20:24  5.0.2195.6070  1,642,512  Win32k.sys    Uni-processor
   27-Sep-2002  20:24  5.0.2195.5935    243,472  Winsrv.dll    Uni-processor
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Windows XP

This problem was first corrected in Windows XP Service Pack 1.

Windows 2000

This problem was first corrected in Windows 2000 Service Pack 4.

Properties

Article ID: 325804 - Last Review: March 22, 2007 - Revision: 1.9
APPLIES TO
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbwin2ksp4fix kbqfe kbbug kbfix kbsecurity kbwin2000presp4fix kbwinxpsp1fix KB325804

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