CSNW でネットワーク上のファイルを開くときに遅延が発生する

文書翻訳 文書翻訳
文書番号: 326903 - 対象製品
この記事は、以前は次の ID で公開されていました: JP326903
重要 : この資料には、レジストリの編集方法が記載されています。万一に備えて、編集の前には必ずシステムの復元方法を理解しておいてください。バックアップ、復元、および編集方法の詳細については、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
256986 Microsoft Windows レジストリの説明
すべて展開する | すべて折りたたむ

現象

Client Services for NetWare (CSNW) で Microsoft Office のファイルを開くときに、遅延が発生する場合があります。この問題は通常、NetWare ベースのサーバー上でファイルを開くときに発生します。

原因

この問題が発生するのは、CSNW でプリンタ名、サーバー名、オブジェクト プロパティの解決が絶えず行われるためです。これにより、パフォーマンスが低下します。クエリを実行するクライアントが増えるほど、問題はより顕著になります。

解決方法

この問題を解決するには、Windows XP の最新の Service Pack を入手します。関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
322389 最新の Windows XP Service Pack を入手する方法
修正プログラムのファイル属性は次表のとおりです。ただし、これより新しい修正プログラムがリリースされている可能性もあります。各ファイルの日付および時刻は、世界協定時刻 (UTC) で示されています。ファイル情報に表示される時刻は、ローカル時刻に変換されています。UTC とローカル時刻との時差を確認するには、コントロール パネルの [日付と時刻] の [タイム ゾーン] タブを使用してください。
日付         時刻     バージョン        サイズ      ファイル名
   ---------------------------------------------------
   29-Aug-2002  01:21  5.1.2600.1106  156,544  Nwrdr.sys

状況

マイクロソフトでは、この問題をこの資料の冒頭に記載したマイクロソフト製品の問題として認識しています。 この問題は、Windows XP Service Pack 1 で修正済みです。

詳細

警告 : レジストリ エディタの使い方を誤ると、深刻な問題が発生することがあります。最悪の場合、オペレーティング システムの再インストールが必要になることがあります。マイクロソフトは、レジストリ エディタの誤用により発生した問題に関しては、一切責任を負わないものとします。レジストリ エディタは、自己の責任においてご使用ください。

次のレジストリ キーの 2 つの値を変更できます。
HKEY_LOCAL_MACHINE\SYSTEMCurrentControlSet\Services\NwRdr\Parameters
NdsObjectCacheSize の値を、接続するリソースの数に応じて調整します。
値 : NdsObjectCacheSize
型 : REG_DWORD
データ : キャッシュ対象のオブジェクト数
最小 : 0x0
最大 : 0x80
既定値 : 0x0
NdsObjectCacheTimeout の値を、リソースが変更される頻度に応じて設定します。10 の値から始めます。
値 : NdsObjectCacheTimeout
型 : REG_DWORD
データ : エントリが有効になる秒数
最小 : 0x0
最大 : 0x258
既定値 : 0xa

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 326903 (最終更新日 2002-09-10) をもとに作成したものです。

プロパティ

文書番号: 326903 - 最終更新日: 2006年3月24日 - リビジョン: 1.1
この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
キーワード:?
kbhotfixserver kbbug kbfix kbnetwork kbwinxpsp1fix KB326903
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com