오류 메시지: Windows has detected that one or more protected core system files (kernel) on your computer have been modified

기술 자료 번역 기술 자료 번역
기술 자료: 327101 - 이 문서가 적용되는 제품 보기.
모두 확대 | 모두 축소

현상

Windows XP 서비스 팩 1 또는 서비스 팩 2(SP1 또는 SP2)를 설치하려고 하면 다음과 같은 오류 메시지가 나타날 수 있습니다.
Windows has detected that one or more protected core system files (kernel) on your computer have been modified. The Service Pack contains updated versions of those files, which work to provide a stable environment for your programs. Due to this modification, the Service Pack will not be installed. For more information, see Knowledge Base article Q327101 at http://support.microsoft.com.

원인

이 문제는 Boot.ini 파일에서 /KERNEL 스위치를 사용하는 수정된 버전의 Ntoskrnl.exe 파일이 컴퓨터에 있는 경우에 발생합니다. 컴퓨터 시작 시 표시되는 그래픽을 사용자 지정하는 타사 프로그램이 컴퓨터에 설치되어 있기 때문에 이러한 상황이 발생할 수 있습니다. 이러한 문제가 발생할 수 있는 타사 프로그램은 다음과 같습니다.
  • BootXP
  • LogonUI Boot Randomizer

해결 방법

이 문제를 해결하려면 다음과 같이 하십시오.
  1. 확인을 눌러 오류 메시지를 닫습니다.
  2. 시작, 실행을 차례로 누른 다음 열기 상자에 appwiz.cpl을 입력합니다.
  3. 시작 그래픽을 사용자 지정하는 프로그램을 누른 다음 제거를 누릅니다.
  4. 컴퓨터를 다시 시작한 다음 서비스 팩을 다시 설치해 봅니다. 문제가 계속되면 5단계로 진행합니다.
  5. 바탕 화면에서 내 컴퓨터를 마우스 오른쪽 단추로 누른 다음 속성을 누릅니다.
  6. 고급 탭을 누른 다음 시작 및 복구에서 설정을 누릅니다.
  7. 시스템 시작에서 편집을 누릅니다.

    Boot.ini 파일이 메모장에서 열립니다.
  8. /KERNEL= 스위치를 찾아 삭제합니다.
  9. Boot.ini 파일을 저장한 다음 닫습니다.
  10. 컴퓨터를 다시 시작합니다.
  11. Windows XP 서비스 팩을 설치해 봅니다.
참고 해당 단계를 완료하여 문제를 해결하면 서비스 팩이 올바르게 설치됩니다. 그러나 수정된 Ntoskrnl.exe 파일이 실행 중인 상태에서 서비스 팩을 설치하려고 하면 서비스 팩 설치 프로그램이 수정된 Ntoskrnl.exe 파일을 업데이트된 버전으로 대체할 것이라는 내용의 메시지가 나타날 수 있습니다.

현재 상태

이것은 의도적으로 설계된 동작입니다.

추가 정보

이 문제에 대한 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
327120 오류 메시지: Windows Service Pack 1 Has Detected That One or More Protected Core System Files on Your Computer Have Been Modified
이 문서에 나와 있는 다른 공급업체 제품은 Microsoft와 무관한 회사에서 제조한 것입니다. Microsoft는 이들 제품의 성능이나 신뢰성에 관하여 명시적이든 묵시적이든 어떠한 보증도 하지 않습니다.
현상 절에 나와 있는 오류는 Windows XP SP2를 설치하려고 할 때도 발생합니다.



Microsoft 제품 관련 기술 전문가들과 온라인으로 정보를 교환하시려면 Microsoft 뉴스 그룹에 참여하시기 바랍니다.

속성

기술 자료: 327101 - 마지막 검토: 2005년 3월 17일 목요일 - 수정: 3.3
본 문서의 정보는 다음의 제품에 적용됩니다.
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
키워드:?
kberrmsg kbbug kbnofix kbenv KB327101

피드백 보내기

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com