Article ID: 327124 - Last Review: October 27, 2006 - Revision: 1.6

HTTP 500 or HTTP 403 error when requests are sent to Exchange 2000 Server

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SYMPTOMS

When a request is sent to Exchange 2000, you may experience any of the following symptoms:
  • If a request is sent for .asp items that are located on the Exchange 2000 server, you receive an HTTP 500 error.
  • When a request is sent for Exwform.dll Internet Server Application Programming Interface (ISAPI)-rendered requests, you receive an HTTP 403 "forbidden" error.
  • You may receive a message that says you have received an HTTP 500 error.
  • You may receive an error message that is similar to the following error message:
    The operation has failed.

CAUSE

This problem occurs because the URL handling code is allocated memory off the stack. Each thread is given a fixed stack size to work with. If the stack size is exceeded, an exception occurs that causes the operation to fail.

RESOLUTION

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
  Date         Time   Version            Size    File name
   --------------------------------------------------------------
   26-Jul-2002  06:30  6.0.6304.0        675,840  Davex.dll        
			
Note Because of file dependencies, this update requires Exchange 2000 Server Service Pack 3 (SP3). For more information, click the following article number to view the article in the Microsoft Knowledge Base:
301378  (http://support.microsoft.com/kb/301378/ ) How to obtain the latest Exchange 2000 Server service pack

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

APPLIES TO
  • Microsoft Exchange 2000 Server Standard Edition
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbfix kbexchange2000presp4fix kbbug KB327124
 

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