Artigo: 327153 - Última revisão: terça-feira, 26 de Dezembro de 2006 - Revisão: 2.2

PROBLEMA: As páginas ASP não processam e evento de DCOM 10010 aparece no registo de eventos do sistema

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Expandir tudo | Reduzir tudo

Sintomas

Quando tenta navegar em páginas ASP (Active Server Pages), poderá receber a seguinte mensagem de erro no browser:
HTTP 500 - Erro interno do servidor
Se desmarcar a caixa de verificação Mostrar amigável mensagens de erro HTTP no browser, receberá a seguinte mensagem de erro no browser:
Erro de aplicação de servidor
O servidor encontrou um erro ao carregar uma aplicação durante o processamento do pedido. Consulte o registo de eventos para obter informações mais detalhadas. Contacte o administrador do servidor para obter assistência
Receberá uma mensagem de erro se o seguinte no registo de eventos do sistema:
Origem: DCOM
ID do evento: 10010
Utilizador: NT AUTHORITY\SYSTEM
Descrição: O servidor {3D14228D-FBE1-D 0-D-00C04FD919C1} não foi registado no DCOM dentro do tempo de espera requerido.
Esta mensagem de erro é seguida no registo de eventos de uma mensagem de aviso é semelhante a um dos seguintes procedimentos:
Origem: W3SVC
ID do evento: 36
Utilizador: N/d
Descrição: O servidor não conseguiu carregar a aplicação ' CaminhoAplic '. O erro foi 'Execução no servidor falhou'.

Origem: W3SVC
ID do evento: 36
Utilizador: N/d
Descrição: O servidor não conseguiu carregar a aplicação '/ LM/W3SVC/1/ROOT/<vdir>'. O erro foi 'Execução no servidor falhou'

Origem: W3SVC
ID do evento: 36
Utilizador: N/d
Descrição: O servidor não conseguiu carregar a aplicação '/ LM/W3SVC/1/ROOT'. O erro foi 'Execução no servidor falhou'.

Origem: W3SVC
ID do evento: 36
Utilizador: N/d
Descrição: O servidor não conseguiu carregar a aplicação '/ LM/W3SVC/1/Root/certsrv'. O erro foi 'Execução no servidor falhou'.
Também poderá ver entradas semelhantes à seguinte no ficheiro %SystemRoot%\Iis5.log:
OC_ABOUT_TO_COMMIT_QUEUE:Unreg iis_core:FindModules: FindProcessByNameW falhou!

Além disso, poderá ser apresentada uma mensagem de erro semelhante à seguinte quando utiliza o utilitário FileMon para monitorizar a actividade do ficheiro:
Programas de captura FileMon: 1:53:21 61 PM DLLHOST.EXE:2428 IRP_MJ_CREATE C:\WINNT\System32\dllhost.exe.Local ficheiro atributos não encontrado: opções de qualquer: abrir

Causa

As entradas de NT Authority\utilizadores ou NT AUTHORITY\INTERACTIVE tem sido removidas do grupo utilizadores.

Resolução

Adicione estes utilizadores novamente ao grupo utilizadores do e, em seguida, de reiniciar os serviços de informação Internet (IIS):
  1. Clique em Iniciar , clique em programas , clique em Ferramentas administrativas e, em seguida, clique em Gestão de computadores para abrir a consola de gestão de computadores.
  2. No painel da esquerda, expanda utilizadores e grupos locais e, em seguida, clique na pasta grupos .
  3. No painel da direita, clique com o botão direito do rato no grupo de utilizadores e, em seguida, clique em Propriedades .
  4. Clique em Adicionar .
  5. Na caixa de diálogo Seleccionar utilizadores ou grupos , localize caixa pendente Procurar em e, em seguida, seleccione o computador local.
  6. Seleccione Utilizadores autenticados e, em seguida, clique em Adicionar . Seleccione INTERACTIVE e, em seguida, clique em Adicionar . Clique em OK , clique em Aplicar e clique em Fechar para fechar as propriedades para o grupo utilizadores.
  7. No painel da esquerda, expanda Serviços e aplicações e, em seguida, clique em Serviços .
  8. No painel da direita, clique com o botão direito do rato em Serviço Admin do IIS e, em seguida, clique em reiniciar .
  9. Na caixa de diálogo de confirmação de Reiniciar outros serviços , clique em Sim .
Para obter informações sobre o utilitário FileMon, visite o seguinte Web site da Sysinternals:
http://www.microsoft.com/technet/sysinternals/default.mspx (http://www.microsoft.com/technet/sysinternals/default.mspx)
Microsoft fornece informações de contactos outros fabricantes para ajudar a encontrar suporte técnico. Poderá ser alterado estas informações de contacto sem aviso prévio. Microsoft não garante a precisão destas informações de contacto outros fabricantes.

A informação contida neste artigo aplica-se a:
  • Microsoft Internet Information Services 5.0
Palavras-chave: 
kbmt kbpending kbprb KB327153 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 327153  (http://support.microsoft.com/kb/327153/en-us/ )
Retired KB ArticleExclusão de Responsabilidade para Conteúdo sem Suporte na KB
Este artigo foi escrito sobre produtos para os quais a Microsoft já não fornece suporte. Por conseguinte, este artigo é oferecido "tal como está" e deixará de ser actualizado.