Help and Support
 

powered byLive Search

Error Message: The Database Files in this Storage Are Inconsistent

Article ID:327156
Last Review:December 3, 2007
Revision:6.4
This article was previously published under Q327156
On This Page

SYMPTOMS

When you try to mount the mailbox store or public folder store on an Exchange-based computer, you may receive the following error message:
The database files in this storage are inconsistent

Back to the top

CAUSE

This issue occurs when your mailbox store or public store contains inconsistencies.

Back to the top

RESOLUTION

To resolve this issue, try to restore the database from a backup (Method 1) if you can. This is the most reliable method if your backup is up-to-date and is usable. If no backup file is available, you might be able to repair the database (Method 2), but you must be aware that repairing a database can lead to irrecoverable data loss. Also, there may be situations where a database is so badly corrupted that it may not be repairable.

Important Microsoft does not recommend that you run a repaired database in a production environment. You must use Mailbox Merge (Exmerge) to merge the data from the repaired database into a new database as soon as possible after you discover that there are inconsistencies in the mailbox store or in the public store.

Back to the top

Method 1

If you have a backup of the store that is inconsistent, you can restore from the backup file, and then mount the store.

Back to the top

Method 2

Repair the information store:
1.At a command prompt, change to the drive:\Program Files\Exchsrvr\Bin folder, where drive is the letter of the drive on which Exchange is installed. Use one of the following commands:
If you are trying to restore the mailbox store, type eseutil /p "drive:\Program Files\Exchsrvr\MDBDATA\priv1.edb", and then press ENTER.
If you are trying to restore the public folder store, type eseutil /p "drive:\Program Files\Exchsrvr\MDBDATA\pub1.edb", and then press ENTER.
2.At the command prompt, type eseutil /mh "drive:\Program Files\Exchsrvr\MDBDATA\priv1.edb" (or pub1.edb), and then press ENTER to verify the consistency information that is returned.
3.At the command prompt, type eseutil /d "drive:\Program Files\Exchsrvr\MDBDATA\priv1.edb" (or pub1.edb), and then press ENTER to defragment and to compact the database.
4.At the command prompt, type ISINTEG -S Server_Name -FIX -TEST ALLTESTS, and then press ENTER. Repeat this several times until it reports zero fixes and zero errors.
5.Mount the store.
6.Back up the store.

Back to the top

MORE INFORMATION

For additional information about the utilities that are described in this article, click the article numbers below to view the articles in the Microsoft Knowledge Base:
182081 (http://support.microsoft.com/kb/182081/EN-US/) XADM: Description of the Isinteg Utility
182903 (http://support.microsoft.com/kb/182903/EN-US/) XADM: ESEUTIL Command Line Parameters

Back to the top


APPLIES TO
Microsoft Exchange Server 2003 Enterprise Edition
Microsoft Exchange Server 2003 Standard Edition
Microsoft Exchange 2000 Server Standard Edition
Microsoft Windows Small Business Server 2003 Premium Edition
Microsoft Windows Small Business Server 2003 Standard Edition

Back to the top

Keywords: 
kberrmsg kbprb KB327156

Back to the top

Article Translations

 

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.