Select database record command does not work

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Article ID: 327222 - View products that this article applies to.
This article was previously published under Q327222
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SYMPTOMS

After you open a database-connected drawing in Visio, the Select database record command may not work correctly. For example, you may not be able to view with database record information about the data source, the table name, the primary key field, and the key value. This symptom may occur if the following conditions exist:
  • The drawing was created in Visio 5.0c, and the drawing was linked to a data source.
  • You are using Visio 2002 Service Release 1 (SR-1).
  • You tried to open the drawing by right-clicking it, and then clicking Select database record.

CAUSE

This problem occurs because Visio 2002 does not correctly process shapes that were created in earlier versions of Visio. The code in CDBSession::ParameterKeyCount in the Shapes.cpp file obtains the number of key fields in the shape to determine which Select dialog box to display. The code looks for the Visio 2002 cell, and if it does not find it, the code quits looking.

RESOLUTION

Service pack information

This problem is corrected in Microsoft Visio 2002 Service Pack 2.

To resolve this problem, obtain the latest service pack for Visio 2002. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
867749 How to obtain the latest Visio 2002 Service Pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
The global version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time     Version      Size     File name
   --------------------------------------------------------
   31-Jul-2002  1:10:25  10.0.3205.4  592,000  Visdbwiz.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
This problem was first corrected in Visio 2002 Service Pack 2.

Properties

Article ID: 327222 - Last Review: October 26, 2013 - Revision: 2.6
APPLIES TO
  • Microsoft Visio 2002 Standard Edition
  • Microsoft Visio 2002 Professional Edition
Keywords: 
kbnosurvey kbarchive kbautohotfix kbhotfixserver kbqfe kbenv kbqfe kbbug kbfix KB327222

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