Artigo: 327334 - Última revisão: quarta-feira, 28 de Fevereiro de 2007 - Revisão: 6.4

XADM: ID do evento 474 erro indica uma falha de hardware

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Sintomas

Numa instalação da Exchange 2000 Server, poderão ocorrer um ou mais dos seguintes problemas:
  • Eventos semelhantes aos seguintes são listados no registo de aplicações do Visualizador de eventos:

    Date:     date        Source:   ESE98
    Time:     time        Category: (2)
    Type:     Error       Event ID: 474
    User:     N/A
    Computer: Servername
    
    Description:
    Information store "2680" the database page read from the file "C:\Program 
    Files\Exchsrvr\mdbdata\priv1.edb" at offset 4050944 (0x00000000003dd000) for 4096 
    (0x00001000) bytes failed verification due to a page checksum mismatch.
    The expected checksum was 1537063750 (0x5b9dbb46) and the actual 
    checksum was 1536998214 (0x5b9cbb46).
    The read operation will fail with error - 1018 (0xfffffc06).
    If this condition persists then please restore the database from a previous 
    backup.

  • Os utilizadores não é possível enviar nem receber mensagens de correio electrónico.
  • Não é possível iniciar o Microsoft Outlook no computador cliente.
  • O serviço Exchange Message Transfer Agent (MTA) não é iniciado no computador do Exchange 2000 Server.

Causa

Estes problemas poderão ocorrer se a base de dados do Exchange Server do arquivo de informações ficou danificada.

Erro de 474 ID de evento indica um possível problema de hardware ou firmware no subsistema do disco rígido no servidor do Exchange. Esta falha provocou danos físicos do Exchange da base de dados. Erro -1811 (0xFFFFF8ED hexadecimal) corresponde ao erro do tipo JET_errFileNotFound e é descrito como o seguinte:
Não foi encontrado um ficheiro.

Resolução

Para corrigir este problema, mover caixas de correio da utilizador para um segundo servidor de Exchange, diagnosticar e corrigir os problemas relacionados com hardware no primeiro servidor, restaurar a base de dados do Exchange a partir de uma cópia de segurança e, em seguida, mover caixas de correio da utilizador novamente para o primeiro servidor de Exchange.

Nota : Se não tiver um segundo servidor de Exchange 2000, poderá temporariamente instalar um e, em seguida, removido-lo depois de concluir o processo de recuperação. Siga o procedimento de instalação do Exchange 2000 Server para o site.

Para mover caixas de correio para um segundo servidor de Exchange

Para mover caixas de correio da utilizador para o segundo servidor de Exchange:
  1. Clique em Iniciar , aponte para programas , aponte para Ferramentas administrativas e, em seguida, clique em utilizadores do Active Directory e computadores .
  2. Na árvore da consola, expanda o objecto de domínio e, em seguida, clique em são armazenados no contentor em que o utilizador contas cujas caixas de correio que pretende mover.
  3. Prima e mantenha premida a tecla CTRL enquanto clica os nomes dos utilizadores cujas caixas de correio que pretende mover para o segundo servidor do Exchange. Quando tiver seleccionado todos os nomes que pretende mover, clique com o botão direito do rato a lista de utilizadores, clique em Exchange Tasks e, em seguida, liberte o CTRL chave.
  4. No Assistente de tarefas do Exchange, clique em seguinte , clique em Mover a caixa de correio e, em seguida, clique em seguinte .

    A localização actual de caixas de correio da utilizador é apresentada.
  5. Para especificar o destino para as caixas de correio, seleccionar um servidor na caixa servidor , seleccione um arquivo de caixa de correio na caixa de Arquivo de caixa de correio e, em seguida, clique em seguinte .
  6. No ecrã final do Exchange Task Wizard, certifique-se que a informação está correcta e, em seguida, clique em Concluir . Se as informações não estiverem correctas, clique em ' Anterior ' para corrigir as informações.

Desmontar o arquivo de caixa de correio

Nota : neste procedimento, estão activos grupos administrativos. Para activar grupos administrativos, siga os passos no procedimento "Criar um grupo administrativo" na ajuda do Exchange System Manager.

Para desmontar o arquivo:
  1. Clique em Iniciar , aponte para programas , aponte para Microsoft Exchange e, em seguida, clique em System Manager .
  2. Na árvore de directório do Exchange System Manager , expanda Administrative Groups , expanda First Administrative Group , expanda Servers , expanda your Exchange server name e, em seguida, expanda First Storage Group .
  3. Clique com o botão direito do rato Arquivo de caixa de correio , clique em Dismount Store e clique em Sim para confirmar a desmontar o arquivo.

Copiar ficheiro log transacções

Tem de ter cópias actualizadas dos ficheiros de registo transacção para "reproduzir" mensagens de correio até à hora que de arquivo foi desmontado. Como precaução, copie os ficheiros de registo para uma localização segura no caso do programa de cópia de segurança substitui estes ficheiros como parte do procedimento de restauro. Para copiar os ficheiros de registo:
  1. Clique em Iniciar , aponte para programas , aponte para Acessórios e, em seguida, clique em linha de comandos .
  2. Na linha de comandos, escreva md Logbackup , e, em seguida, prima ENTER.
  3. Escreva cópia c:\progra~1\exchsrvr\mdbdata\*.* c:\logbackup e, em seguida, prima ENTER.

    Nota : pode utilizar o utilitário Esefile para copiar rapidamente a ficheiros de base de dados de grandes dimensões.

    Para obter informações adicionais sobre como utilizar o Esefile utilitário, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft:
    248406  (http://support.microsoft.com/kb/248406/EN-US/ ) XADM: O utilitário de Esefile suporte para o Exchange Server 5.5 e Exchange 2000

Diagnosticar o dispositivo de hardware

Determinar a causa raiz do erro 474 de eventos. Isto é normalmente causado por um dispositivo danificado no subsistema do disco rígido ou por firmware desactualizado ou incompatível no subsistema do disco rígido. Também poderá ser indicada por erros de entrada/saída (E/s) do disco apresentados no registo do sistema do Visualizador de eventos. Execute todos os diagnósticos de fabricante nos controladores de disco rígido. Verifique o sistema de ficheiros está danificado. Contacte o fornecedor de hardware para obter actualizações de firmware disponível para discos rígidos ou controladores.

Restaurar a base de dados do Exchange a partir de uma cópia de segurança

Utilize o programa cópia de segurança para restaurar os ficheiros Priv1.edb e Priv1.stm. Certifique-se de que o software de cópia de segurança não é montado a base de dados depois de restaurar os ficheiros (se utilizar o NTBackup para restaurar as bases de dados, clique para desmarcar a caixa de verificação Montar da base de dados depois de restaurar o Assistente de restauro).

Copiar os ficheiros de registo da pasta Logbackup

Se a operação de restauro tenha substituído os ficheiros de registo de transacções, utilize O Explorador do Windows ou o comando copy a partir de uma linha cmd de copiar os ficheiros de registo (log) de transacções a pasta Logbackup (em que guardou anteriormente os) novamente para a localização original (por predefinição, c:\Programas\Exchsrvr\Mdbdata).

Arquivo remount

Para montar o arquivo de novo:
  1. Clique em Iniciar , aponte para programas , aponte para Microsoft Exchange e, em seguida, clique em System Manager .
  2. Na árvore de directório do Exchange System Manager , expanda Administrative Groups , expanda First Administrative Group , expanda Servers , expanda your Exchange server name e, em seguida, expanda First Storage Group .
  3. Clique com o botão direito do rato em Mailbox Store e, em seguida, clique em Montar os arquivos . Na caixa de diálogo Arquivo de caixa de correio , clique em OK .

    O arquivo de informações é iniciado reproduzir as mensagens novamente para o tempo foram desmontados e traz o sistema de mensagens para a data e hora actuais.
  4. Efectue uma cópia de segurança online imediata.

Mais Informação

Se não tiver uma cópia de segurança válida com o qual pretende restaurar a base de dados, terá de efectuar uma operação de reparação forçada na base de dados danificado. Para o fazer, siga estes passos:
  1. Executar a operação de reparação forçada, conforme descrito no seguinte artigo da base de dados de conhecimento da Microsoft:
    259851  (http://support.microsoft.com/kb/259851/ ) Consequências da execução do eseutil /p ou edbutil /d /r comando no Exchange
  2. Depois da operação de reparação forçada concluída com êxito, execute uma desfragmentação offline da base de dados para recuperar a base de dados de soma de verificação erros. A velocidade aproximada deste procedimento é 4 a 6 GB por hora. Terá também de cerca de 110 por cento do tamanho da base de dados disponível como espaço livre do disco rígido para efectuar esta operação. Para obter informações adicionais sobre como efectuar este procedimento, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
    192185  (http://support.microsoft.com/kb/192185/EN-US/ ) XADM: Como desfragmentar com o utilitário Eseutil (Eseutil.exe)
  3. Execute o utilitário Isinteg a base de dados reparada para detectar e corrigir erros lógicos no arquivo que pode resultar da operação de reparação forçada. Este procedimento é executada à velocidade de cerca de 3 a 6 gigbytes (GB) por hora. Por predefinição, o programa de Isinteg está localizado na pasta programas Files\Exchsrvr\Bin na unidade em que o Exchange 2000 está instalado.

    Sintaxe: isinteg -s servername - verbose - fix - testar alltests -l path and file name for log

    Por exemplo, escreva o seguinte comando, onde servername é o nome do servidor do Exchange 2000:
    isinteg -s NomeServidor - fix - testar alltests - c:\isinteg1.log verboso -l
    Escreva o número do arquivo desmontado que pretende e, em seguida, prima ENTER.
  4. Examinar o ficheiro de registo produzido pelo Isinteg procedimento e, em seguida, repita o comando Isinteg comandos até que o número de correcções e erros no ficheiro de registo é igual a 0 (zero) ou até que o número de erros e correcções não é alterado.

    Nota : Especifique um nome diferente para o ficheiro de registo sempre que executar o utilitário Isinteg.
  5. Execute o programa Esefile bases de dados desfragmentada (.edb e .stm) para efectuar a verificação de soma de verificação.

    Nota : está disponível no CD-ROM do Exchange 2000 na pasta Support\Utils\i386 Esefile O programa.

    Para obter informações adicionais sobre como utilizar Esefile.exe, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
    248406  (http://support.microsoft.com/kb/248406/EN-US/ ) XADM: O utilitário de Esefile suporte para o Exchange Server 5.5 e Exchange 2000
    Uma base de dados reparada não deve ser deixado na produção. Embora o parâmetro /d é utilizado com o comando Eseutil para desfragmentar uma base de dados, o programa de Eseutil, na realidade, cria uma nova base de dados para armazenar as informações desfragmentadas e, em seguida, substitui a base de dados existente por esta nova cópia. Isto é particularmente útil em cenários em que a estrutura de base de dados existente pode estar danificada.
  6. Monte o arquivo de informações.
  7. Efectue uma cópia de segurança online imediata da base de dados reparada.
Em alguns casos, depois de efectuar a operação de reparação forçada, poderá detectar sintomas que não é possível corrigir o utilitário Isinteg, tais como mensagens desaparecendo ou serviços não responde (pendente). Neste caso, poderá utilizar o Exchange Mailbox enviar a impressão em série utilitário (ExMerge) para exportar os dados da base de dados, criar uma nova base de dados e, em seguida, importar os dados nela. Para o fazer, siga estes passos.

Nota : repor uma base de dados do arquivo de informações pode resultar numa perda de funcionalidade ou funcionalidade reduzida para os utilizadores com relação regras, offline ficheiros e pastas, delegar permissões e formulários personalizados.
  1. Copie os três ficheiros localizados na pasta Support\Utils\i386\Exmerge no CD-ROM do Exchange 2000 ou no CD-um ROM do Exchange 2000 Service Pack para o directório Files\EXCHSRVR\BIN programa localizado na unidade na qual instalou o Exchange.

    Nota : para obter informações detalhadas sobre como instalar e utilizar o utilitário Mailbox Merge, vista Exmerge.doc o ficheiro que é contida na pasta Support\Utils\i386\Exmerge o CD-ROM do Exchange 2000 ou um service pack do Exchange 2000 CD-ROM.
  2. Monte o arquivo se este já não está montado.
  3. Conceda a conta administrativa permissões Receber como e Enviar como para as caixas de correio na base de dados a partir do qual pretende exportar mensagens. Para o fazer:
    1. Inicie o Exchange System Manager e, em seguida, localize o contentor que contém a base de dados que pretende--por exemplo, Mailbox Store (Servername).
    2. Clique com o botão direito do rato na base de dados e, em seguida, clique em Propriedades .
    3. Clique no separador segurança , clique na conta na lista Nome (por exemplo, clique em administrador ) e, em seguida, clique para seleccionar a Enviar como e caixas de verificação Receber como em Permitir (Allow) na lista permissões .
    4. Clique em Aplicar , clique em OK e, em seguida, saia do Exchange System Manager.
  4. Inicie o Explorador do Windows, localize a pasta que contém o ficheiro Exmerge.exe (por predefinição, c:\Programas\Microsoft Files\Exchsrvr\Bin) e, em seguida, faça duplo clique em ExMerge.exe .
  5. Clique em seguinte , clique em Extract or Import (Two Step Procedure) e, em seguida, clique em seguinte .
  6. Clique em passo 1: extrair dados de um Exchange Server Mailbox e, em seguida, clique em seguinte .
  7. Escreva o nome do servidor do Exchange 2000 na caixa Nome do Microsoft Exchange Server e, em seguida, clique em Opções .
  8. No separador dados , clique para seleccionar as caixas de verificação seguintes:
    utilizador mensagens e pastas
    mensagens da pasta associado
    permissões de pasta
    Nota : A caixa de verificação itens do Dumpster é para itens recuperáveis que foram eliminadas pelos utilizadores (quando é seleccionada a opção de Recuperação de itens eliminados ). Esta opção requer mais espaço na partição de destino.
  9. Clique no separador do Procedimento de importação e clique no método que pretende utilizar para importar dados para o arquivo de destino.

    A selecção de Intercalar dados para o arquivo de destino é frequentemente utilizada e está seleccionada por predefinição.
  10. Clique no separador datas e, em seguida, clique em todos os (se não estiver já seleccionada).
  11. Clique em Aplicar , clique em OK e, em seguida, clique em seguinte .
  12. Clique em Seleccionar tudo , verifique se todos os utilizadores estão seleccionados e, em seguida, clique em seguinte .
  13. Verifique se a selecção de região predefinido está correcta e, em seguida, clique em seguinte .
  14. No página Directório de destino , clique numa partição com o espaço necessário para armazenar os ficheiros .pst que serão exportados. Também podem direccionar os ficheiros .pst para outro servidor se não tiverem espaço na unidade local. Se for este o caso, certifique-se de que mapeia uma unidade para a localização remota. Se copiar os ficheiros .pst para outro servidor, aumenta substancialmente o tempo que demora para executar o processo.
  15. Clique em seguinte , clique em seguinte e, em seguida, clique em Concluir quando o procedimento de exportação for concluída.
  16. Pare o serviço de arquivo de informações e cópia de segurança ou mudar o nome os ficheiros de base de dados com a qual tiver problemas.

    importante : A base de dados pode ser armazenado numa partição e o registo de ficheiros noutra partição. Pode mover estes ficheiros para outro servidor ou mudar-lhes o nome, mas a Microsoft recomenda que mantenha uma cópia da base de dados original e ficheiros de registo até ter determinado que este processo tem funcionado correctamente.
  17. Inicie o serviço de arquivo de informações e, em seguida, montar o arquivo.

    Este procedimento cria outro ficheiro de base de dados Priv1.edb.

    Nota : em alguns casos, poderá ter de reiniciar os serviços do Exchange ou reinicie o servidor antes de montar o arquivo. Deste modo, garante que lhe for pedido para forçar a criação de uma base de dados vazia.
  18. Iniciar sessão caixa de correio e, em seguida, enviar uma mensagem teste a todos os utilizadores que estão no servidor.

    Este passo é crítico para o processo de utilitário ExMerge. Isto cria, na realidade, as caixas de correio na nova base de dados.
  19. Inicie o utilitário ExMerge e, em seguida, clique em seguinte .
  20. Clique em extrair ou importar (dois passos procedimento) e, em seguida, clique em seguinte .
  21. Clique em passo 2: importar dados para o Exchange Server Mailbox e, em seguida, clique em seguinte .
  22. Escreva o nome do servidor do Exchange 2000 na caixa Nome do Microsoft Exchange Server e, em seguida, clique em Opções .
  23. No separador dados , clique para seleccionar as caixas de verificação seguintes:
    utilizador mensagens e pastas
    mensagens da pasta associado
    permissões de pasta
  24. Clique em Aplicar , clique em OK e, em seguida, clique em seguinte .
  25. Clique em Seleccionar tudo e, em seguida, clique em seguinte .

    Nota : se alguns dos utilizadores não são listadas na página Selecção da caixa de correio , poderão não recebeu a mensagem que enviou a todos os utilizadores. Certifique-se de que enviou uma mensagem de teste para todos os utilizadores. Neste caso, terminar a operação ExMerge, enviar ao utilizador uma mensagem de correio electrónico e reinicie a operação do ExMerge.
  26. Verifique se a selecção de região predefinido está correcta e, em seguida, clique em seguinte .
  27. Seleccione a pasta que contém os ficheiros .pst que exportou (por exemplo, C:\Exmergedata) e, em seguida, clique em seguinte .
  28. Clique em seguinte e, em seguida, clique em Concluir quando o processo de importação é concluído com êxito.
  29. Inicie sessão no número de caixas de correio para confirmar que os respectivos conteúdos foram importados com êxito.
Para obter informações adicionais, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
314917  (http://support.microsoft.com/kb/314917/EN-US/ ) XADM: Compreender e analisar-1018-1019 e-1022 erros de base de dados do Exchange
296788  (http://support.microsoft.com/kb/296788/EN-US/ ) XADM: Cópia de segurança offline e procedimentos de restauro para o Exchange 2000 Server
317014  (http://support.microsoft.com/kb/317014/EN-US/ ) XADM: Parâmetros da linha de comandos do Eseutil do Exchange 2000 Server
192185  (http://support.microsoft.com/kb/192185/EN-US/ ) XADM: Como desfragmentar com o utilitário Eseutil (Eseutil.exe)
265441  (http://support.microsoft.com/kb/265441/EN-US/ ) XADM: Algumas perguntas e respostas sobre o utilitário ExMerge
174197  (http://support.microsoft.com/kb/174197/EN-US/ ) XADM: Informações sobre o programa (Exmerge.exe) de intercalação de caixas de correio do Microsoft Exchange
259851  (http://support.microsoft.com/kb/259851/ ) Consequências da execução do eseutil /p ou edbutil /d /r comando no Exchange
272570  (http://support.microsoft.com/kb/272570/EN-US/ ) XADM: Como recuperar de danos do arquivo de informações de
282496  (http://support.microsoft.com/kb/282496/EN-US/ ) XADM: Considerações e procedimentos recomendados ao repor uma base de dados da caixa de correio do Exchange
259688  (http://support.microsoft.com/kb/259688/EN-US/ ) XADM: Como utilizar o utilitário ExMerge para extrair dados de um arquivo de informações privado danificado
301460  (http://support.microsoft.com/kb/301460/EN-US/ ) XADM: Exchange 2000 parâmetros da linha de comandos para a ferramenta Isinteg.exe
Para obter informações adicionais sobre recuperação de desastres do Exchange 2000, visite o seguinte Web site Microsoft TechNet:

A informação contida neste artigo aplica-se a:
  • Microsoft Exchange 2000 Server Standard Edition
  • Microsoft Exchange 2000 Enterprise Server
Palavras-chave: 
kbmt kberrmsg kbprb KB327334 KbMtpt
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