Problema di registrazione di eventi WMI

Traduzione articoli Traduzione articoli
Identificativo articolo: 327542 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Strumentazione gestione Windows (WMI) non eliminare le registrazioni di evento temporanee quando il sink corrispondente diventa non valido. Un sink non valido può verificarsi nei seguenti scenari:
  • Un client non ha annullato la registrazione dell'evento (IWbemServices::CancelAsyncCall).
  • L'oggetto sink è stato eliminato prima che il conteggio dei riferimenti raggiunge zero.
  • Errore hardware.
  • Il processo client non è stato terminato normalmente.
A causa del sink non valido, gli eventi vengono continuamente generati da accodare per il consumer, è necessario riavviare il servizio Winmgmt. Di conseguenza, il processo di WinMgmt utilizza una grande quantità di risorse della CPU e di memoria.

Cause

Quando il servizio WinMgmt tenta di chiamare il sink su un client che ha chiuso improvvisamente, si verifica un errore di "Server RPC Unavailable (0x800706BA)". (In alternativa, questo comportamento si anche verifica in Unsecapp.exe se il callback viene effettuato tramite un'interfaccia IUnsecuredApartment.) WMI non è in grado di distinguere se il recapito di eventi non riuscito a causa di un problema di rete temporanei o perché il sistema client viene chiuso improvvisamente. Questo errore indica che la destinazione per la chiamata non è attualmente disponibile. Poiché il client non ha annullato la registrazione dell'evento, WMI continua a chiamare il client per ottenere eventi quando viene ristabilita la connettività di rete. Ogni evento di timeout e ignorato nella coda di eventi WMI interna per il consumer, ma la registrazione stesso non ottenere timeout.

Risoluzione

Informazioni sul Service Pack

Per risolvere il problema, ottenere il service pack più recente per Microsoft Windows 2000. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
260910Come ottenere Windows 2000 Service Pack più recente

Informazioni sull'hotfix

È disponibile un hotfix supportato. Questo hotfix è tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica questo problema specifico.

Se l'hotfix è disponibile per il download, è una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, inviare una richiesta di servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi è necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, è perché un aggiornamento rapido (hotfix) non è disponibile per tale lingua.La versione in lingua inglese di questa correzione presenta gli attributi di file elencati nella tabella seguente (o successivi). Date e ore per questi file sono indicati nella coordinated universal time (UTC). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello strumento Data e ora del Pannello di controllo.
   Date         Time   Version        Size     File name
   --------------------------------------------------------
   25-Sep-2002  10:40  1.50.1085.88   643,146  Wbemcore.dll
				

Status

Microsoft ha confermato che questo problema riguarda i prodotti Microsoft elencati all'inizio di questo articolo. Questo problema è stato innanzitutto corretto in Microsoft Windows 2000 Service Pack 4.

Informazioni

Quando si applica questo aggiornamento rapido (hotfix), il Sub-System di eventi WMI di Windows 2000 Annulla una sottoscrizione di eventi quando viene rilevato un errore di tipo di procedura remota RPC durante l'invio di eventi (ad esempio, "RPC server non disponibile"). L'aggiornamento rapido non comporta alcun monitoraggio tempo reale di connessione. Se un consumer di eventi perde la connettività con WMI (Winmgmt), le sottoscrizioni di eventi sono eliminate alla successiva che viene provato il recapito di un evento. WMI continua a utilizzare le risorse della CPU per gestire le registrazioni evento intrinseco e polling finché non viene provato il recapito di un evento. Risorse della CPU non sono interessate per eventi estrinseci e reali. Questa soluzione è la stessa soluzione che è stata incorporata in Windows XP e versioni successive di Windows.

Per ulteriori informazioni su come ottenere la correzione rapida per Windows 2000 Datacenter Server, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
265173Il programma Datacenter e il prodotto di Windows 2000 Datacenter Server

Proprietà

Identificativo articolo: 327542 - Ultima modifica: sabato 24 febbraio 2007 - Revisione: 3.6
Le informazioni in questo articolo si applicano a:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
Chiavi: 
kbmt kbautohotfix kbhotfixserver kbqfe kbqfe kbwin2ksp4fix kbsysadmin kbbug kbfix kbwin2000presp4fix KB327542 KbMtit
Traduzione automatica articoli
Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 327542
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com