De computer loopt tijdens het afsluiten of opnieuw opstarten vast als de functie ExitWindowsEx() door meerdere programma's wordt aangeroepen

Vertaalde artikelen Vertaalde artikelen
Artikel ID: 327565 - Bekijk de producten waarop dit artikel van toepassing is.
Alles uitklappen | Alles samenvouwen

Symptomen

Als twee of meer programma's proberen om Windows af te sluiten of opnieuw te starten, loopt een computer waarop Microsoft Windows XP of Microsoft Windows 2000 wordt uitgevoerd mogelijk vast. De bureaubladachtergrond is zichtbaar en de muisaanwijzer kan worden bewogen, maar de computer reageert niet op toetsaanslagen (ook niet op de toetsencombinatie CTRL+ALT+DELETE). U moet wellicht de computer uitschakelen om door te kunnen gaan. Als Automatische updates is geconfigureerd voor het installeren van updates vanaf Windows Update, Microsoft Update of een Windows Server Update Service-server (WSUS), lopen Windows 2000-systemen nadat u updates hebt geïnstalleerd mogelijk vast tijdens het afsluiten of opnieuw opstarten.

Oorzaak

Als meerdere programma's de functie ExitWindowsEx aanroepen om Windows nagenoeg tegelijkertijd af te sluiten of opnieuw op te starten, wordt een van de afsluitberichten mogelijk genegeerd. De afsluitprocedure wordt dan niet voltooid.

Oplossing

Een ondersteunde hotfix is beschikbaar bij Microsoft. Deze hotfix is echter alleen bedoeld als oplossing van het probleem dat in dit artikel wordt beschreven. Voer deze hotfix alleen uit op systemen waarop dit specifieke probleem zich voordoet. Deze hotfix moet mogelijk extra worden getest. Als u geen ernstige problemen ondervindt, raadt Microsoft u daarom aan te wachten op de volgende update waarin deze hotfix is opgenomen.

Als de hotfix kan worden gedownload, is aan het begin van dit Knowledge Base-artikel een sectie 'Hotfix kan worden gedownload' opgenomen. Als een dergelijke sectie niet aanwezig is, kunt u de hotfix aanvragen bij de klantondersteuning van Microsoft.

Opmerking Als er nog andere problemen optreden of als er oplossingen vereist zijn, moet u mogelijk een afzonderlijk serviceverzoek indienen. De normale ondersteuningskosten gelden voor extra ondersteuningsvragen die niet in aanmerking komen voor deze specifieke hotfix. Bezoek de volgende website van Microsoft voor een volledige lijst met telefoonnummers van de klantondersteuning van Microsoft of om een afzonderlijk serviceverzoek te maken:
http://support.microsoft.com/contactus/?ws=support
Opmerking Op het formulier 'Hotfix kan worden gedownload' zijn de talen vermeld waarvoor de hotfix beschikbaar is. Als uw taal daar niet bij staat, is de hotfix niet beschikbaar voor die taal.
Opmerking Er is geen Windows 2000-hotfix beschikbaar voor dit probleem aangezien Windows 2000 zich in een uitgebreide ondersteuningsfase bevindt. Ga voor meer informatie naar de volgende Microsoft-website:
http://www.microsoft.com/windows/lifecycle/servicepacks.mspx
Meer informatie over het beleid ten aanzien van de levenscyclus van Microsoft-producten vindt u op de volgende Microsoft-website: volgende website
http://support.microsoft.com/common/international.aspx?RDPATH=dm;en-us;lifecycle.
De Engelse versie van deze hotfix heeft de bestandskenmerken die in de volgende tabel worden weergegeven (of recentere bestandskenmerken). De datums en tijden voor deze bestanden worden weergegeven in de UTC-notatie (Coordinated Universal Time). Wanneer u de bestandsinformatie weergeeft, wordt deze naar lokale tijd geconverteerd. Als u het verschil tussen UTC en lokale tijd wilt bepalen, gebruikt u het tabblad Tijdzone van het onderdeel Datum en tijd in het Configuratiescherm.
   Datum        Tijd   Versie            Grootte      Bestandsnaam
   -------------------------------------------------------
   22-aug-2002  19:16  5.1.2600.100  1.671.040  Win32k.sys
				

Status

Microsoft heeft bevestigd dat dit probleem zich kan voordoen in de Microsoft-producten die worden vermeld in de sectie 'Van toepassing op'.

Eigenschappen

Artikel ID: 327565 - Laatste beoordeling: woensdag 31 december 2008 - Wijziging: 3.1
De informatie in dit artikel is van toepassing op:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows® 2000 Server
Trefwoorden: 
kbautohotfix kbhotfixserver kbbug kbfix kbqfe KB327565

Geef ons feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com