Komputer zawiesza się podczas zamykania lub ponownego uruchamiania, jeśli kilka programów wywołuje funkcję ExitWindowsEx()

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 327565 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Rozwiń wszystko | Zwiń wszystko

Symptomy

Jeśli co najmniej dwa programy próbują zamknąć lub ponownie uruchomić system Windows, komputer z systemem Microsoft Windows XP lub Microsoft Windows 2000 może przestać odpowiadać podczas zamykania. Tapeta pulpitu może być widoczna, a wskaźnik myszy może się poruszać, ale komputer nie odpowiada na instrukcje przesyłane z klawiatury (w tym na naciskanie kombinacji klawiszy CTRL+ALT+DELETE). W celu kontynuowania może być konieczne wyłączenie komputera. Jeśli funkcja Aktualizacje automatyczne jest skonfigurowana do instalowania aktualizacji z witryny Windows Update, Microsoft Update lub serwera Windows Server Update Service (WSUS), system Windows 2000 może przestać odpowiadać w trakcie zamykania lub ponownego uruchamiania po zainstalowaniu aktualizacji.

Przyczyna

Jeśli kilka programów wywołuje funkcję ExitWindowsEx w celu zamknięcia lub ponownego uruchomienia systemu Windows prawie w tym samym czasie, jeden z komunikatów zamknięcia może zostać niepoprawnie odrzucony. W wyniku tego proces zamykania nie zostaje ukończony.

Rozwiązanie

Firma Microsoft udostępniła obsługiwaną poprawkę. Jednak jest ona przeznaczona tylko do usunięcia problemu opisanego w tym artykule. Tę poprawkę należy stosować tylko w tych systemach, w których występuje opisany problem. Ta poprawka może być nadal w fazie testowania. Jeśli dany system nie jest poważnie narażony na ten problem, firma Microsoft zaleca, aby poczekać na następną aktualizację oprogramowania zawierającą tę poprawkę.

Jeśli poprawka jest dostępna do pobrania, na początku tego artykułu z bazy wiedzy Knowledge Base jest umieszczona sekcja „Poprawka dostępna do pobrania”. Jeśli nie ma tej sekcji, skontaktuj się z działem obsługi klienta i pomocy technicznej firmy Microsoft w celu uzyskania poprawki.

Uwaga W przypadku wystąpienia dodatkowych błędów lub konieczności rozwiązania problemu może być wymagane utworzenie osobnego zlecenia usługi. Typowe opłaty za korzystanie z pomocy technicznej będą pobierane tylko w przypadku dodatkowych pytań i problemów, których nie można rozwiązać przy użyciu tej poprawki. Aby uzyskać pełną listę numerów telefonów działu obsługi klienta i pomocy technicznej firmy Microsoft lub utworzyć osobne zlecenie usługi, odwiedź następującą witrynę firmy Microsoft w sieci Web:
http://support.microsoft.com/contactus/?ws=support
Uwaga Sekcja „Poprawka dostępna do pobrania” zawiera listę języków, dla których ta poprawka jest dostępna. Jeśli odpowiedni język nie jest widoczny, oznacza to, że ta poprawka nie jest dostępna dla tego języka.
Uwaga Nie udostępniono związanej z tym problemem poprawki dla systemu Windows 2000, ponieważ system Windows 2000 jest w fazie rozszerzonej pomocy technicznej. Aby uzyskać więcej informacji, odwiedź następującą witrynę firmy Microsoft w sieci Web:
http://www.microsoft.com/windows/lifecycle/servicepacks.mspx
Aby uzyskać więcej informacji o zasadach dotyczących cyklu obsługi produktu firmy Microsoft, odwiedź następującą witrynę firmy Microsoft w sieci Web: następująca witryna sieci Web
http://support.microsoft.com/common/international.aspx?RDPATH=dm;en-us;lifecycle.
Wersja angielskojęzyczna tej poprawki ma atrybuty plików przedstawione w poniższej tabeli (lub nowsze). Daty i godziny odpowiadające tym plikom zostały podane w formacie uniwersalnego czasu koordynowanego (UTC). Podczas wyświetlania informacji dotyczących plików są one konwertowane na czas lokalny. Różnicę między czasem UTC i czasem lokalnym można sprawdzić, korzystając z karty Strefa czasowa narzędzia Data i godzina w Panelu sterowania.
   Data        Godzina   Wersja         Rozmiar       Nazwa pliku
   -------------------------------------------------------
   22-sie-2002  19:16  5.1.2600.100  1 671 040  Win32k.sys
				

Stan

Firma Microsoft potwierdziła, że jest to problem występujący w produktach firmy Microsoft wymienionych w sekcji „Informacje zawarte w tym artykule dotyczą”.

Właściwości

Numer ID artykułu: 327565 - Ostatnia weryfikacja: 31 grudnia 2008 - Weryfikacja: 3.4
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
Słowa kluczowe: 
kbautohotfix kbhotfixserver kbbug kbfix kbqfe KB327565

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com