Month and day are not displayed in the order that you expect in a mail merge document linked to an external data source in Word 2002

Article translations Article translations
Article ID: 327579 - View products that this article applies to.
Expand all | Collapse all

On This Page

Symptoms

When you use Word 2002 to create a mail merge document that is linked to a data source that contains dates, the values of the date fields in the document may display the incorrect date. Specifically, the day and the month may be switched.

Cause

This problem occurs when all the following conditions are true:
  • You have attached the data source to the document by means of OLE DB.
  • Your system date format is not MM/DD/YYYY or MM/DD/YY.
  • The relevant date values are ambiguous where the day and month values are concerned. For example, the day value is less than or equal to 12. This occurs whether or not a formatting switch has been applied to the date mail merge field in the mail merge document.
  • You have applied a formatting switch to the date mail merge field in the mail merge document.

Resolution

Service Pack Information

This problem is corrected in Office XP Service Pack 3. To resolve this problem, obtain the latest service pack for Microsoft Office XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
307841 How to obtain the latest Office XP service pack

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time    Size       File name     
   -----------------------------------------------
   24-Jan-2003  18:39   5,676,428  Winword.msp
   24-Jan-2003  19:21   6,629,784  Winwordff.msp
After the hotfix is installed, the following files will have the listed attributes or later:
   Date         Time   Version      Size        File name     
   --------------------------------------------------------
   24-Jan-2003  02:05  10.0.4921.0  10,598,984  Winword.exe
				

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Office XP Service Pack 3.

More information

With the hotfix installed, you must still insert the desired date/time picture switch in the DATE mergefield. Such as {MERGEFIELD Date \@ "dd.MM.YYYY"} or {MERGEFIELD Date \@ "d.MMM.YYYY"}.

Properties

Article ID: 327579 - Last Review: June 19, 2014 - Revision: 6.0
Applies to
  • Microsoft Word 2002
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbbug kbfix KB327579

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com