Base de datos no se monta, y aparece el error 0xfffff05b después de aplicar SP3 a Exchange 2000

Seleccione idioma Seleccione idioma
Id. de artículo: 327772 - Ver los productos a los que se aplica este artículo
Este artículo se ha archivado. Se ofrece "tal cual" y no se volverá a actualizar.
Expandir todo | Contraer todo

En esta página

Síntomas

Después de instalar Exchange 2000 Server Service Pack 3 (SP3) o posterior, la base de datos almacén de información no se monta.

Este problema puede producirse al actualizar cualquier versión anterior al SP3 de Exchange 2000 Server a Exchange 2000 Server SP3 o a cualquier versión posterior . Por ejemplo, si intenta actualizar Exchange 2000 SP2 a Microsoft Exchange Server 2003, puede experimentar este problema.

Puede encontrar eventos similar al siguiente en el registro de aplicación del Visor de sucesos:

Tipo de suceso: error
Origen del suceso: ESE
Categoría del suceso: general
ID. de suceso: 505
Descripción: Almacén de información (2028) intentar abrir el archivo comprimido " unidad : \Exchsrvr\MDBDATA\priv1.edb" para lectura / escritura porque no se pudo convertir a un archivo normal. La operación de abrir archivo fallará con error-4005 (0xfffff05b). Para evitar este error en el futuro puede manualmente descomprimir el archivo y cambiar el estado de compresión de la carpeta que contiene a sin comprimir. No se admite la escritura a este archivo cuando está comprimida.

Tipo de suceso: error
Origen del suceso: MSExchangeIS
Categoría del suceso: general
ID. de suceso: 9519
Descripción: Iniciar Error 0xfffff05b base de datos "primer almacenamiento Group\Mailbox almacén (EXCHANGE)" en el almacén de información de Microsoft Exchange. No se pudo adjuntar a DB de Jet.



Nota En el suceso: 505 (sección de descripción), unidad hace referencia a la unidad en la que la base de datos del almacén de información de Exchange está instalado.

Causa

Este problema puede producirse al aplicar Exchange 2000 Server Service Pack 3 a un servidor de Exchange 2000 que contiene una base de datos almacén de información que está comprimido mediante compresión del sistema de archivos NTFS. Este problema puede producirse también cuando se actualiza un equipo con Exchange 2000 Server a Exchange Server 2003. Exchange 2000 Server Service Pack 3 y Exchange 2003 impedir bases de datos de almacén de información comprimida de montaje.

Los archivos que se administran mediante el motor de almacenamiento extensible (ESENT o ESE) no están diseñados para almacenarse en una unidad comprimida. El motor de almacenamiento extensible depende de la independencia de sector para la recuperación basada en registro y compresión de archivos invalida la independencia de sector. Compresión no debe activarse para volúmenes que alojan bases de datos ESE o cualquier base de datos que utiliza el registro de escritura adelantada.

Antes de Exchange 2000 Server Service Pack 3, se permite montar bases de datos de almacén de información comprimida. Sin embargo, en cualquier bases de datos de almacén de información de Exchange 2000 o registros de almacén de información que se han comprimido mediante compresión NTFS pueden resultar dañados.

Con Exchange 2000 Server Service Pack 3 y posterior, comprimida información almacenar archivos de base de datos de 128 megabytes (MB) o menos son descomprimidos automáticamente. Cuando los archivos de base de datos crecen a más de 128 MB, la base de datos no se monta y se generan los mensajes de error en el registro de aplicación. Exchange 2000 Server Service Pack 3 y Exchange Server 2003 impide bases de datos comprimidos mayores de 128 MB de montaje.

Dado que la base de datos del almacén de información pública puede ser menor que 128 MB, puede montar. Sin embargo, todos los pasos de la sección "Solución" de este artículo se aplican a todas Exchange 2000 Server o Exchange Server 2003 información de las bases de almacén de datos que están en una carpeta comprimida, independientemente de si puede montar o no.

Para obtener información adicional acerca de daños en bases de datos de almacén de información de Exchange debido de compresión de NTFS en las versiones anteriores de Exchange, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
170009Almacén para producir un error hace que el volumen NTFS comprimidos

Solución

Para resolver este problema, debe descomprimir las carpetas donde las bases de datos del almacén de información y los registros residen, desfragmentar las bases de datos y, a continuación, realice una copia de seguridad preparadas para Exchange en línea de los grupos de almacenamiento del almacén de información donde residen las bases de datos y registros. Para ello, siga estos pasos.

Desmontar las bases de datos


Nota Realice este procedimiento sólo si las bases de datos siguen montados.
  1. Haga clic en Inicio , seleccione programas , seleccione Microsoft Exchange y, a continuación, haga clic en Administrador del sistema .
  2. En el panel izquierdo, haga doble clic en el grupo administrativo y, a continuación, haga doble clic en servidores .
  3. Haga doble clic en el grupo de almacenamiento apropiado.
  4. Haga clic con el botón secundario en Almacén del buzón ( nombreDeServidorExchange ) , donde NombreServidorExchange es el nombre del servidor de Exchange y haga clic en Desmontar el almacén .
  5. Haga clic en .
  6. Haga clic con el botón secundario en Almacén de carpetas públicas ( nombreDeServidorExchange ) , donde NombreServidorExchange es el nombre del servidor de Exchange y haga clic en Desmontar el almacén .
  7. Haga clic en .

Descomprimir la carpeta donde residen las bases de datos y registros

  1. Abra el Explorador de Windows.
  2. Haga doble clic en la carpeta que contenga el bases de Exchange datos del almacén de información públicas y privadas o archivos de registro y, a continuación, haga clic en Propiedades .
  3. Haga clic en para desactivar la casilla de verificación Comprimir contenido para ahorrar espacio en disco y, a continuación, haga clic en Aceptar .
  4. En el cuadro de diálogo Confirmar cambios de atributos , haga clic en Aplicar cambios a esta carpeta , subcarpetas y archivos , donde carpeta es en el que residen las bases de datos o registros y a continuación, haga clic en Aceptar .

    Aparece un indicador de progreso. Muestra el proceso de descompresión. Microsoft recomienda que supervise este indicador, ya que los mensajes de confirmación pueden aparecer durante el proceso de descompresión.
  5. Haga clic en Aceptar .
  6. Repita los pasos 1 a 5 para cada carpeta donde comprimida información de Exchange 2000 almacenar bases de datos o registro de almacén de información comprimido archivos residen.

    Nota Si la carpeta no está comprimida, pero está recibiendo el 505 de ID de evento y 9519 de ID de evento en el registro de aplicación, se puede comprimir la base de datos almacén de información por sí mismo (por ejemplo, Priv1.edb o Priv1.stm). En este caso, debe seguir estos pasos:
    1. Abra la hoja de propiedades del archivo (como Priv1.edb o Priv1.stm), haga clic en Avanzadas .
    2. Si se selecciona la casilla de verificación Comprimir contenido para ahorrar espacio en disco , haga clic para desactivarla.
    3. Haga clic en Aceptar dos veces.
    Debe hacerlo para cada base de datos almacén de información que se ha comprimido y cada registro de almacén de información que está comprimido.

Realizar desfragmentación sin conexión de bases de datos

Una desfragmentación sin conexión de las bases de datos genera una nueva tabla de base de datos. La tabla de base de datos anterior ha puede volverse inestable debido de compresión.

Nota por ciento de 110 del tamaño de archivo de base de datos es necesario como espacio libre en la unidad antes de que se puede desfragmentar el archivo de base de datos.

Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
183888Requisitos de espacio en disco libre para Eseutil.exe
  1. Haga clic en Inicio y, a continuación, haga clic en Ejecutar .
  2. En el cuadro de diálogo Abrir escriba cmd y, a continuación, presione ENTRAR.
  3. En el símbolo del sistema, escriba cd exchsrvr\bin y, a continuación, presione ENTRAR.
  4. Tipo eseutil /d unidad : \exchsrvr\mdbdata\ PrivateStore.edb , donde unidad es la unidad en qué base de datos de almacén de información privada de Exchange está instalado y donde PrivateStore.edb es el nombre de su privado archivo de base de datos, a continuación, presione ENTRAR.
  5. Tipo eseutil /d unidad : \exchsrvr\mdbdata\ PublicStore.edb , donde unidad es la unidad en que se instala la base de datos del almacén de información pública de Exchange y donde PublicStore.edb es el nombre del archivo de base de datos pública y, a continuación, presione ENTRAR.
  6. Salga del símbolo del sistema.
Para obtener información adicional acerca de cómo completar una desfragmentación mediante la utilidad Eseutil, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
192185Cómo desfragmentar con la herramienta ESEUTIL (Eseutil.exe)

Vuelva a montar las bases de datos

  1. Haga clic en Inicio , seleccione programas , seleccione Microsoft Exchange y, a continuación, haga clic en Administrador del sistema .
  2. En el panel izquierdo, haga doble clic en el grupo administrativo y, a continuación, haga doble clic en servidores .
  3. Haga clic con el botón secundario en Almacén del buzón ( nombreDeServidorExchange ) , donde NombreServidorExchange es el nombre del servidor de Exchange y haga clic en Montar el almacén .
  4. Haga clic en Aceptar .
  5. Haga clic con el botón secundario en Almacén de carpetas públicas ( nombreDeServidorExchange ) , donde NombreServidorExchange es el nombre del servidor de Exchange y haga clic en Montar el almacén .
  6. Haga clic en Aceptar .

Realizar copia de un inmediata, en línea preparadas para Exchange seguridad de los grupos de almacenamiento donde residen las bases de datos y registros

Para obtener información adicional acerca de cómo realizar una copia de seguridad en línea compatible con Exchange de Exchange 2000, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
258243Cómo realizar copias de seguridad de un equipo con Exchange y restaurarlas mediante el programa Copia de seguridad de Windows

Más información

Para obtener información adicional acerca de las bases de datos Jet y las unidades comprimidas, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
318116Problemas con bases de datos Jet en unidades comprimidas

Propiedades

Id. de artículo: 327772 - Última revisión: lunes, 24 de febrero de 2014 - Versión: 4.4
La información de este artículo se refiere a:
  • Microsoft Exchange Server 2000 Service Pack 3
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Small Business Server 2000 Standard Edition
  • Microsoft Windows Small Business Server 2003 Standard Edition
  • Microsoft Windows Small Business Server 2003 Premium Edition
Palabras clave: 
kbnosurvey kbarchive kbmt kberrmsg kbprb KB327772 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 327772

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com