Artikel-ID: 327804 - Geändert am: Mittwoch, 11. September 2002 - Version: 1.2

Winmodem-Gerät funktioniert nach Aktualisierung auf Windows XP SP1 nicht auf Toshiba Portege 2000

wichtig : Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Bevor Sie die Registrierung bearbeiten, vergewissern Sie sich bitte, dass Sie die Registrierung wiederherstellen können, falls ein Problem auftritt. Weitere Informationen zum Erstellen einer Sicherungskopie, zum Wiederherstellen und Bearbeiten der Registrierung finden Sie in folgendem Artikel der Microsoft Knowledge Base:
256986  (http://support.microsoft.com/kb/256986/EN-US/ ) Beschreibung der Microsoft Windows-Registrierung

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Problembeschreibung

Nachdem Sie Windows XP Service Pack 1 (SP1) installiert haben, funktioniert das Winmodem-Gerät nicht mehr auf der Toshiba Portege 2000.

Wenn Sie das Gerät im Geräte-Manager anzeigen, wird es mit einem gelb angezeigt "!", die angibt, dass das Gerät Probleme auftreten.

Ursache

ALi-Chipsatz stellt nur eine Hardware-ID für den Controller Audio Codec ' 97 (AC ' 97) zur Verfügung. Die verfügbaren Hardware-ID ist für Audio. Der Audiotreiber zählt auch einen untergeordneten Knoten für das Modem. SP1 aktualisiert den audio Knoten, der für das Winmodem-Gerät das Problem verursacht.

Lösung

Wenden Sie eines der folgenden Verfahren an, um dieses Problem zu beheben. Diese Methoden werden in der Reihenfolge dargestellt, es wird empfohlen.

Methode 1: Verwenden der Funktion Roll Back Treiber für den Audio-Knoten

  1. Klicken Sie mit der rechten Maustaste auf Arbeitsplatz , und klicken Sie dann auf Eigenschaften .
  2. Klicken Sie auf die Registerkarte Hardware , und klicken Sie dann auf Geräte-Manager .
  3. Erweitern Sie Modems , und doppelklicken Sie dann auf den audio Knoten für Ihr Modem.
  4. Klicken Sie auf die Registerkarte Treiber , und klicken Sie dann auf Installierter Treiber .

Methode 2: Bearbeiten der Datei Ltsmwxp.inf und Aktualisieren des Treibers

Die Datei Ltsmwxp.inf bearbeiten

  1. Klicken Sie auf Start , und klicken Sie dann auf Suchen .
  2. Klicken Sie auf Alle Dateien und Ordner .
  3. Geben Sie im Feld Gesamter oder Teil des Dateinamens ltsmwxp.inf , und klicken Sie dann auf Suchen .
  4. Doppelklicken Sie im Fenster Suchergebnisse auf Ltsmwxp.inf .
  5. Im Menü Datei klicken Sie auf Speichern unter , und speichern Sie die Datei als Ltsmwxp.old .
  6. Suchen Sie die folgende Zeile in der Datei:
    %ALI_AMR.Modem% = ALI_AMR.Modem, PCI\VEN_10B9 & DEV_5450 & SUBSYS_4C275349
  7. Fügen Sie nach dieser Zeile die following:%ALI_AMR.Modem% = ALI_AMR.Modem, \VEN_10B9&DEV_5450&SUBSYS_4C275349 {be20ddbf-3fb3-4add-a5c0-49be7ac20fb}

  8. Im Menü Datei klicken Sie auf Speichern unter , und speichern Sie die Datei als Ltsmwxp.inf .
  9. Notieren Sie den Speicherort dieser Datei, und beenden Sie den Editor.

Den Treiber aktualisieren

  1. Klicken Sie mit der rechten Maustaste auf Arbeitsplatz , und klicken Sie dann auf Eigenschaften .
  2. Klicken Sie auf die Registerkarte Hardware , und klicken Sie dann auf Geräte-Manager .
  3. Erweitern Sie Modems , und doppelklicken Sie dann auf den audio Knoten für Ihr Modem.
  4. Klicken Sie auf die Registerkarte Treiber , und Klicken Sie dann auf Aktualisieren .
  5. Klicken Sie im Hardware-Assistenten auf Software von einer Liste oder der angegebenen Position (Erweitert) installieren , und geben Sie dann den Speicherort der Datei Ltsmwxp.inf.

    Hinweis : erhalten Sie möglicherweise eine Meldung, die besagt, dass der Treiber nicht signiert ist.

Methode 3: Bearbeiten der Registrierung

Warnung : unkorrekte Verwendung des Registrierungseditors kann schwerwiegende Probleme, die eine Neuinstallation Ihres Betriebssystems erforderlich machen verursachen. Microsoft kann nicht garantieren, dass Probleme, die Verwendung des Registrierungseditors entstehen, behoben werden können. Benutzen Sie den Registrierungseditor auf eigene Verantwortung.

  1. Klicken Sie auf Start , und klicken Sie dann auf Ausführen .
  2. Geben Sie in das Feld Öffnen regedit ein und klicken Sie dann auf OK .
  3. Gehen Sie im Registrierungseditor zu dem folgenden Unterschlüssel:
    \VEN_10B9&5450$SUBSYS_4C275349 HKEY_LOCAL_MACHINE\System\CurrentControlSet\Enum\ {be20ddbf-3fb3-4add-a5c0-49be7ac20fb}
  4. Um eine Sicherungskopie des Unterschlüssels zu erstellen, klicken Sie auf den Unterschlüssel, und klicken Sie dann im Menü Datei auf Exportieren .
  5. Geben Sie einen Namen für die Sicherungskopie im Feld Dateiname den Namen , klicken Sie auf Ausgewählte Teilstruktur und klicken Sie dann auf Speichern .

    Hinweis : Wenn Sie diesen Schlüssel wiederherstellen benötigen, nachdem Sie dieses Verfahren abgeschlossen haben, doppelklicken Sie auf diese Sicherungskopie.
  6. Doppelklicken Sie im rechten Fensterbereich auf den HardwareID -Schlüssel.
  7. Geben Sie im Feld Wert Folgendes: PCI\VEN_10B9 & 5450 SUBSYS_4C275349 ?

  8. Klicken Sie auf OK , und starten Sie den Computer neu.

Status

Microsoft hat bestätigt, dass es sich hierbei um ein Problem bei den in diesem Artikel genannten Microsoft-Produkten handelt.

Weitere Informationen

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Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows XP Home Edition SP1
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 327804  (http://support.microsoft.com/kb/327804/en-us/ )
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