WD2002: Compare and Merge Documents Feature Shows Inaccurate Changes

Article translations Article translations
Article ID: 327871 - View products that this article applies to.
This article was previously published under Q327871
This article has been archived. It is offered "as is" and will no longer be updated.
Expand all | Collapse all

On This Page

SYMPTOMS

When you use the Compare and Merge Documents feature in Microsoft Word to compare a revised document with the original version of a document, inaccurately marked changes appear in the revised document.

CAUSE

This problem may occur when the Random Security Identifiers (RSIDs) are missing from the documents that are being compared or merged.

RSIDs may be missing when any one of the following conditions is true in at least one of the documents that is being compared or merged:
  • At least one of the documents has been edited and saved in an earlier version of Microsoft Word.

    -or-
  • At least one of the documents has been saved as Web Page (*.htm; *.html) or as Web Page, Filtered (*.htm; *.html).

    -or-
  • The Store random number to improve merge accuracy option is turned off.

RESOLUTION

Service Pack Information

This problem is corrected in Office XP Service Pack 3.To resolve this problem, obtain the latest service pack for Microsoft Office XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
307841 How to obtain the latest Office XP Service Pack

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
The global version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Size       File Name     
   --------------------------------------------
   10-Jan-2003  08:01  5,856,560  Winword.msp
   10-Jan-2003  08:48  6,626,108  Winwordff.msp
				
After the hotfix is installed, the following files will have the listed attributes or later:
   Date         Time   Version      Size        File Name     
   --------------------------------------------------------
   09-Jan-2003  22:31  10.0.4907.0  10,598,984  Winword.exe
				
This fix is a post-Office XP Service Pack 2 (SP-2) fix. To install the fix, you must have Office XP SP-2 installed. For additional information about Office XP SP-2, click the following article number to see the article in the Microsoft Knowledge Base:
325671 OFFXP: Overview of the Office XP Service Pack 2
Additionally, you may have to install Windows Installer 2.0 to install this fix. For additional information about the Windows Installer requirement for post-Office XP SP-2 fixes, click the following article number to see the article in the Microsoft Knowledge Base:
330537 OFFXP: Office XP Updates and Patches Released After September 2002 May Require Windows Installer 2.0

WORKAROUND

To maintain accuracy when you compare and merge documents:
  • Create and make changes to documents in Word 2002. Do not use an earlier version of Microsoft Word to make editing changes to a document that you want to compare or merge.

    -and-
  • Make sure that the Store random number to improve merge accuracy option is turned on in Microsoft Word for each person who will make changes to the document that you want to compare or merge.

    To verify that the Store random number to improve merge accuracy option is turned on, follow these steps:
    1. On the Tools menu, click Options.
    2. Click the Security tab, and then make sure that the Store random number to improve merge accuracy check box is selected.
    3. Click OK to close the Options dialog box.
    Note By default, the Store random number to improve merge accuracy option is turned on when you install Microsoft Word.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Office XP Service Pack 3.

MORE INFORMATION

When you compare and merge documents, Word uses randomly generated numbers (RSIDs) to track related documents. Although these numbers are hidden, they may be used to demonstrate that two documents are related. Word may fail to merge any existing revisions to a document when the RSIDs for a document are missing.

Properties

Article ID: 327871 - Last Review: February 27, 2014 - Revision: 3.2
APPLIES TO
  • Microsoft Word 2002 Standard Edition
Keywords: 
kbnosurvey kbarchive kbautohotfix kbqfe kbhotfixserver kbofficexppresp3fix kbbug kbfix KB327871

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com