Les index décroissants dans Access 2002 se transforment en index croissants lors de la migration vers SQL même après l'installation du Service Pack 2 Office XP ou du Service Pack 3 Office XP

Traductions disponibles Traductions disponibles
Numéro d'article: 328019 - Voir les produits auxquels s'applique cet article
Ancien nº de publication de cet article : F328019
Cet article a été archivé. Il est proposé « en l'état » et ne sera plus mis à jour.
Cet article peut contenir des liens vers des informations en langue anglaise (pas encore traduites).
Important Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, pensez à le sauvegarder et assurez-vous que vous savez le restaurer en cas de problème. Pour plus d'informations sur la sauvegarde, la restauration et la modification du Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
256986 Description du Registre de Microsoft Windows
Agrandir tout | Réduire tout

Sommaire

Symptômes

Lorsque vous utilisez l'Assistant de migration de Microsoft Access 2002 pour migrer une base de données vers SQL Server, vous remarquez que les index décroissants sont transformés en index croissants dans la base de données résultante.

Remarque Ce problème se produit même après l'installation du Service Pack 2 (SP2) Microsoft Office XP ou du Service Pack 3 (SP3) Microsoft Office XP. Ce problème est documenté comme étant résolu dans le Service Pack 2 Office XP. Pour plus d'informations sur le problème décrit dans la section "Symptômes" de cet article, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
325670 ACC2002 : Problèmes résolus dans Access 2002 par le Service Pack 2 Microsoft Office XP

Cause

Ce problème peut se produire lorsque vous exécutez l'Assistant de migration avant d'installer le Service Pack 2 ou le Service Pack 3 Office XP. Lors de la mise à jour des fichiers dans le Service Pack 2 ou le Service Pack 3 Office XP, les fichiers avec version qui n'ont pas été modifiés par l'utilisateur sont mis à jour. Si vous exécutez l'Assistant de migration, les fichiers avec version associés à l'Assistant sont modifiés. Les Service Packs 2 et 3 Office XP les traitent alors comme des fichiers sans version modifiés par l'utilisateur et ne seront peut-être pas en mesure de les mettre à jour correctement.

Résolution

Pour résoudre ce problème, téléchargez et installez la mise à jour Microsoft Access 2002 : KB833857. Pour plus d'informations sur la mise à jour Microsoft Access 2002 : KB833857, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
833857 Description de la mise à jour Microsoft Access 2002 datée du 23 mars 2004

Informations d'administration

Si vous êtes un administrateur, vous pouvez appliquer d'autres méthodes pour résoudre ce problème. Les administrateurs de bases de données peuvent déployer le Service Pack 2 Office XP ou le Service Pack 3 Office XP à l'aide de la méthode décrite dans la documentation sur les Service Packs comprise dans le Kit de ressources Office, puis procéder comme suit pour les systèmes utilisateurs exécutant Access 2002.

Avertissement Toute utilisation incorrecte de l'Éditeur du Registre peut générer des problèmes sérieux, pouvant vous obliger à réinstaller votre système d'exploitation. Microsoft ne peut pas garantir que les problèmes résultant d'une mauvaise utilisation de l'Éditeur du Registre puissent être résolus. Vous assumez l'ensemble des risques liés à l'utilisation de cet outil. Repérez votre numéro GUID, puis exécutez Msiexec.exe. Pour cela, procédez comme suit :
  1. Fermez tous les programmes en cours d'exécution.
  2. Recherchez le numéro GUID alphanumérique associé au produit Microsoft Office que vous souhaitez mettre à jour. Pour cela, procédez comme suit :
    1. Cliquez sur Démarrer, puis sur Exécuter.
    2. Dans la zone Ouvrir, tapez regedit, puis cliquez sur OK.
    3. Recherchez la clé suivante dans le Registre et cliquez dessus :

      HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall
    4. Sélectionnez le premier dossier {GUID} de 32 caractères répertorié, puis vérifiez si la valeur DisplayName (dans le volet droit) correspond à celle de l'installation Office que vous mettez à jour. Si la valeur DisplayName ne correspond pas à votre installation Office, passez au {GUID} suivant répertorié sous le dossier Uninstall.
    5. Après avoir trouvé la clé {GUID} correcte, vous pouvez copier le nom de la clé en cliquant avec le bouton droit dessus, puis en cliquant sur Copier le nom de clé.
    6. Démarrez le Bloc-notes ou un autre éditeur de texte de votre choix, puis collez le nom de la clé dans le document.
    7. Sélectionnez, puis copiez uniquement le GUID dans le nom de la clé.
  3. Cliquez sur Démarrer, puis sur Exécuter.

    Tapez la commande suivante dans la zone Ouvrir, puis cliquez sur OK :
    msiexec /i guid REINSTALL=AccessFiles,AccessWizards REINSTALLMODE=dmu
    guid est le numéro GUID alphanumérique de 32 caractères associé à ce produit.
  4. Cliquez sur OK lorsqu'un message s'affiche pour vous indiquer que l'installation est terminée.
  5. Cliquez sur Oui si le système vous invite à redémarrer l'ordinateur.

Statut

Microsoft a confirmé l'existence de ce problème dans les produits Microsoft figurant dans la liste des produits concernés par cet article.

Plus d'informations

Après l'installation du Service Pack 2 Office XP et la mise à jour des fichiers de l'Assistant Access 2002 à l'aide de l'utilitaire Msiexec.exe, les fichiers de l'Assistant doivent avoir les attributs de fichier suivants ou ceux d'une version ultérieure :
   Date      Heure   Taille     Nom de fichier
   -------------------------------------------
   05/12/01  04:46   1 662 976  Acwzlib.mde
   05/12/01  04:46   5 345 280  Acwzmain.mde
   25/04/02  02:03   8 019 968  Acwztool.mde
				

Références

Pour plus d'informations sur les numéros GUID et l'utilitaire Msiexec.exe, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
302663 OFFXP : Schéma de numérotation pour les identificateurs globaux uniques (GUID) des codes produits
Pour plus d'informations sur le Service Pack 2 Office XP dans la documentation sur les Service Packs située dans le Kit de ressources Office, reportez-vous au site Web de Microsoft à l'adresse suivante (en anglais) :
http://www.microsoft.com/office/ork/xp/journ/oxpsp2a.htm
Pour plus d'informations sur le Service Pack 3 Office XP dans la documentation sur les Service Packs située dans le Kit de ressources Office, reportez-vous au site Web de Microsoft à l'adresse suivante (en anglais) :
http://www.microsoft.com/office/ork/2003/admin/xp/oxpsp3a.htm

Propriétés

Numéro d'article: 328019 - Dernière mise à jour: mardi 4 février 2014 - Version: 1.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Access 2002
Mots-clés : 
kbnosurvey kbarchive kbbug kbfix KB328019
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com