Gli indici decrescenti di Access 2002 diventano crescenti durante l'upsize a SQL anche dopo l'installazione di Office XP SP2 o Office XP SP3

Traduzione articoli Traduzione articoli
Identificativo articolo: 328019 - Visualizza i prodotti a cui si riferisce l?articolo.
Questo articolo è stato archiviato. L?articolo, quindi, viene offerto ?così come è? e non verrà più aggiornato.
Importante In questo articolo sono contenute informazioni su come modificare il Registro di sistema. Prima di modificare il Registro di sistema, eseguire una copia di backup e assicurarsi di sapere come ripristinarlo in caso di problemi. Per ulteriori informazioni su come eseguire il backup, ripristinare e modificare il Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito (il contenuto potrebbe essere in inglese):
256986 Descrizione del Registro di sistema di Microsoft Windows
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Quando si utilizza l'Upsize guidato in Microsoft Access 2002 per eseguire l'upsize di un database a SQL Server, gli indici decrescenti diventano crescenti nel database risultante.

Nota Questo problema si verifica anche dopo avere installato Microsoft Office XP Service Pack 2 (SP-2) o Microsoft Office XP Service Pack 3 (SP3). Questo problema è stato risolto in Office XP SP-2. Per ulteriori informazioni sul problema descritto nella sezione "Sintomi" di questo articolo, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito (il contenuto potrebbe essere in inglese):
325670 ACC2002: Problemi risolti in Access 2002 da Office XP Service Pack 2

Cause

Questo problema può verificarsi quando si esegue l'Upsize guidato e in seguito si installa Office XP SP-2 o Office XP SP3. Nel contesto del processo di aggiornamento di Office XP SP-2 o Office XP SP3, vengono aggiornati i file della versione non modificati dall'utente. Se si esegue l'Upsize guidato, i file della versione associati alla procedura guidata vengono modificati e vengono considerati da Office XP SP-2 e SP3 come file non della versione modificati dall'utente e non possono essere aggiornati correttamente.

Risoluzione

Per risolvere il problema, scaricare e installare l'aggiornamento di Access 2002: KB833857. Per ulteriori informazioni sull'aggiornamento di Access 2002: KB833857, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito (il contenuto potrebbe essere in inglese):
833857 Descrizione dell'aggiornamento di Microsoft Access 2002 del 23 marzo 2004

Informazioni amministrative

Gli amministratori possono utilizzare altri metodi per risolvere il problema. Gli amministratori di database possono distribuire Office XP Service Pack 2 o Office XP Service Pack 3 utilizzando il metodo descritto nella documentazione del service pack in Office Resource Kit (ORK), quindi applicare la procedura indicata di seguito sui sistemi che eseguono Access 2002.

Avviso L'errato utilizzo dell'editor del Registro di sistema può causare gravi problemi che potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non è in grado di garantire la risoluzione di problemi causati dall'errato utilizzo dell'editor del Registro di sistema. L'utilizzo dell'editor del Registro di sistema è a rischio e pericolo dell'utente. Individuare il numero del proprio GUID, quindi eseguire Msiexec.exe. Per effettuare questa operazione, attenersi alla seguente procedura:
  1. Chiudere tutti i programmi in esecuzione.
  2. Individuare il numero GUID alfanumerico associato al prodotto Microsoft Office che si sta tentando di aggiornare. Per effettuare questa operazione, attenersi alla seguente procedura:
    1. Fare clic sul pulsante Start, quindi scegliere Esegui.
    2. Nella casella Apri digitare Regedit, quindi scegliere OK.
    3. Individuare ed espandere la seguente chiave nel Registro di sistema:

      HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall
    4. Selezionare la prima cartella {GUID} di 32 caratteri visualizzata, quindi controllare il valore DisplayName (nel riquadro di destra) per trovare il valore corrispondente all'installazione di Office da aggiornare. Se il valore DisplayName non corrisponde all'installazione di Office, passare al {GUID} successivo nella cartella Uninstall.
    5. Una volta individuata la chiave {GUID} corretta, è possibile copiare il nome della chiave facendo clic con il pulsante destro del mouse sulla chiave e scegliendo Copia nome chiave.
    6. Avviare il Blocco note o un altro editor di testo e incollare il nome della chiave nel documento.
    7. Selezionare e copiare solo il GUID presente nel nome della chiave.
  3. Fare clic sul pulsante Start, quindi scegliere Esegui.

    Digitare il comando riportato di seguito nella casella Apri, quindi scegliere OK:
    msiexec /i guid REINSTALL=AccessFiles,AccessWizards REINSTALLMODE=dmu
    Dove guid è il numero GUID alfanumerico composto da 32 caratteri, associato al prodotto.
  4. Scegliere OK quando viene visualizzato il messaggio che avvisa che l'installazione è stata completata correttamente.
  5. Scegliere alla richiesta di riavviare il computer.

Status

Microsoft ha confermato che questo problema si verifica con i prodotti elencati alla fine del presente articolo.

Informazioni

Dopo l'installazione di Office XP SP-2 e l'aggiornamento dei file della procedura guidata di Access 2002 mediante l'utilità Msiexec.exe, i file della procedura guidata devono avere i seguenti attributi o successivi:
   Data        Ora       Dimensione  Nome file
   ----------------------------------------------
   05/12/2001  04.46      1.662.976  Acwzlib.mde
   05/12/2001  04.46      5.345.280  Acwzmain.mde
   25/04/2002  02.03      8.019.968  Acwztool.mde
				

Riferimenti

Per ulteriori informazioni sui GUID e sull'utilità Msiexec.exe, fare clic sul numero dell'articolo della Knowledge Base riportato di seguito:
302663 OFFXP: Schema di numerazione per i GUID codice prodotto
Per ulteriori informazioni su Office XP Service Pack 2 nella documentazione del service pack in Office Resource Kit (ORK), visitare il seguente sito Web Microsoft (informazioni in lingua inglese):
http://www.microsoft.com/office/ork/xp/journ/oxpsp2a.htm
Per ulteriori informazioni su Office XP Service Pack 3 nella documentazione del service pack in Office Resource Kit (ORK), visitare il seguente sito Web Microsoft (informazioni in lingua inglese):
http://www.microsoft.com/office/ork/2003/admin/xp/oxpsp3a.htm

Proprietà

Identificativo articolo: 328019 - Ultima modifica: mercoledì 29 gennaio 2014 - Revisione: 1.0
Le informazioni in questo articolo si applicano a
  • Microsoft Access 2002 Standard Edition
Chiavi: 
kbnosurvey kbarchive kbbug kbfix KB328019
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com