Background pages are not displayed in Metadata previews

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Article ID: 328047 - View products that this article applies to.
This article was previously published under Q328047
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SYMPTOMS

When you view the metadata information for each page in a Visio drawing file, the first page preview is shown with additional preview images of changes that were made during previous edits of the first page. Additionally, background page previews are not shown at all for any of the pages.

NOTE: You have to have a third-party or custom program to view this additional metadata. With Microsoft Visio, you can save a preview picture of one or all of the pages in the file; however, Visio displays only a preview of the first page if you use click Preview on the Views menu in the File Open dialog box.

CAUSE

The list that is formulated to sort the pages by foreground pages first and background pages returns the expected page ID for only the first background page and only if the drawing is made up only of background pages. Also, the previews are not reinitialized correctly when a subset of pages is edited. This results in the updated metafile previews of the pages being appended to the existing previews.

RESOLUTION

Service pack information

This problem is corrected in Visio 2002 Service Pack 2.

To resolve this problem, obtain the latest service pack for Visio 2002. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
867749 How to obtain the latest Visio 2002 Service Pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
The global version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date          Time       Size        File name      
   -------------------------------------------------
   09-Sep-2002   5:06 PM    2,658,304   Q328047.msp
				
After the hotfix is installed, the following files will have the listed file attributes or later:
   Date          Time        Version        Size        File name
   ---------------------------------------------------------------
   09-Sep-2002   4:06 PM     10.0.3305.4    68,832      visio.exe
   09-Sep-2002   4:06 PM     10.0.3305.4    6,348,008   vislib.dll
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
This problem was first corrected in Visio 2002 Service Pack 2.

MORE INFORMATION

For more information about about file properties, type about Visio file summary properties in the Ask a question box or the Answer Wizard, and then press ENTER to view the topics.

Properties

Article ID: 328047 - Last Review: October 26, 2013 - Revision: 2.6
APPLIES TO
  • Microsoft Visio 2002 Standard Edition
  • Microsoft Visio 2002 Professional Edition
Keywords: 
kbnosurvey kbarchive kbautohotfix kbhotfixserver kbqfe kbbug kbfix kbqfe KB328047

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