Programm öffnet Datei schreibgeschützt bzw. zeigt Zugriffsverletzung oder Meldung "Zugriff verweigert" an, wenn von einem Netzwerkordner aus geöffnet bzw. in einen Netzwerkordner gespeichert wird

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 328170 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
328170 Program opens a file as read-only or returns a sharing violation or "access denied" message when opening from or saving to a network folder
Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, dass nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachigen Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.
Alles erweitern | Alles schließen

Auf dieser Seite

Problembeschreibung

Wenn Sie einen Netzwerkordner in Windows Explorer öffnen und anschließend eine Datei aus diesem Ordner öffnen bzw. in diesem Ordner speichern möchten, zeigt das entsprechende Programm eine Zugriffsverletzung an, gibt die Fehlermeldung "Zugriff verweigert" aus oder öffnet das Dokument in schreibgeschütztem Zustand. In der Regel tritt dieses Problem auf, wenn Sie einen Netzwerkordner öffnen und danach auf eine Microsoft Word- oder Microsoft Excel-Datei doppelklicken. Das Dokument wird im schreibgeschützten Zustand geöffnet.

Ursache

Dieses Problem kann auftreten, wenn der "Column"-Handler der Microsoft Windows XP-Shell die Inhalte der Datei im Netzwerkordner liest, um zusätzliche Informationen zu beispielsweise Autor oder Thema zu erhalten, während das zugeordnete Programm gleichzeitig versucht, die Datei zu öffnen oder zu speichern.

Lösung

Service Pack-Informationen

Installieren Sie das neueste Service Pack für Microsoft Windows XP, um dieses Problem zu beheben. Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
322389 Wie Sie das neueste Service Pack für Windows XP erhalten

Hotfix-Informationen

Ein Hotfix zur Behebung des Problems ist jetzt bei Microsoft erhältlich. Der Hotfix ist jedoch nur zur Behebung des in diesem Artikel beschriebenen Problems vorgesehen. Deshalb sollten Sie nur Systeme aktualisieren, bei denen dieses spezielle Problem auftritt. Der Hotfix wird unter Umständen zu einem späteren Zeitpunkt weiteren Tests unterzogen. Wenn Ihr System durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfehlen wir, auf das nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Falls der Hotfix zum Download zur Verfügung steht, finden Sie am Anfang dieses Knowledge Base-Artikels den Hinweis "Hotfix-Download ist verfügbar". Ist dies nicht der Fall, wenden Sie sich an die Kundenbetreuung bzw. den Support von Microsoft, um den Hotfix zu erhalten.

Hinweis: Falls weitere Probleme auftreten oder andere Schritte zur Problembehandlung erforderlich sind, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Für zusätzliche Supportanfragen und -belange, die sich nicht auf diesen speziellen Hotfix beziehen, fallen die üblichen Supportgebühren an. Eine vollständige Liste mit Telefonnummern des technischen Supports sowie die Möglichkeit zum Erstellen einer separaten Serviceanfrage finden Sie auf der folgenden Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support
Hinweis: Das Formular "Hotfix-Anfrage" zeigt die Sprachen an, für die der Hotfix verfügbar ist. Falls Ihre Sprache nicht angezeigt wird, gibt es für diese Sprache (noch) keinen Hotfix. Die englische Version dieses Updates weist die in der nachstehenden Tabelle aufgelisteten Dateiattribute (oder höher) auf. Datums- und Uhrzeitangaben für diese Dateien sind in der "Coordinated Universal Time" (UTC) angegeben. Wenn Sie die Dateiinformationen anzeigen, werden diese Angaben in die lokale Zeit konvertiert. Den Unterschied zwischen UTC-Zeit und lokaler Zeit können Sie im Systemsteuerungsprogramm "Datum/Uhrzeit" mithilfe der Registerkarte Zeitzone ermitteln.
Datum       Zeit   Version        Größe      Dateiname
---------------------------------------------------------
15.01.2003  13:00  6.0.2800.1157  8.240.128  Shell32.dll

Hinweis: Hierbei handelt es sich um einen clientseitigen Hotfix, der auf dem Computer installiert werden muss, der auf die Remotefreigabe zugreift.

Abhilfe

Gehen Sie folgendermaßen vor, um dieses Problem zu umgehen:
  1. Öffnen Sie in Windows Explorer den Netzwerkordner, in dem sich die Datei befindet, die Sie öffnen bzw. speichern möchten.
  2. Klicken Sie im Menü Extras auf Ordneroptionen.
  3. Klicken Sie auf Herkömmliche Windows-Ordner verwenden und anschließend auf OK.
Sie können den folgenden Registrierungsschlüssel zu Testzwecken umbenennen. Dadurch wird verhindert, dass die Shell die Datei öffnet und die optionalen Spalteninformationen extrahiert. Ändern Sie den Schlüssel dieses Schlüssels:
HKEY_CLASSES_ROOT\Folder\Shellex\ColumnHandlers\{24F14F01-7B1C-11d1-838f-0000F80461CF}
Verwenden Sie stattdessen folgenden Schlüssel:
HKEY_CLASSES_ROOT\Folder\Shellex\ColumnHandlers\{24F14F01-7B1C-11d1-838f-0000F80461CF}-disable

Status

Microsoft hat bestätigt, dass es sich hierbei um ein Problem bei den in diesem Artikel genannten Microsoft-Produkten handelt. Dieses Problem wurde erstmals in Microsoft Windows XP Service Pack 2 behoben.

Weitere Informationen

Standardmäßig versucht die Windows XP-Shell nach der Installation des Hotfixes nicht mehr, die gesamte Datei zu lesen, um Dateiattribute zu extrahieren, wenn sich die Datei auf einer UNC-Freigabe befindet, die gesamte Datei kann jedoch weiterhin gelesen werden, wenn sich die Daten auf einem verbundenen Laufwerk befinden. Die Pop-Up-Beschreibungen für den Ordner und die Desktop-Elemente zeigen dann für Dateien im Netzwerk nur noch den Typ, die Größe und das Änderungsdatum an.

Gehen Sie folgendermaßen vor, um die zusätzlichen Spalteninformationen anzuzeigen:
  1. Klicken Sie im Menü Ansicht auf Details.
  2. Klicken Sie mit der rechten Maustaste auf die Spaltenüberschrift, und klicken Sie dann auf die Eigenschaften, die Sie anzeigen möchten (aktivierte Eigenschaften werden mit einem Häkchen versehen).
Wenn zusätzliche Spalten angezeigt werden, kann das in diesem Artikel beschriebene Problem auftreten, falls das Programm in dem Moment die Datei exklusiv öffnen will, in dem Windows Explorer die Spaltendaten ausliest. Zeigen Sie keine zusätzlichen Spalteninformationen an, um das Problem zu vermeiden.

Dieser Hotfix behebt auch Probleme, die mit einer geringen Netzwerkleistung in einem WAN oder einem ausgelasteten Netzwerk in Zusammenhang stehen. Da Explorer die Datei nicht mehr über das Netzwerk öffnet, wird der Netzwerkverkehr dadurch deutlich verringert. Weitere Informationen zur Lösung dieses Problems auf verbundenen Laufwerken finden Sie im folgenden Artikel der Microsoft Knowledge Base:
816627 Drucken über TCP/IP-Port kann unter Windows 2000 langsam sein

Eigenschaften

Artikel-ID: 328170 - Geändert am: Freitag, 20. Juni 2008 - Version: 4.6
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbwinxpsp2fix kbenv kbbug kbfix kbwinxppresp2fix KB328170
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com