In un programma un file viene aperto come file in sola lettura oppure viene restituito un messaggio di violazione di condivisione o di "Accesso negato" quando si tenta di aprire o di salvare un file in una cartella di rete

Traduzione articoli Traduzione articoli
Identificativo articolo: 328170 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Se si apre una cartella di rete in Esplora risorse e quindi si tenta di aprire o salvare un file in tale cartella, il programma associato potrebbe restituire un messaggio di violazione di condivisione o di "Accesso negato" oppure il file potrebbe venire aperto in sola lettura. In genere, questo problema si verifica quando si apre una cartella di rete e quindi si fa doppio clic per aprire un file di Microsoft Word o di Microsoft Excel. Il documento viene aperto in sola lettura.

Cause

Questo problema può verificarsi quando il gestore di colonne della shell di Microsoft Windows XP legge il contenuto del file nella cartella di rete per ottenere ulteriori informazioni, quali l'autore o l'oggetto, nello stesso momento in cui il programma associato tenta di aprire o salvare il file.

Risoluzione

Informazioni sul service pack

Per risolvere il problema, procurarsi il service pack più recente per Microsoft Windows XP. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
322389 Come ottenere il service pack più recente per Windows XP

Informazioni sull'aggiornamento rapido (hotfix)

È disponibile una correzione supportata da Microsoft, che è tuttavia destinata esclusivamente alla correzione del problema descritto in questo articolo. Utilizzarla solo nei computer in cui si verifica questo problema specifico. È possibile che su questa correzione vengano eseguite ulteriori verifiche. Se pertanto questo problema non causa gravi difficoltà, si consiglia di attendere la versione successiva del service pack di Windows XP contenente tale correzione.

Per risolvere immediatamente il problema, contattare il Servizio Supporto Tecnico Clienti Microsoft per ottenere la correzione. Per un elenco completo di numeri di telefono del Servizio Supporto Tecnico Clienti Microsoft e per informazioni sui costi dell'assistenza, visitare il sito Web Microsoft all'indirizzo:
http://support.microsoft.com/default.aspx?scid=fh;[LN];CNTACTMS
NOTA: in casi particolari, le spese normalmente addebitate per le chiamate al Servizio Supporto Tecnico Clienti Microsoft potrebbero essere annullate qualora un addetto del Servizio Supporto Tecnico Clienti Microsoft dovesse determinare che uno specifico aggiornamento risolverà il problema. I normali costi dell'assistenza verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico aggiornamento in questione.

La versione in lingua inglese di questa correzione presenta gli attributi di file elencati nella tabella seguente (o attributi successivi). Date e ore elencate di seguito sono espresse in UTC. Quando si visualizzano le informazioni sul file, l'ora viene convertita in ora locale. Per calcolare la differenza tra l'ora UTC e quella locale, utilizzare la scheda Fuso orario dello strumento Data e ora del Pannello di controllo.
   Data         Ora    Versione       Dimensione  Nome file
   ----------------------------------------------------------
   15/01/2003   13.00  6.0.2800.1161   8.240.128  Shell32.dll
				

Note Questa è una correzione relativa al lato client che deve essere installata sul computer che ha accesso alla condivisione remota.

Workaround

Per aggirare il problema, attenersi alla procedura seguente:
  1. In Esplora risorse aprire la cartella di rete contenente il file che si sta tentando di aprire o salvare.
  2. Scegliere Opzioni cartella dal menu Strumenti.
  3. Fare clic su Usa cartelle di Windows, quindi scegliere OK.
Ai fini di una verifica, è possibile rinominare la seguente chiave del Registro di sistema. In questo modo si impedirà alla shell di aprire il file e di estrarre le informazioni facoltative sulla colonna. Cambiare la chiave seguente:
HKEY_CLASSES_ROOT\Folder\Shellex\ColumnHandlers\{24F14F01-7B1C-11d1-838f-0000F80461CF}
Utilizzare al suo posto la chiave:
HKEY_CLASSES_ROOT\Folder\Shellex\ColumnHandlers\{24F14F01-7B1C-11d1-838f-0000F80461CF}-disable

Status

Microsoft ha confermato che questo problema si verifica con i prodotti elencati alla fine del presente articolo. Questo problema è stato corretto per la prima volta nel Service Pack 2 per Microsoft Windows XP.

Informazioni

Per impostazione predefinita, una volta installato l'aggiornamento automatico, la shell di Windows XP non tenterà più di leggere l'intero file per estrarne degli attributi quando questo si trova in una condivisione UNC, tuttavia l'intero file potrebbe ancora essere letto se i dati si trovano su un'unità mappata. Nella descrizione rapida delle cartelle e degli oggetti del desktop verranno solo visualizzati il tipo, la dimensione e la data di modifica per i file che si trovano nella rete.

Per visualizzare informazioni di colonne aggiuntive, attenersi alla seguente procedura:
  1. Scegliere Dettagli dal menu Visualizza.
  2. Fare clic con il pulsante destro del mouse sull'intestazione della colonna, quindi fare clic per aggiungere un segno di spunta accanto agli attributi aggiuntivi che si desidera vengano visualizzati.
Se vengono visualizzate colonne aggiuntive, è possibile che il problema descritto in questo articolo si verifichi quando il programma tenta di aprire il file in modo esclusivo nello stesso tempo in cui Esplora risorse sta estraendo i dati di colonna. Per impedire il verificarsi del problema, non visualizzare informazioni di colonne aggiuntive.

Questo aggiornamento rapido risolve anche problemi di degrado delle prestazioni di rete su una WAN (Wide Area Network) o una rete saturata. Poiché in Esplora risorse il file non viene più aperto in modalità remota, il traffico di rete risulta notevolmente ridotto.

Per ulteriori informazioni sulla risoluzione di questo problema sulle unità mappate, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito (il contenuto potrebbe essere in inglese):
816627 La stampa sulla porta TCP/IP potrebbe essere lenta in Windows 2000

Proprietà

Identificativo articolo: 328170 - Ultima modifica: venerdì 31 marzo 2006 - Revisione: 4.1
Le informazioni in questo articolo si applicano a
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
Chiavi: 
kbqfe kbhotfixserver kbwinxpsp2fix kbenv kbbug kbfix kbwinxppresp2fix KB328170
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com