Einige Programme funktionieren beim Öffnen großer Dateien nicht erwartungsgemäß

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Artikel-ID: 328237 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
328237 Some programs do not work as expected when large files are opened
Wichtig: Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Sie sollten eine Sicherungskopie der Registrierung erstellen, bevor Sie die Registrierung bearbeiten. Sie müssen wissen, wie die Registrierung wiederhergestellt werden kann, wenn ein Problem auftritt. Weitere Informationen zum Erstellen einer Sicherungskopie, zum Wiederherstellen und Bearbeiten der Registrierung finden Sie im folgenden Artikel der Microsoft Knowledge Base:
322756 Unter Windows XP und Windows Server 2003 eine Sicherungskopie der Registrierung erstellen und die Registrierung bearbeiten und wiederherstellen
Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, dass nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachigen Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.
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Problembeschreibung

Bestimmte Programme, beispielsweise Microsoft Excel und Microsoft Word, funktionieren beim Öffnen mittelgroßer bis großer Dateien nicht erwartungsgemäß. Eine Netzwerkablaufverfolgung zeigt, dass der Redirector sequenzielle Lesevorgänge mit einer Größe von 4 bis 8 KB ausgibt. Die Ablaufverfolgung zeigt beim Lesen großer Dateien eine hohe Anzahl kleiner von einem Programm bereitgestellter Lesevorgänge an.

Ursache

Dieses Problem tritt auf, weil der Redirector die ReadAhead-Funktion nicht verwendet.

Lösung

Windows Server 2003

Installieren Sie das neueste Service Pack für Windows Server 2003, um das Problem zu beheben. Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
889100 So erhalten Sie das neueste Service Pack für Windows Server 2003
Hinweis: Falls die Anwendung große Dateien sequenziell liest, müssen Sie für den Registrierungseintrag
ReadAheadGranularity
manuell den Wert 8 eingeben. Weitere Hinweise finden Sie im Abschnitt "Weitere Informationen" in diesem Artikel.

Windows XP

Service Pack-Informationen

Installieren Sie das aktuelle Service Pack für Windows XP, um dieses Problem zu beheben. Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
322389 Wie Sie das neueste Service Pack für Windows XP erhalten

Hotfix-Informationen

Ein Hotfix zur Behebung des Problems ist jetzt bei Microsoft erhältlich. Der Hotfix ist jedoch nur zur Behebung des in diesem Artikel beschriebenen Problems vorgesehen. Deshalb sollten Sie nur Systeme aktualisieren, bei denen dieses spezielle Problem auftritt. Der Hotfix wird unter Umständen zu einem späteren Zeitpunkt weiteren Tests unterzogen. Wenn Ihr System durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfehlen wir, auf das nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Falls der Hotfix zum Download zur Verfügung steht, finden Sie am Anfang dieses Knowledge Base-Artikels den Hinweis "Hotfix-Download ist verfügbar". Ist dies nicht der Fall, wenden Sie sich an die Kundenbetreuung bzw. den Support von Microsoft, um den Hotfix zu erhalten.

Hinweis: Falls weitere Probleme auftreten oder andere Schritte zur Problembehandlung erforderlich sind, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Für zusätzliche Supportanfragen und -belange, die sich nicht auf diesen speziellen Hotfix beziehen, fallen die üblichen Supportgebühren an. Eine vollständige Liste mit Telefonnummern des technischen Supports sowie die Möglichkeit zum Erstellen einer separaten Serviceanfrage finden Sie auf der folgenden Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support
Hinweis: Das Formular "Hotfix-Anfrage" zeigt die Sprachen an, für die der Hotfix verfügbar ist. Falls Ihre Sprache nicht angezeigt wird, gibt es für diese Sprache (noch) keinen Hotfix.
Dateiinformationen
Die englische Version dieses Hotfixes weist die in der nachstehenden Tabelle aufgelisteten Dateiattribute (oder höher) auf. Datums- und Uhrzeitangaben für diese Dateien sind in der "Coordinated Universal Time" (UTC) angegeben. Wenn Sie die Dateiinformationen anzeigen, werden diese Angaben in die lokale Zeit konvertiert. Den Unterschied zwischen UTC-Zeit und lokaler Zeit können Sie in der Systemsteuerung unter "Datum und Uhrzeit" mithilfe der Angaben auf der Registerkarte Zeitzone ermitteln.
   Datum       Uhrzeit   Version         Größe      Dateiname
   --------------------------------------------------------------
   24.06.2003  18:11     5.1.2600.1239     401.920  Mrxsmb.sys
   24.06.2003  18:11     5.1.2600.1239     156.160  Rdbss.sys

   27.06.2003  01:17     5.1.2600.1239      92.160  Cscdll.dll       
   27.06.2003  01:17     5.1.2600.1239   1.120.256  Ole32.dll        

Windows 2000

Hotfix-Informationen

Ein Hotfix zur Behebung des Problems ist bei Microsoft erhältlich. Der Hotfix ist jedoch nur zur Behebung des in diesem Artikel beschriebenen Problems vorgesehen. Deshalb sollten Sie nur Systeme aktualisieren, bei denen dieses spezielle Problem auftritt. Der Hotfix wird unter Umständen zu einem späteren Zeitpunkt weiteren Tests unterzogen. Wenn Ihr System durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfehlen wir, auf das nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Falls der Hotfix zum Download zur Verfügung steht, finden Sie am Anfang dieses Knowledge Base-Artikels den Hinweis "Hotfix-Download ist verfügbar". Ist dies nicht der Fall, wenden Sie sich an die Kundenbetreuung von Microsoft, um den Hotfix zu erhalten.

Hinweis: Falls weitere Probleme auftreten oder andere Schritte zur Problembehandlung erforderlich sind, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Für zusätzliche Supportanfragen und -belange, die sich nicht auf diesen speziellen Hotfix beziehen, fallen die üblichen Supportgebühren an. Eine vollständige Liste mit Telefonnummern des technischen Supports sowie die Möglichkeit zum Erstellen einer separaten Serviceanfrage finden Sie auf der folgenden Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support
Hinweis: Über den Link im Abschnitt "Hotfix-Download ist verfügbar" gelangen Sie zum Hotfix-Anfrageformular. Hier können Sie die Sprachen anzeigen, für die der Hotfix zur Verfügung steht. Falls Ihre Sprache nicht angezeigt wird, gibt es für diese Sprache (noch) keinen Hotfix.
Dateiinformationen
Die englische Version dieses Hotfixes weist die in der nachstehenden Tabelle aufgelisteten Dateiattribute (oder höher) auf. Datums- und Uhrzeitangaben für diese Dateien sind in der "Coordinated Universal Time" (UTC) angegeben. Wenn Sie die Dateiinformationen anzeigen, werden diese Angaben in die lokale Zeit konvertiert. Den Unterschied zwischen UTC-Zeit und lokaler Zeit können Sie in der Systemsteuerung unter "Datum und Uhrzeit" mithilfe der Angaben auf der Registerkarte Zeitzone ermitteln.
   Datum       Uhrzeit  Version           Größe    Dateiname
   ------------------------------------------------------------
   20.06.2003  18:29    5.0.2195.6760     407.792  Mrxsmb.sys
   20.06.2003  18:29    5.0.2195.6760     169.520  Rdbss.sys

   20.06.2003  18:50    5.0.2195.6760     944.400  Ole32.dll        
   20.06.2003  18:50    5.0.2195.6753     432.400  Rpcrt4.dll       
   20.06.2003  18:50    5.0.2195.6760     187.664  Rpcss.dll        

Status

Microsoft hat bestätigt, dass es sich hierbei um ein Problem bei den in diesem Artikel genannten Microsoft-Produkten handelt. Dieses Problem wurde erstmals in Microsoft Windows XP Service Pack 2 behoben.

Weitere Informationen

Warnung: Durch die falsche Bearbeitung der Registrierung mithilfe des Registrierungs-Editors oder einer anderen Methode können schwerwiegende Probleme verursacht werden. Diese Probleme können eine Neuinstallation des Betriebssystems erforderlich machen. Microsoft kann nicht garantieren, dass Probleme, die von einer falschen Verwendung des Registrierungs-Editors herrühren, behoben werden können. Benutzen Sie den Registrierungs-Editor auf eigene Verantwortung.

Der Redirector wurde so verbessert, dass er für sequenzielle Lesevorgänge die ReadAhead-Funktion verwendet. Wenn ein Programm Segmente von 4 KB oder 8 KB nacheinander liest, verwendet der Redirector daher den Cache-Manager und liest die Daten bereits im Voraus in den Zwischenspeicher, indem er einen größeren Datensatz liest.

Außerdem wurde der folgende Registrierungseintrag hinzugefügt, um die ReadAhead-Größe zu kontrollieren:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanWorkStation\Parameters


Name: ReadAheadGranularity
Datentyp: REG_DWORD
Wert: Anzahl der vorauszulesenden Seiten. Der gültige Bereich reicht von 0 bis 16. Die Standardeinstellung liegt bei 8 Seiten (32 KB).
Die Funktion "ReadAhead" ist bei installiertem Hotfix 894463 deaktiviert. Sie müssen daher den Registrierungseintrag "ReadAheadGranularity" manuell hinzufügen. Gehen Sie hierzu folgendermaßen vor:
  1. Klicken Sie auf Start und auf Ausführen, geben Sie regedit ein, und klicken Sie auf OK.
  2. Klicken Sie mit der rechten Maustaste auf den folgenden Unterschlüssel in der Registrierung:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanWorkStation\Parameters
  3. Zeigen Sie im Menü Bearbeiten auf Neu, und klicken Sie anschließend auf DWORD-Wert.
  4. Geben Sie ReadAheadGranularity ein, und drücken Sie anschließend die [EINGABETASTE].
  5. Klicken Sie im Menü Bearbeiten auf Ändern.
  6. Klicken Sie auf Dezimal, geben Sie im Feld Wert den Wert 8 ein, und klicken Sie auf OK.
Hinweis: Es gibt nur sehr wenige Szenarios, in denen Sie die den Registrierungseintrag
ReadAheadGranularity
ändern müssen. Sie müssen diese Einstellung beispielsweise auf einer verlustreichen WAN-Verbindung oder einem stark ausgelasteten Terminal Server auf eine Einstellung von 4 ändern (diese Einstellung gleicht einem Lesevorgang der Größe 16 KB). Wenn Windows große Dateien sequenziell liest, ist die Leistung des Programms normalerweise höher, wenn das Programm größere Lesevorgänge bereitstellt. Weitere Informationen dazu, wie Sie einen Hotfix für Windows 2000 Datacenter Server erhalten können, finden Sie im folgenden Artikel der Microsoft Knowledge Base:
265173 Das Datacenter-Programm und das Windows 2000 Datacenter Server-Produkt

Eigenschaften

Artikel-ID: 328237 - Geändert am: Freitag, 20. Juni 2008 - Version: 4.5
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows XP Professional
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Keywords: 
kbautohotfix kbhotfixserver kbwinxpsp2fix kbwinxppresp2fix kbwin2000presp5fix kbqfe kbbug kbfix KB328237
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