Funzionamento imprevisto di alcuni programmi quando si aprono file di grandi dimensioni

Traduzione articoli Traduzione articoli
Identificativo articolo: 328237 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Alcuni programmi come Microsoft Excel e Microsoft Word non funzionano correttamente quando si aprono file di medie o grandi dimensioni. Da un network trace risulta che dal redirector vengono fornite letture sequenziali dai 4 agli 8 KB. La traccia consente di visualizzare un numero elevato di letture di piccole dimensioni inviate dal programma quando vengono aperti file di grandi dimensioni.

Cause

Questo problema si verifica perché il redirector non utilizza la funzionalità ReadAhead.

Risoluzione

Windows XP

Informazioni sul service pack

Per risolvere il problema, procurarsi l'ultimo service pack per Windows XP. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
322389 Come ottenere il service pack più recente per Windows XP

Informazioni sull'hotfix

È disponibile un hotfix supportato da Microsoft, che è tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Utilizzarlo solo nei sistemi in cui si verifica questo problema specifico. È possibile che su questo hotfix vengano eseguiti ulteriori test. Se pertanto questo problema non causa gravi difficoltà, si consiglia di attendere la versione successiva del service pack di Windows XP contenente tale hotfix.

Per risolvere immediatamente il problema, contattare il Servizio Supporto Tecnico Clienti Microsoft per ottenere l'hotfix. Per un elenco completo di numeri di telefono del Servizio Supporto Tecnico Clienti Microsoft e per informazioni sui costi dell'assistenza, visitare il sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota In casi particolari, le spese normalmente addebitate per le chiamate al Servizio Supporto Tecnico Clienti Microsoft potrebbero essere annullate qualora un addetto del Servizio Supporto Tecnico Clienti Microsoft dovesse determinare che uno specifico aggiornamento risolverà il problema. I normali costi del Servizio Supporto Tecnico Clienti Microsoft verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico aggiornamento in questione.
Informazioni sui file
La versione in lingua inglese di questo hotfix presenta gli attributi di file elencati nella tabella seguente (o attributi successivi). Date e ore elencate di seguito sono espresse in UTC (Universal Time Coordinate). Quando si visualizzano le informazioni sui file, l'ora viene convertita in ora locale. Per calcolare la differenza tra l'ora UTC e quella locale, utilizzare la scheda Fuso orario dello strumento Data e ora del Pannello di controllo.
   Data        Ora    Versione       Dimensioni  Nome file
   --------------------------------------------------------
   24/06/2003  18.11  5.1.2600.1239     401.920  Mrxsmb.sys
   24/06/2003  18.11  5.1.2600.1239     156.160  Rdbss.sys

   27/06/2003  01.17  5.1.2600.1239      92.160  Cscdll.dll       
   27/06/2003  01.17  5.1.2600.1239   1.120.256  Ole32.dll

Windows 2000

Informazioni sull'hotfix

È disponibile un hotfix supportato da Microsoft, che è tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Utilizzarlo solo nei sistemi in cui si verifica questo problema specifico. È possibile che su questo hotfix vengano eseguiti ulteriori test. Se pertanto questo problema non causa gravi difficoltà, si consiglia di attendere la versione successiva del service pack di Windows 2000 contenente tale hotfix.

Per risolvere immediatamente il problema, contattare il Servizio Supporto Tecnico Clienti Microsoft per ottenere l'hotfix. Per un elenco completo di numeri di telefono del Servizio Supporto Tecnico Clienti Microsoft e per informazioni sui costi dell'assistenza, visitare il sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota In casi particolari, le spese normalmente addebitate per le chiamate al Servizio Supporto Tecnico Clienti Microsoft potrebbero essere annullate qualora un addetto del Servizio Supporto Tecnico Clienti Microsoft dovesse determinare che uno specifico aggiornamento risolverà il problema. I normali costi del Servizio Supporto Tecnico Clienti Microsoft verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico aggiornamento in questione.
Informazioni sui file
La versione in lingua inglese di questo hotfix presenta gli attributi di file elencati nella tabella seguente (o attributi successivi). Date e ore elencate di seguito sono espresse in UTC (Universal Time Coordinate). Quando si visualizzano le informazioni sui file, l'ora viene convertita in ora locale. Per calcolare la differenza tra l'ora UTC e quella locale, utilizzare la scheda Fuso orario dello strumento Data e ora del Pannello di controllo.
   Data        Ora    Versione        Dimensioni  Nome file
   ---------------------------------------------------------
   20/06/2003  18.29  5.0.2195.6760      407.792  Mrxsmb.sys
   20/06/2003  18.29  5.0.2195.6760      169.520  Rdbss.sys

   20/06/2003  18.50  5.0.2195.6760      944.400  Ole32.dll        
   20/06/2003  18.50  5.0.2195.6753      432.400  Rpcrt4.dll       
   20/06/2003  18.50  5.0.2195.6760      187.664  Rpcss.dll

Status

Microsoft ha confermato che questo problema si verifica con i prodotti elencati nella sezione "Le informazioni in questo articolo si applicano a" del presente articolo. Questo problema è stato corretto per la prima volta in Microsoft Windows XP Service Pack 2.

Informazioni

Il redirector è stato migliorato per consentire la funzionalità ReadAhead su letture sequenziali. Di conseguenza quando da un programma vengono letti segmenti da 4 o 8 KB in modo sequenziale, il redirector attiva il gestore della cache per effettuare la prelettura dei dati da memorizzare leggendo una quantità elevata di dati.

È stata inoltre introdotta la seguente voce del Registro di sistema per controllare la dimensione di ReadAhead:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanWorkStation\Parameters


Nome valore: ReadAheadGranularity
Tipo dati: REG_DWORD
Dati valore: Numero di pagine di readahead. L'intervallo valido è compreso tra 0 e 16. L'impostazione predefinita è 8 pagine (32 KB).
Se viene installato l'hotfix 894463, la funzione ReadAhead è disattivata. Di conseguenza è necessario immettere manualmente la voce del Registro di sistema ReadAheadGranularity. Per effettuare questa operazione, attenersi alla seguente procedura:
  1. Fare clic sul pulsante Start, scegliere Esegui, digitare regedit, quindi scegliere OK.
  2. Individuare e fare clic con il pulsante destro del mouse sulla sottochiave del Registro di sistema seguente:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanWorkStation\Parameters
  3. Scegliere Nuovo dal menu Modifica, quindi fare clic su Valore DWORD.
  4. Digitare ReadAheadGranularity, quindi premere INVIO.
  5. Scegliere Modifica dal menu Modifica.
  6. Fare doppio clic su Decimale, digitare 8 nella casella Dati valore, quindi scegliere OK.
Nota In alcuni scenari è possibile che sia necessario modificare la voce del Registro di sistema
ReadAheadGranularity
. Ad esempio potrebbe essere necessario modificarla per un collegamento WAN con perdita di dati o per un Terminal server interessato da un carico di lavoro eccessivo impostandola su 4, equivalente a una dimensione di lettura di 16 KB. In genere quando in Windows vengono letti in sequenza file di grandi dimensioni, le prestazioni del programma risultano migliori con impostazioni maggiori delle dimensioni di lettura. Per ulteriori informazioni su come ottenere un hotfix per Windows 2000 Datacenter Server, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
265173 Il programma Datacenter e il prodotto Windows 2000 Datacenter Server

Proprietà

Identificativo articolo: 328237 - Ultima modifica: martedì 23 gennaio 2007 - Revisione: 4.1
Le informazioni in questo articolo si applicano a
  • Microsoft Windows XP Professional
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
Chiavi: 
kbhotfixserver kbwinxpsp2fix kbwinxppresp2fix kbwin2000presp5fix kbqfe kbbug kbfix KB328237
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com