オフラインで利用できるように構成されていないファイルやフォルダがキャッシュされる

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文書番号: 328284 - 対象製品
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目次

現象

キャッシュする (つまりオフラインで利用できるようにする) よう構成されていないファイルやフォルダのいくつかが、キャッシュされることがあります。これらのファイルやフォルダがシステムによってピンされた (つまり Windows が自動的にそれらのファイルやフォルダを要求した) ことは、CSCsniff ツールによって示されます。

: CSCsniff ツールは、オフライン ファイルに関する問題のトラブルシューティング用にサポート担当者がユーザーに提供できる Microsoft Product Support Services (PSS) 内部ツールです。

原因

この問題は、キャッシュするよう構成されているファイルやフォルダに、分散ファイル システム (DFS) 共有上でホストされたファイルやフォルダへのリンクが含まれる場合に発生することがあります。管理キャッシュ アルゴリズム (管理ピン コード) では、ピンを行う前にリンク対象が "キャッシュ可能" かどうかは確認されません。

以下の構成により、ファイルおよびフォルダがキャッシュされるようになります。
  • [[オフライン ファイル] のユーザー構成を無効にする] ポリシー設定が有効である。
  • The [[オフラインで使用する] を無効にする] ポリシー設定が有効である。
  • ファイルおよびフォルダが、[管理的に割り当てられたオフライン ファイル] ポリシー設定の一覧に含まれている。
  • 分散ファイル システムがキャッシュ設定をオフにするよう明示的に構成されていない、つまり、[この共有フォルダで、キャッシュを可能にする] 設定が共有に対して有効である。
この構成を適切に行うことで、[管理的に割り当てられたオフライン ファイル] 設定の一覧に含まれているファイルおよびフォルダのみがキャッシュされます。最初の 2 つのポリシー設定により、分散ファイル システム共有にあるファイルおよびフォルダをオフラインで使用可能にすることができなくなるため、分散ファイル システム共有の内容はキャッシュされなくなります。

ただし、[管理的に割り当てられたオフライン ファイル] 設定の一覧に含まれているファイルおよびフォルダに、分散ファイル システム共有上に配置されたファイルまたはフォルダへのショートカット (リンク) が含まれている場合は、リンク対象のファイルまたはフォルダもキャッシュされます。この現象は、Windows オフライン ファイル機能が分散ファイル システム共有上のファイルおよびフォルダのキャッシュを完全にはサポートしていなくても発生します。

解決方法

Service Pack の情報

この問題を解決するには、Microsoft Windows 2000 の最新の Service Pack を入手します。関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
260910 最新の Windows 2000 Service Pack の入手方法

修正プログラムの情報

マイクロソフトでは、この問題を修正する修正プログラムを提供しています。ただし、この修正プログラムは、この資料に記載されている問題のみを修正することを目的としたものです。この修正プログラムは、ここで説明する問題が発生しているシステムにのみ適用してください。

修正プログラムをダウンロードできる場合は、この「サポート技術情報」 (Microsoft Knowledge Base) の資料の上部に「修正プログラムのダウンロード」セクションがあります。このセクションが表示されていない場合は、Microsoft Customer Service and Support にリクエストを送信し、修正プログラムを入手してください。

: 別の問題が発生した場合、またはトラブルシューティングが必要な場合には、別のサービス リクエストを作成しなければならない場合があります。特定の修正プログラムの対象とならない追加の質問および問題については、通常のサポート料金が適用されます。Microsoft Customer Service and Support の電話番号一覧または別のサービス リクエストの作成については、次のマイクロソフト Web サイトを参照してください。
http://support.microsoft.com/contactus/?ws=support
:「ダウンロード」フォームには、修正プログラムを入手できる言語が表示されます。使用している言語が表示されない場合は、その言語の修正プログラムが存在しないことになります。 修正プログラム (英語版) のファイル属性は次の表のとおりです。ただし、これより新しい修正プログラムがリリースされている可能性もあります。これらのファイルの日付と時刻は世界協定時刻 (UTC) で表示されます。ファイル情報に表示される時刻は、ローカル時刻に変換されています。UTC とローカル時刻との時差を確認するには、コントロール パネルの [日付と時刻] の [タイム ゾーン] タブを使用してください。
   日付         時刻   バージョン        サイズ     ファイル名 ------------------------------------------------------ 2002/10/01  10:27  5.0.2195.6062  101,136  Cscdll.dll 2002/10/01  10:27  5.0.2195.6076  238,864  Cscui.dll 2002/09/26  11:24  5.0.2195.6073  371,856  Mrxsmb.sys 2002/09/26  11:24  5.0.2195.6073  132,816  Rdbss.sys

状況

マイクロソフトでは、この問題をこの資料の冒頭に記載したマイクロソフト製品の問題として認識しています。 この問題は、Microsoft Windows 2000 Service Pack 4 で修正済みです。

詳細

Windows 2000 Datacenter Server 用の修正プログラムを入手する方法の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
265173 Windows Datacenter プログラムおよび Windows 2000 Datacenter Server

プロパティ

文書番号: 328284 - 最終更新日: 2008年10月3日 - リビジョン: 2.7
この資料は以下の製品について記述したものです。
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional
キーワード:?
kbautohotfix kbhotfixserver kbqfe kbqfe kbwin2ksp4fix kbbug kbfix kbwin2000presp4fix KB328284
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

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