Article ID: 328311 - Last Review: February 21, 2007 - Revision: 1.9

SharePoint Portal Server May Stop Responding When Processing a VBScript Web Part

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This article was previously published under Q328311
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SYMPTOMS

SharePoint Portal Server can create a VBScript Web Part. If a user creates a VBScript Web Part that uses the Microsoft OLE DB provider for Internet Publishing (Msdaipp.dll), the portal may stop responding. You must restart the SharePoint Portal Server services for the portal to start responding. The following sample code uses the Microsoft OLE DB provider for Internet Publishing:
Dim oConn 'As ADODB.Connection
Dim oRs 'As ADODB.RecordSet

Set oConn = Server.CreateObject("ADODB.Connection")
Set oRs = Server.CreateObject("ADODB.Recordset")

oConn.Provider = "msdaipp.dso"
oConn.Properties.Item("Prompt") = 4
oConn.Properties.Item("Flush WinInet Password Cache").Value = True
				

CAUSE

This problems occurs because the Microsoft OLE DB provider for Internet Publishing (Msdaipp.dll) is incorrectly adding a refcount to an object. When ActiveX Data Objects (ADO) calls to release all the objects, Msdaipp.dll still has an object that has a refcount. If Msdaipp.dll does not release the object, the critical section is not released. When the critical section is not released, the other threads must wait. If all the threads are in a wait state, the portal stops responding.

RESOLUTION

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version         Size       File name
----------------------------------------------------------
26-Sep-2002  14:34  10.145.4629.34  1,187,840  Msdaipp.dll

				
Note Because of file dependencies, this update requires Microsoft SharePoint Portal Server 2001 To resolve this problem, obtain the latest service pack for Microsoft SharePoint Portal Server 2001. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
312963  (http://support.microsoft.com/kb/312963/EN-US/ ) How to Obtain the Latest SharePoint Portal Server 2001 Service Pack

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

APPLIES TO
  • Microsoft SharePoint Portal Server 2001
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbbug kbfix kbshareptportalsvr2001presp2fix KB328311
 

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