A diretiva "NoDesktop" causa problemas de exibição de área de trabalho

Traduções deste artigo Traduções deste artigo
ID do artigo: 328596 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Se um usuário pressiona a combinação de teclas logotipo Windows + D, ou clicar com botão direito do mouse a barra de tarefas e, em seguida, clicar em Mostrar a área de trabalho , todos os programas são minimizados conforme o esperado, mas o usuário, em seguida, pode receber uma mensagem de erro informando que uma restrição de diretiva esteja in-loco. A área de trabalho, em seguida, está visível. No entanto, se o usuário pressiona o logotipo Windows + D novamente, ou clicar com botão direito do mouse a barra de tarefas e clicar em Mostrar janelas abertas , o usuário recebe a mesma mensagem de erro e nenhuma das janelas são restauradas.

Esses sintomas podem ocorrer se você tiver a diretiva "NoDesktop" em vigor (essa diretiva tem um nome "amigável" de "Ocultar e desativar todos os itens na área de trabalho").

Causa

Quando a área de trabalho é mostrada, ele recebe um comando para redesenhar os ícones. Como os ícones estão desativados, o usuário recebe a mensagem de erro. As mesmas etapas ocorrem quando as janelas são restauradas (basicamente na ordem inversa). Isso não funciona devido a uma diretiva de restrição de.

Resolução

Informações sobre o service pack

Para resolver esse problema, obtenha o service pack mais recente para o Microsoft Windows XP. Para obter informações adicionais, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
322389Como obter o service pack mais recente do Windows XP

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.A versão em inglês deste hotfix apresenta os atributos de arquivo (ou posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas na acordo hora universal coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário na ferramenta Data e hora no painel de controle.
   Date         Time   Version        Size        File name     Platform  SP
   ---------------------------------------------------------------------------
   12-Sep-2002  20:54  6.0.2600.100    8,222,720  Shell32.dll   x86        none
   12-Sep-2002  01:50  6.0.2800.1120   8,238,592  Shell32.dll   x86        1
   12-Sep-2002  20:55  6.0.2600.100   14,314,496  Shell32.dll   IA-64      none
   12-Sep-2002  00:20  6.0.2600.100    8,222,720  Wshell32.dll  IA-64      none
   12-Sep-2002  01:50  6.0.2800.1120  14,362,112  Shell32.dll   IA-64      1
   11-Sep-2002  20:20  6.0.2800.1120   8,238,592  Wshell32.dll  IA-64      1

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".Esse problema foi corrigido primeiro no Microsoft Windows XP Service Pack 2.

Propriedades

ID do artigo: 328596 - Última revisão: terça-feira, 5 de junho de 2007 - Revisão: 2.6
A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Professional
Palavras-chave: 
kbmt kbautohotfix kbhotfixserver kbqfe kbqfe kbwinxpsp2fix kbbug kbfix kbwinxppresp2fix KB328596 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 328596

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com