W profilu mobilnym gromadzą się dodatkowe pliki .tmp

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 328607 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Rozwiń wszystko | Zwiń wszystko

Na tej stronie

Symptomy

W profilu mobilnym mogą gromadzić się dodatkowe pliki o nazwie Prf*.tmp, a w dzienniku zdarzeń aplikacji może zostać zarejestrowany następujący komunikat o błędzie:
Typ zdarzenia: Błąd
Źródło zdarzenia: Userenv
Kategoria zdarzenia: Brak
Identyfikator zdarzenia: 1000
Data: data
Godzina: godzina
Użytkownik: S-1-5-21-#########-##########-##########-####
Komputer: Nazwa komputera
Opis:
System Windows nie może skopiować pliku \\nazwa_serwera\udział\...\Prf???.tmp do lokacji R:\Documents and Settings\...\Prf???.tmp. Skontaktuj się z administratorem sieci.
SZCZEGÓŁY — Nie można utworzyć pliku, który już istnieje.

Przyczyna

Ten problem może wystąpić, jeżeli usługa indeksowania lub inny proces (np. agent otwierania plików) otworzył wskazany plik tymczasowy podczas synchronizacji profilu. Jeżeli tak się stanie, plik tymczasowy nie zostanie usunięty. Zostanie natomiast załadowany wraz z profilem mobilnym po wylogowaniu się i uzgodniony z profilem lokalnym podczas ponownego logowania.

Wprawdzie podobny efekt może być powodowany także przez programy antywirusowe, jednak ich znaczenie jest raczej marginalne, ponieważ procesy takie wykonują mniej operacji na plikach niż usługa indeksowania i agent otwierania plików.

Rozwiązanie

W celu obejścia tego problemu należy zastosować jedną z następujących metod:
  • Wyłącz oprogramowanie lub usługę powodujące konflikt z aparatem profilu.

    -lub-
  • Wyklucz foldery profilów z zakresu działania funkcji skanującej lub monitorującej, która powoduje konflikt.
Firma Microsoft zaleca, aby przed usunięciem plików sprawdzić, czy nie zawierają one przydatnych danych. Aparat profilu nie usuwa plików Prf*.tmp zawierających zbędne informacje, aby uniknąć potencjalnej utraty danych.

Stan

To zachowanie jest zgodne z projektem. Uzgadnianie profili jest szczególnie przydatne w przeciwdziałaniu błędom utraty danych poprzez zachowanie plików tymczasowych.

Więcej informacji

Opis szczegółowy

  1. Podczas synchronizacji i uzgadniania profilu, gdy aparat profilu (USERENV) wykryje, że plik w profilu docelowym jest starszy niż jego odpowiednik w profilu źródłowym, plik źródłowy jest kopiowany do pliku Prf*.tmp w lokalizacji docelowej.
  2. Stary plik docelowy jest usuwany, a nazwa pliku Prf*.tmp jest odpowiednio zmieniana.

    Należy zwrócić uwagę, że nazwy plików tymczasowych są generowane przez funkcję API GetTempFileName wejścia/wyjścia plików systemu Windows. Jeżeli inny proces otworzy plik tymczasowy zanim plik tymczasowy zostanie usunięty i nie zamknie go, plik nie zostanie usunięty. Fakt ten nie jest rejestrowany w postaci komunikatu w dzienniku zdarzeń aplikacji. Aby uzyskać dodatkowe informacje, zobacz temat „Informacje dotyczące rejestrowania Userenv” w tym artykule.
  3. Przy wylogowaniu wszystkie pozostałe pliki Prf*.tmp są automatycznie ładowane wraz z profilem.
  4. Przy następnym logowaniu podczas uzgadniania profilu wystąpią błędy tworzenia plików, jeżeli zostaną ponownie użyte nazwy plików tymczasowych. Powoduje to wyświetlenie komunikatu o zdarzeniu Userenv o identyfikatorze 1000, który jest opisany w sekcji „Symptomy” tego artykułu.

Informacje dotyczące rejestrowania Userenv

Nie można usuwać następujących plików Prf*.tmp:
  • Plików zasad systemu Microsoft Windows NT 4.0 (te pliki znajdują się zawsze w katalogu głównym profilu).

    Jeżeli zauważysz, że pliki te nie zostały usunięte, znaczy to, że plik tymczasowy nie został usunięty; nie znaczy to, że zasada nie została zastosowana. W tym scenariuszu w dzienniku Userenv są rejestrowane następujące dane:
    USERENV() gg:mm:ss:nnn ApplySystemPolicy: Nie można usunąć pliku zasad PRF###.TMP. Błąd 32
  • Tymczasowych plików przemieszczania profilu standardowego (pliki te nie są nigdy przechowywane w katalogu głównym profilu).

    Jeżeli nie można usunąć istniejącego pliku docelowego, nie można także usunąć pliku Prf*.tmp. Może tak się stać, jeżeli inny proces otworzył oba pliki. W tym przypadku nie jest wykonywana ponowna próba usunięcia pliku Prf*.tmp. W wyniku tego powstaje przestarzała lokalna kopia pliku (i najnowsza kopia w pliku tymczasowym). W tym scenariuszu w dzienniku Userenv są rejestrowane następujące dane:
    USERENV() gg:mm:ss:nnn ReconcileFile: Nie można usunąć pliku nazwa_pliku z błędem = 32
    W niektórych przypadkach istniejący plik docelowy został usunięty, co jest standardową czynnością poprzedzającą zmianę nazwy pliku tymczasowego, ale zmiana nazwy pliku Prf*.tmp nie była możliwa. W tym przypadku pliki tymczasowe nie są usuwane celowo, aby uniknąć utraty danych. W dzienniku Userenv rejestrowane są następujące dane:
    USERENV() gg:mm:ss:nnn ReconcileFile: Nie można zmienić nazwy pliku PRF###.TMP na nazwa_pliku z błędem = 32
UWAGA: Definicja błędu 32 jest następująca:
ERROR_SHARING_VIOLATION
Proces nie może uzyskać dostępu do pliku, ponieważ jest on używany przez inny proces.

Właściwości

Numer ID artykułu: 328607 - Ostatnia weryfikacja: 30 marca 2007 - Weryfikacja: 3.1
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Windows XP Professional
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
Słowa kluczowe: 
kbprb KB328607

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com