ทำงานตัวกำหนดเวลางานไม่ทำงาน และสร้างรหัสข้อผิดพลาด 0x8004130f เป็นระยะ ๆ

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 328773 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

เนื้อหาบนหน้านี้

อาการ

ถ้าคุณกำลังเรียกใช้งานตัวกำหนดเวลางานต่าง ๆ ในแต่ละวัน โดยใช้บัญชีผู้ใช้บนคอมพิวเตอร์แบบมัลติโปรเซสเซอร์ และถ้าบางส่วนของงานทำงานวันหลายครั้ง งานอาจเป็นระยะ ๆ สูญเสียข้อมูลประจำตัวของตนเอง และไม่มีการเรียกใช้งาน เมื่อปัญหานี้เกิดขึ้น คุณพบรายการที่คล้ายกับต่อไปนี้ในแฟ้ม Schedlgu.txt ในโฟลเดอร์ของ Windows:
"ชื่องาน" (โปรแกรม:)บันทึกเวลาของเวลา** ข้อผิดพลาด **
ความพยายามเรียกข้อมูลบัญชีผู้ใช้สำหรับงานที่ระบุล้มเหลว จึง งานไม่ทำงาน เกิดข้อผิดพลาด หรือข้อมูลบัญชีผู้ใช้ไม่มีอยู่สำหรับงาน ข้อผิดพลาดเฉพาะคือ:
0x8004130f: ไม่พบข้อมูลบัญชีผู้ใช้ไม่มีในฐานข้อมูลความปลอดภัยของ Task Scheduler สำหรับงานที่ระบุได้

ถ้าคุณเปิดคุณสมบัติสำหรับงานที่ได้รับผลกระทบ คุณเห็นว่า คุณเข้าสู่ระบบด้วยบัญชีที่มีระบุเป็นบัญชีงานรันภายใต้ ไม่ว่าตัวซึ่งระบุบัญชีก่อน

สาเหตุ

ในชุดของสถานการณ์ไม่ค่อยพบ ฐานข้อมูลข้อมูลประจำตัวที่ใช้ Task Scheduler อาจเสีย ข้อมูลประจำตัวจะถูกเอาออกเมื่อตรวจพบที่เกิดความเสียหาย อินเทอร์เฟซสำหรับผู้ใช้แสดงชื่อของผู้ใช้ปัจจุบันในคุณสมบัติของงานเมื่อคุณเปิดงานหลังจากนั้นหมดของข้อมูลประจำตัว

การแก้ไข

ข้อมูล Service Pack

เมื่อต้องการแก้ไขปัญหานี้ ขอรับ service pack ล่าสุดสำหรับ Microsoft Windows 2000 สำหรับข้อมูลเพิ่มเติม ให้คลิกหมายเลขบทความต่อไปนี้ เพื่อดูบทความในฐานความรู้ของ Microsoft::
260910วิธีการขอรับ Service Pack ล่าสุดของ Windows 2000

ข้อมูลโปรแกรมแก้ไขด่วน

โปรแกรมแก้ไขด่วนที่ได้รับการสนับสนุนจาก Microsoft พร้อมใช้งานแล้ว อย่างไรก็ตาม โปรแกรมแก้ไขด่วนนี้มีเป้าหมายเพื่อการแก้ไขปัญหาที่อธิบายไว้ในบทความนี้เท่านั้น นำโปรแกรมแก้ไขด่วนนี้ไปใช้กับระบบที่พบปัญหานี้เท่านั้น

หากมีโปรแกรมแก้ไขด่วนพร้อมสำหรับการดาวน์โหลด คุณจะเห็นส่วน "โปรแกรมแก้ไขด่วนพร้อมดาวน์โหลด" อยู่ที่ด้านบนของบทความฐานความรู้นี้ หากส่วนนี้ไม่ปรากฏขึ้น ให้ส่งการร้องขอไปที่ฝ่ายบริการสนับสนุนลูกค้าของ Microsoft เพื่อขอรับโปรแกรมแก้ไขด่วน

หมายเหตุ:หากเกิดปัญหาอื่น ๆ หรือ ถ้ามีการแก้ไขปัญหาเป็นสิ่งจำเป็น คุณอาจต้องสร้างการร้องขอบริการแยกต่างหาก ค่าใช้จ่ายในการสนับสนุนปกติจะเกิดขึ้นเมื่อมีคำถามและประเด็นการสนับสนุนอื่นๆ ซึ่งไม่จัดอยู่ในโปรแกรมแก้ไขด่วนเฉพาะที่กล่าวถึงนี้ สำหรับรายการของหมายเลขโทรศัพท์ของฝ่ายบริการและการสนับสนุนลูกค้าของ Microsoft ทั้งหมด หรือถ้าต้องการสร้างคำขอรับการสนับสนุนแยกต่างหาก โปรดเข้าสู่เว็บไซต์ของ Microsoft ต่อไปนี้::
http://support.microsoft.com/contactus/?ws=support
หมายเหตุ:แบบฟอร์ม "โปรแกรมแก้ไขด่วนพร้อมดาวน์โหลด" แสดงภาษาในโปรแกรมแก้ไขด่วนมีอยู่ หากคุณไม่เห็นภาษาของคุณ เป็นเพราะไม่มีโปรแกรมแก้ไขด่วนสำหรับภาษานั้นโปรแกรมแก้ไขด่วนรุ่นภาษาอังกฤษนี้มีแอตทริบิวต์ของแฟ้ม (หรือแอตทริบิวต์ของแฟ้มที่ใหม่กว่า) ซึ่งแสดงอยู่ในตารางต่อไปนี้ วันที่และเวลาของแฟ้มเหล่านี้จะปรากฏในรูปแบบเวลามาตรฐานสากล (UTC) เมื่อคุณดูข้อมูลแฟ้ม ข้อมูลจะถูกแปลงเป็นเวลาท้องถิ่น เมื่อต้องการค้นหาความแตกต่างระหว่างเวลา UTC กับเวลาท้องถิ่น ใช้โซนเวลาแท็บในเครื่องมือ'วันและเวลา'ใน'แผงควบคุม'
   Date         Time   Version         Size     File name
   -------------------------------------------------------
   15-Jan-2003  19:13  4.71.2195.6654  123,664  Mstask.exe

สถานะ

Microsoft ยืนยันว่าปัญหานี้เป็นปัญหาที่เกิดขึ้นกับผลิตภัณฑ์ของ Microsoft ซึ่งมีการระบุไว้ในส่วนเริ่มต้นของเอกสารนี้ปัญหานี้ได้รับการแก้ไขครั้งแรกใน Microsoft Windows 2000 Service Pack 4

ข้อมูลเพิ่มเติม

สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการรับโปรแกรมแก้ไขด่วนสำหรับ Windows 2000 Datacenter Server โปรดคลิกหมายเลขบทความด้านล่างเพื่อดูบทความใน Microsoft Knowledge Base::
265173Datacenter Program และผลิตภัณฑ์ Windows 2000 Datacenter Server

คุณสมบัติ

หมายเลขบทความ (Article ID): 328773 - รีวิวครั้งสุดท้าย: 13 มกราคม 2554 - Revision: 3.0
ใช้กับ
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbsysadmin kbwin2ksp4fix kbbug kbfix kbwin2000presp4fix kbmt KB328773 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:328773

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com