First Character of Each Line Is Missing When You Print with the Generic Printer Driver

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Article ID: 328894 - View products that this article applies to.
This article was previously published under Q328894
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SYMPTOMS

After you apply Windows 2000 Service Pack 3 (SP3), the first character of each line is not printed when you use the generic printer driver.

CAUSE

This behavior occurs because some changes in the Unidrv driver are not initialized correctly in the generic printer driver.

RESOLUTION

Service Pack Information

To resolve this problem, obtain the latest service pack for Microsoft Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
260910 How to Obtain the Latest Windows 2000 Service Pack

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version         Size   File name
   -----------------------------------------------------
   15-Nov-2001  12:27                  5,149  Empty.cat
   06-Sep-2002  07:10  5.2.41.0        3,584  Spmsg.dll
   06-Sep-2002  07:10  5.2.41.0       46,080  Spuninst.exe
   12-Jun-2001  18:05  5.0.2195.3727   3,856  Svcpack1.dll
   18-Sep-2002  07:48  0.3.0.0         8,464  Tty.dll
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Windows 2000 Service Pack 4.

MORE INFORMATION

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the article number below to view the article in the Microsoft Knowledge Base:
265173 The Datacenter Program and Windows 2000 Datacenter Server Product

Properties

Article ID: 328894 - Last Review: February 27, 2014 - Revision: 4.5
APPLIES TO
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Advanced Server SP3
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Service Pack 3
Keywords: 
kbnosurvey kbarchive kbautohotfix kbhotfixserver kbqfe kbprint kbwin2ksp4fix kbbug kbfix kbwin2000presp4fix KB328894

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