Bufor klienta wprowadza pętli, gdy dotyczy animacja jednocześnie kilka drukarek sieciowych

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 329234 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Rozwiń wszystko | Zwiń wszystko

Na tej stronie

Symptomy

Kiedy klient otwiera kilka drukarek sieciowych, które są wszystkie na jednym serwerze i następnie wybiera właściwości drukarki i preferencje dla wszystkich w tym samym czasie drukarek bufor po stronie klienta może nie odpowiadać zgodnie z oczekiwaniami. Ponadto może zwiększyć wykorzystanie Procesora serwera wydruku i pozostaje wysoka. W tym scenariuszu przechwytywania sieci pokazuje, że klient wielokrotnie kwerendy Serwer wydruku dla właściwości drukarki.

Wyświetla przechwytywania sieci zdalne wywołanie procedury (RPC) w następstwie żądania od klienta:
MSRPC: c/o RPC Request: call 0x3845 opnum 0x8 context 0x0 hint 0x734

Przyczyna

Ten problem występuje, gdy bufor klienta wprowadzi pętli Podczas wykonywania RemoteGetPrinterData zdalnego wywołania procedury.

Rozwiązanie

Informacje dotyczące dodatku Service pack

Aby rozwiązać ten problem, należy uzyskać najnowszy dodatek service pack dla systemu Microsoft Windows XP. Aby uzyskać dodatkowe informacje kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
322389 bazy wiedzy Jak uzyskać najnowszy dodatek service pack dla systemu Windows XP

Informacje o poprawce

Obsługiwana poprawka jest dostępna w firmie Microsoft. Jednak ta poprawka jest przeznaczona do usunięcia tylko problemu opisanego w tym artykule. Tylko do systemów, w których występuje ten problem, należy zastosować tę poprawkę. Ta poprawka może być dodatkowo testowana. Jeśli dany system nie jest poważnie narażony na ten problem, firma Microsoft zaleca, aby poczekać na następną aktualizację oprogramowania zawierającą tę poprawkę.

Jeśli poprawka jest dostępna do pobrania, jest sekcja "Poprawka dostępna do pobrania" na początku tego artykułu z bazy wiedzy Knowledge Base. Ta sekcja nie jest wyświetlany, skontaktuj się z działem pomocy technicznej firmy Microsoft w celu uzyskania poprawki.

Uwaga Wystąpienia dodatkowych błędów lub konieczności rozwiązania problemu, należy utworzyć osobne zlecenie usługi. Zwykłe technicznej będą pobierane dodatkowych pytań i problemów, które nie kwalifikują się do tej poprawki. Aby uzyskać pełną listę numerów telefonów pomocy technicznej firmy Microsoft lub utworzyć osobne zlecenie usługi odwiedź następującą witrynę firmy Microsoft w sieci Web:
http://support.microsoft.com/contactus/?ws=support
Uwaga "Poprawka dostępna do pobrania" zawiera listę języków, dla których poprawka jest dostępna. Jeśli język nie jest widoczny, jest to, ponieważ poprawka nie jest dostępna dla danego języka. Angielskim wersja tej poprawki ma atrybuty pliku (lub nowsze) wymienione w Poniższa tabela. Daty i godziny odpowiadające tym plikom są wyświetlane w skoordynowanego czasu uniwersalnego (UTC). Podczas przeglądania informacji o pliku jest konwertowane na czas lokalny. Aby zobaczyć różnicę między czasem UTC i czasem lokalnym, należy użyć w Strefa czasowa Karta w narzędziu Data i godzina w Panelu sterowania.
   Date         Time   Version            Size    File name    
   ---------------------------------------------------------------  
   04-Oct-2002  17:29  5.1.2600.101       86,528  Win32spl.dll SP1
   04-Oct-2002  17:17  5.1.2600.1130      90,112  Win32spl.dll SP2    
			

Stan

Microsoft potwierdziła, że jest to problem występujący w produktach firmy Microsoft, które są wymienione na początku tego artykułu. Ten problem został po raz pierwszy rozwiązany w dodatku Service Pack 2 dla systemu Microsoft Windows XP.

Właściwości

Numer ID artykułu: 329234 - Ostatnia weryfikacja: 23 czerwca 2011 - Weryfikacja: 2.0
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Słowa kluczowe: 
kbautohotfix kbhotfixserver kbwinxpsp2fix kbqfe kbbug kbfix kbwinxppresp2fix kbmt KB329234 KbMtpl
Przetłumaczone maszynowo
WAŻNE: Ten artykuł nie został przetłumaczony przez człowieka, tylko przez oprogramowanie do tłumaczenia maszynowego firmy Microsoft. Firma Microsoft oferuje zarówno artykuły tłumaczone przez ludzi, jak i artykuły tłumaczone maszynowo, dzięki czemu każdy użytkownik może uzyskać dostęp do całej zawartości bazy wiedzy Knowledge Base we własnym języku. Prosimy jednak pamiętać, że artykuły przetłumaczone maszynowo nie zawsze są doskonałe. Mogą zawierać błędy słownictwa, składni i gramatyki, przypominające błędy robione przez osoby, dla których język użytkownika nie jest językiem ojczystym. Firma Microsoft nie odpowiada za wszelkie nieścisłości, błędy lub szkody spowodowane nieprawidłowym tłumaczeniem zawartości oraz za wykorzystanie tej zawartości przez klientów. Oprogramowanie do tłumaczenia maszynowego jest często aktualizowane przez firmę Microsoft.
Anglojęzyczna wersja tego artykułu to:329234

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com