Komunikat o błędzie Stop „0x0000009C (0x00000004, 0x00000000, 0xb2000000, 0x00020151)” może zostać wyświetlony w systemie Windows XP

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 329284 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Wersja tego artykułu dla systemów Microsoft Windows NT 4.0 i Microsoft Windows 2000: 162363 .
Rozwiń wszystko | Zwiń wszystko

Symptomy

Następujący komunikat o błędzie Stop może zostać wyświetlony w systemie Windows XP:
STOP: 0x0000009C (0x00000004, 0x00000000, 0xb2000000, 0x00020151)
"MACHINE_CHECK_EXCEPTION"
Cztery parametry w nawiasie mogą być różne.

Przyczyna

To zachowanie występuje, ponieważ procesor wykrył i zgłosił nieodwracalny błąd sprzętu w systemie Windows XP. Do wykonania tego procesor użył funkcji MCE (Machine Check Exception) procesorów Pentium lub funkcji MCA (Machine Check Architecture) niektórych procesorów Pentium Pro. Następujące czynniki mogą być przyczyną wyświetlenia tego komunikatu o błędzie:
  • Błędy magistrali systemowej
  • Błędy pamięci, takie jak problemy z parzystością lub korekcją ECC (Error Correction Code)
  • Błędy pamięci podręcznej w procesorze lub sprzęcie
  • Błędy buforów TLB (Translation Lookaside Buffers) w procesorze
  • Inne wykryte problemy ze sprzętem specyficzne dla procesora i dostawcy
  • Inne wykryte problemy ze sprzętem specyficzne dla dostawcy

Rozwiązanie

Użycie narzędzia Raportowanie błędów systemu Windows

Jeżeli wystąpi ten błąd, należy użyć narzędzia Raportowanie błędów systemu Windows. Korzystając z tego narzędzia, można wysłać raport o błędach bezpośrednio do firmy Microsoft, by otrzymać raport zwrotny w przypadku, gdy będzie dostępna metoda rozwiązania lub obejścia problemu. Aby skorzystać z tego narzędzia, wykonaj następujące kroki:
  • Po wyświetleniu monitu o wysłanie raportu o błędzie do firmy Microsoft kliknij przycisk Wyślij raport o błędach.
  • Po wysłaniu raportu o błędach do firmy Microsoft, jeżeli jest dostępna metoda rozwiązania lub obejścia problemu, kliknij przycisk Więcej informacji. W ten sposób można uzyskać poprawkę lub informacje na temat metody obejścia problemu.
Jeżeli poprawka lub metoda obejścia nie są dostępne, można skontaktować się z Pomocą techniczną firmy Microsoft w celu uzyskania pomocy w zakresie rozwiązywania tego problemu. Aby uzyskać informacje dotyczące sposobu kontaktowania się z Pomocą techniczną firmy Microsoft, odwiedź następującą witrynę firmy Microsoft w sieci Web:
http://support.microsoft.com/contactus/

Skontaktowanie się z producentem sprzętu

Optymalną metodą może być skontaktowanie się z producentem sprzętu lub technikiem obsługującym sprzęt komputerowy w celu uzyskania pomocy w zakresie rozwiązywania tego problemu. Producent może podjąć dodatkowe kroki w celu zdiagnozowania tego problemu. Producent będzie mógł określić, czy konieczna jest naprawa lub wymiana sprzętu.

Więcej informacji

Wyjątek sprawdzania komputera występuje wówczas, gdy nie można przywrócić prawidłowego funkcjonowania systemu Windows XP i platformy sprzętowej na skutek błędu sprzętu, uniemożliwiającego pomyślne i niezawodne działanie systemu. Bardziej specyficzna diagnostyka wyjątków sprawdzania komputera jest trudna, dlatego nie istnieje ogólne rozwiązanie. Należy skontaktować się z producentem sprzętu lub technikiem obsługującym sprzęt komputerowy w celu uzyskania pomocy w zakresie rozwiązywania tego problemu.

Wyjątki sprawdzania komputera często występują wówczas, gdy spełniony jest jeden z następujących warunków:
  • Procesor lub płyta główna działają poza ich specyfikacjami. Na przykład zwiększona została częstotliwość zegara procesora lub magistrali. Firma Microsoft zaleca uruchomienie sprzętu zgodnie z prędkościami zalecanymi przez producenta.
  • Zakłócenia zasilania, przeciążone linie zasilające, niezgodne zasilanie i awarie zasilania mogą destabilizować komputer. Należy upewnić się, że dostępne jest stabilne, niezawodne zasilanie komputera.
  • Ekstremalne warunki termiczne wynikające z awarii urządzeń chłodzących, takich jak wentylatory, mogą być przyczyną uszkodzenia komputera. Należy upewnić się, że wszystkie urządzenia chłodzące działają.
  • Pamięć jest uszkodzona lub typ pamięci jest niepoprawny dla danego komputera. Jeżeli ostatnio zmieniono konfigurację pamięci, należy przywrócić poprzednią konfigurację w celu ustalenia przyczyny problemu. Należy upewnić się, że dla danego komputera używana jest poprawna pamięć.
Uwaga: Sprzęt może obsługiwać dodatkowe funkcje rejestrowania błędów, które przechwytują wyjątek sprawdzania komputera i sugerują bardziej specyficzne rozwiązanie.

Procesory Pentium i Pentium Pro dostarczają mechanizm wykrywania i zgłaszania problemów związanych ze sprzętem, takich jak błędy parzystości pamięci i błędy pamięci podręcznej. Aby zasygnalizować błąd sprzętu, procesor sygnalizuje wykrycie błędu sprawdzania komputera, generując wyjątek sprawdzania komputera (przerwanie 18). System Windows XP raportuje zgłoszony błąd i wyświetla parametry, których można użyć do zdekodowania wyjątku. Skontaktuj się z dostawcą sprzętu lub producentem procesora w celu uzyskania informacji dotyczących architektury sprawdzania komputera (MCA, Machine Check Architecture) lub zobacz Intel Pentium Pro Family Developer's Manual – Volume 3: Operating System Writer's Manual.

Właściwości

Numer ID artykułu: 329284 - Ostatnia weryfikacja: 12 czerwca 2008 - Weryfikacja: 3.0
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Słowa kluczowe: 
kbresolve kberrmsg kbprb kbprod2web KB329284

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com