OL2002: AutoArchive Feature Is Not Disabled When You Use the DoAging Registry Key

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Article ID: 329294 - View products that this article applies to.
This article was previously published under Q329294
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry
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SYMPTOMS

In Outlook 2002, AutoArchive may not be correctly disabled when you set the DoAging=0 policy. If you follow the instructions in the article 258277: "XCLN: How to Disable AutoArchive and Personal Folders" to disable autoarchiving of the personal folders file (.pst), the following are disabled if the
DisablePST
registry key is set to 1:
  • Autoarchiving of PST files.
  • Creation of new PST files from the File menu.
However, the steps do not disable the following:
  • Creating a new PST file by modifying or creating a new e-mail account.
  • Opening a PST file.
After you install Microsoft Office XP and apply the hotfix from article 323244 or any hotfix that inherits article 323244, it also disables creation of new PSTs from the following locations:
  • Creating a new PST file by modifying or creating a new e-mail account.
  • Creation of new PST files from the File menu.
If you used the
DisablePST
registry key to disable AutoArchiving, the PST behavior has changed.

CAUSE

This problem occurs after you upgrade to Office XP and then apply the hotfix in article 323244 or any hotfix that inherits article 323244. The hotfix for article 323244 changed the behavior of how the
DisablePst
key would work because it disables creation of PSTs.

RESOLUTION

Service Pack Information

This problem is corrected in Office XP Service Pack 3.To resolve this problem, obtain the latest service pack for Microsoft Office XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
307841 How to obtain the latest Office XP Service Pack

Hotfix Information

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk. A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this fix should have the following file attributes or later:
   Date         Time      Size       File name     
   ---------------------------------------------------
   01-OCT-2002  15:44:08  2,266,020  Outlook.msp
   01-OCT-2002  16:33:07  4,142,080  Outlook_admin.msp
After the hotfix is installed, the English version of this fix will have the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time      Version      Size       File name
   -----------------------------------------------------------
   08-Aug-2002  20:22:19  10.0.4406.0    137,800  Impmail.dll
   08-Aug-2002  20:22:29  10.0.4406.0    121,416  Outlph.dll
   16-Aug-2002  14:05:14  10.0.4413.0    346,696  Exsec32.dll
   12-Sep-2002  20:52:33  10.0.4510.0    539,208  Outlcm.dll
   12-Sep-2002  20:52:39  10.0.4510.0     92,744  Outlmime.dll
   12-Sep-2002  20:52:41  10.0.4510.0     47,688  Outlook.exe
   19-Sep-2002  14:23:05  10.0.4517.0    105,032  Envelope.dll
   27-Sep-2002  17:47:30  10.0.4524.0  6,314,568  Outllib.dll


After you apply this hotfix, you can disable all PST file functions including Auto Archive: Follow these steps, and then quit Registry Editor:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following key in the registry:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\10.0\Outlook\DisablePST
  3. On the Edit menu, click Modify.
  4. Type 1, and then press ENTER.
However, after you complete these steps, you cannot create PST files. To only disable the AutoArchive feature of Outlook: Follow these steps, and then quit Registry Editor:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following key in the registry:
    HKEY_CURRENT_USER\SOFTWARE\Policies\Microsoft\Office\10.0\Outlook\Preferences
  3. On the Edit menu, point to New, and then click DWORD value.
  4. Type DoAging, and then press ENTER.
  5. On the Edit menu, click Modify.
  6. Type 0, and then click OK.
After you create the
DoAging
registry key and set its value to 0, the following Autoarchive features are disabled:
  • Automatic AutoArchiving after a set number of days.
  • The AutoArchive choice under Mailbox Cleanup.
  • The Autoarchive tab for theFolder Properties that are available for each folder in your mailbox.
By setting the
DoAging
registry key value to 1, these features are enabled. To enable these features: Follow these steps, and then quit Registry Editor:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following key in the registry:
    HKEY_CURRENT_USER\SOFTWARE\Policies\Microsoft\Office\10.0\Outlook\Preferences\DoAging
  3. On the Edit menu, click Modify.
  4. Type 1, and then press ENTER.

This fix is a post-Office XP Service Pack 2 (SP-2) fix. To install the fix, you must have Office XP SP-2 installed. For additional information about Office XP SP-2, click the following article number to see the article in the Microsoft Knowledge Base:
325671 OFFXP: Overview of the Office XP Service Pack 2
Additionally, you may have to install Windows Installer 2.0 to install this fix. For additional information about the Windows Installer requirement for post-Office XP SP-2 fixes, click the following article number to see the article in the Microsoft Knowledge Base:
330537 OFFXP: Office XP Updates and Patches Released After September 2002 May Require Windows Installer 2.0

REFERENCES

258277 XCLN: How to Disable AutoArchive and Personal Folders

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Office XP Service Pack 3.

Properties

Article ID: 329294 - Last Review: October 11, 2005 - Revision: 2.6
APPLIES TO
  • Microsoft Outlook 2002 Service Pack 2
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbenv kbofficexppresp3fix kbbug kbfix KB329294

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