오류 메시지: 사용자 인터페이스 실패: 로그온 사용자 인터페이스 DLL msgina.dll을 로드하지 못했습니다

기술 자료 번역 기술 자료 번역
기술 자료: 329316 - 이 문서가 적용되는 제품 보기.
모두 확대 | 모두 축소

이 페이지에서

현상

Windows 2000 서비스 팩 3(SP3)을 설치하면 컴퓨터를 시작할 때 다음 오류 메시지가 나타날 수 있습니다.
사용자 인터페이스 실패:
로그온 사용자 인터페이스 DLL msgina.dll을 로드하지 못했습니다
시스템 관리자에게 문의하여 DLL을 대체하거나 원래 DLL을 복원합니다.
Windows 로그온 화면이 나타나지 않고 Windows 2000을 열 수 없습니다.

원인

Services.exe가 이러한 레지스트리 키를 만들기 전에 Winlogon.exe가 Mpr.dll 레지스트리 키를 쿼리하는 경우 이 문제가 발생합니다. Windows 2000 SP3에서 Msgina.dll은 Mpr.dll에 종속적입니다. Mpr.dll을 초기화하려면 다음 레지스트리 키가 있어야 합니다.
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\NetworkProvider\HwOrder
이 키는 Services.exe가 시작할 때 만들어집니다. Winlogon.exe가 Services.exe와 동시에 시작되기 때문에 Winlogon은 Mpr.dll 레지스트리 키를 Services.exe에서 만들기 전에 쿼리할 수 있습니다. 이렇게 되면 Msgina.dll이 로드되지 않고 이 문서의 "현상" 절에서 설명한 오류 메시지가 나타납니다. 이러한 종속성이 Windows 2000 서비스 팩 2(SP2)에는 존재하지 않습니다.

해결 방법

서비스 팩 정보

이 문제를 해결하려면 Microsoft Windows 2000의 최신 서비스 팩을 구하십시오. 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
260910 최신 Windows 2000 서비스 팩을 구하는 방법

핫픽스 정보

현재 지원되는 수정 프로그램을 Microsoft에서 구할 수 있지만 이 문서에서 설명하는 문제를 해결하기 위한 것일 뿐이므로 이러한 특정 문제가 발생하는 컴퓨터에만 이 프로그램을 적용해야 합니다. 이 수정 프로그램은 나중에 추가 테스트를 받아야 할 수도 있습니다. 따라서 이 문제의 영향이 심각하지 않으면 이 수정 프로그램이 포함된 다음 Windows 2000 서비스 팩이 나올 때까지 기다리는 것이 좋습니다.

이 문제를 즉시 해결하려면 Microsoft 고객기술지원부에 문의하여 수정 프로그램을 구하십시오. Microsoft 고객기술지원부 전화 번호의 전체 목록과 지원 비용에 대한 정보는 다음 Microsoft 웹 사이트를 참조하십시오.
기술 지원 서비스 안내
참고: 특정 업데이트로 문제를 해결할 수 있다고 Microsoft 기술 지원 전문가가 판단할 경우 지원 요청에 따른 일반적 비용이 취소될 수도 있습니다. 특정 업데이트가 필요하지 않은 추가 지원 질문과 문제에는 일반 지원 비용이 적용됩니다.

이 수정 프로그램의 영어 버전은 아래와 같거나 그 이상의 파일 특성을 가집니다. 이 파일의 날짜와 시간은 UTC(Coordinated Universal Time)로 나열되며 파일 정보를 볼 때 로컬 시간으로 변환됩니다. UTC와 로컬 시간의 차이를 알려면 제어판날짜 및 시간 도구에서 표준 시간대 탭을 사용하십시오.
표 축소표 확대
날짜시간버전크기파일 이름
2002-10-1518:535.0.2195.6090332,560Msgina.dll


이 핫픽스를 적용하려면 컴퓨터를 시작하여 Windows 2000을 열 수 있어야 합니다. 다른 Windows 2000 SP2 기반 컴퓨터와 포맷된 빈 3.5인치 디스크에 액세스해야 합니다.

문제를 해결하려면 Windows 2000을 연 다음 핫픽스를 적용합니다.
  1. 다른 Windows 2000 SP2 기반 컴퓨터에서 포맷된 빈 3.5인치 디스크를 디스크 드라이브에 삽입합니다.
  2. 시작, 실행을 차례로 누르고 cmd를 입력한 다음 확인을 누릅니다.
  3. 명령 프롬프트에서 다음 명령을 입력하고 각 명령 끝에서 Enter 키를 누릅니다.
    C:
    CD \
    CD \WINNT\system32\dllcache
    COPY msgina.dll A:
  4. 디스크 드라이브에서 3.5인치 디스크를 제거합니다.
  5. "현상" 절에서 설명한 문제가 있는 컴퓨터를 시작한 다음 복구 콘솔을 시작합니다. 시작 옵션으로 복구 콘솔을 설치하지 않은 경우 다음을 수행합니다.
    1. 디스크 드라이브에 Windows 2000 Server 설치 디스크 1을 넣거나, 부팅 가능한 CD-ROM 드라이브가 있는 경우에는 CD-ROM 드라이브에 Windows 2000 Server CD-ROM을 넣을 수 있습니다.
    2. 컴퓨터를 다시 시작합니다.
    3. 화면에 나타나는 지시를 따릅니다. 설치 디스크를 사용할 경우 디스크 드라이브에 다른 설치 디스크를 넣으라는 내용의 메시지가 표시됩니다. 파일을 로드하는 데 몇 분이 걸릴 수도 있습니다.
    4. 적절한 옵션을 선택하여 Windows 2000 설치를 복구하고 복구 콘솔을 시작합니다.
  6. 복구 콘솔 명령 프롬프트에서 다음 명령을 입력한 다음 각 명령 끝에서 Enter 키를 누릅니다.
    CD system32
    REN msgina.dll mdgina.old
    CD dllcache
    REN msgina.dll msgina.old
    참고: Msgina.dll이 System32 폴더나 Dllcache 폴더에 없으면 7단계로 가십시오.
  7. 다른 Windows 2000 SP2 기반 컴퓨터에서 복사한 Msgina.dll 파일이 들어 있는 3.5인치 디스크를 "현상" 절에서 설명한 문제가 있는 컴퓨터의 디스크 드라이브에 삽입합니다.
  8. 복구 콘솔 명령 프롬프트에서 다음 명령을 입력하고 각 명령 끝에서 Enter 키를 누릅니다.
    COPY a:\msgina.dll
    CD ..
    COPY a:\msgina.dll
    exit
  9. 컴퓨터를 다시 시작하고 핫픽스를 적용합니다.

현재 상태

Microsoft는 본 문서의 시작 부분에 나열한 제품에서 이 문제를 확인했습니다. 이 문제는 Microsoft Windows 2000 서비스 팩 4에서 처음 수정되었습니다.

추가 정보

Windows 2000 Datacenter Server용 핫픽스를 구하는 방법에 대한 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
265173 Datacenter 프로그램 및 Windows 2000 Datacenter Server 제품
복구 콘솔을 사용하는 방법에 대한 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
301645 HOWTO: Windows 2000으로 시작하지 않는 컴퓨터에 복구 콘솔 사용




Microsoft 제품 관련 기술 전문가들과 온라인으로 정보를 교환하시려면 Microsoft 뉴스 그룹에 참여하시기 바랍니다.

속성

기술 자료: 329316 - 마지막 검토: 2006년 3월 29일 수요일 - 수정: 3.2
본 문서의 정보는 다음의 제품에 적용됩니다.
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 서비스 팩 3
  • Microsoft Windows 2000 서비스 팩 3
키워드:?
kbbug kbfix kbwin2000presp4fix kbqfe kbsecurity kbwin2ksp4fix kbhotfixserver KB329316

피드백 보내기

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com