A mensagem de erro: Falha na interface do usuário: A DLL de logon da interface do usuário Msgina.dll falhou ao carregar.

Traduções deste artigo Traduções deste artigo
ID do artigo: 329316 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Após instalar o Windows 2000 Service Pack 3 (SP3), é possível que você receba a seguinte mensagem de erro ao iniciar o computador.
Falha na interface do usuário:
A DLL de logon da interface do usuário Msgina.dll falhou ao carregar.
Entre em contato com o administrador do sistema para substituir a DLL, ou restaurar a DLL original.
A tela de logon do Windows não é exibida e é impossível abrir o Windows 2000.

Causa

O problema pode ocorrer se o Winlogon.exe consulta a chave de registro Mpr.dll antes que o Services.exe tenha criado essa chave. No Windows 2000 SP3, o Msgina.dll depende do Mpr.dll. Mpr.dll solicitar que a chave de registro a seguir seja capaz de inicializar:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\NetworkProvider\HwOrder
Essa chave é criada quando o Services.exe inicia. Por iniciar ao mesmo tempo que o Services.exe, o Winlogon pode consultar a chave de registro Mpr.dll antes que ela tenha sido criada pelo Services.exe. Quando isso ocorre, o Msgina.dll não carrega e você recebe a mensagem de erro que é descrita na seção Sintomas deste artigo. Essa dependência não existe no Windows 2000 Service Pack 2 (SP2).

Resolução

Informações do Service pack

Para solucionar esse problema, utilize o service pack mais recente para o Windows 2000. Para obter informações adicionais, clique no número abaixo para consultar o artigo na Base de dados de conhecimento da Microsoft:
260910 Como obter o Service Pack mais recente do Windows 2000

Informações do hotfix

Há uma correção que recebe suporte e que está disponível pela Microsoft, mas destina-se apenas a corrigir o problema descrito neste artigo. Aplique-a somente aos computadores que estão apresentando esse problema específico. Esse hotfix pode receber testes adicionais. Portanto, se o problema não afetá-lo de forma direta, a Microsoft recomenda que você espere pelo próximo service pack do Windows 2000 que contenha essa correção.

Para solucionar o problema imediatamente, entre em contato com o Atendimento da Microsoft para obter a correção. Para obter uma lista completa de números de telefone do Atendimento da Microsoft e informações sobre os custos do suporte, visite o seguinte site da Microsoft na Web:
http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS(site em inglês)
OBSERVAÇÃO: Em casos especiais, os custos do atendimento podem ser cancelados se um profissional do Atendimento da Microsoft determinar que uma atualização específica resolverá o problema. Os custos normais do suporte serão aplicados às questões e aos problemas adicionais que não se qualifiquem para a atualização específica.

A versão em inglês do hotfix tem os atributos do arquivo (ou posterior) listados na tabela a seguir. As datas e as horas para esses arquivos estão listadas em UTC (coordinated universal time). Ao consultar as informações sobre o arquivo, ele é convertido para a hora local. Para verificar a diferença entre o UTC e a hora local, utilize a guia Fuso Horário na ferramenta de Data e Hora no Painel de controle.
   Data         Hora   Versão        Tamanho     Nome do arquivo
   ------------------------------------------------------
   15-Oct-2002  18:53  5.0.2195.6090  332,560  Msgina.dll


Para aplicar esse hotfix, é necessário que o computador possa ser iniciado e o Windows 2000 aberto. Será necessário o acesso a um outro computador baseado no Windows 2000 SP2, e um disco formatado de 3 1/2 polegadas.

Para solucionar o problema, abra o Windows 2000 e aplique o hotfix:
  1. No segundo computador baseado no Windows 2000 SP2, insira um disco de 3 1/2 polegadas na unidade de disco.
  2. Clique em Iniciar, em Executar, digite cmd e clique em OK.
  3. No prompt de comando, digite os comandos a seguir e pressione ENTER após cada linha:
    C:
    CD \
    CD \WINNT\system32\dllcache
    COPY msgina.dll A:
  4. Remova o disco de 3 1/2 polegadas da unidade de disco.
  5. Inicie o computador que tem o problema descrito na seção Sintomas e inicie o Console de recuperação. Se você não tem o Console de recuperação instalado como uma opção de inicialização, realize as etapas a seguir:
    1. Insira o disco 1 de Instalação do Servidor do Windows 2000 na unidade de disco, ou se houver uma unidade de CD-ROM inicializável, insira o CD-ROM do Servidor do Windows 2000 nessa unidade de disco.
    2. Reinicie o computador.
    3. Siga as instruções que são exibidas na tela. Se você estiver utilizando os discos de instalação, é solicitado que os outros discos de instalação sejam inseridos na unidade de disco. É possível que os arquivos levem vários minutos para carregarem.
    4. Selecione as opções apropriadas para reparar a instalação do Windows 2000 e inicie o Console de recuperação.
  6. No prompt de comando do Console de recuperação, digite os comandos a seguir e pressione ENTER após cada linha:
    CD system32
    REN msgina.dll mdgina.old
    CD dllcache
    REN msgina.dll msgina.old
    OBSERVAÇÃO: Se o Msgina.dll não existir na pasta System32 ou na pasta Dllcache, passe para a etapa 7.
  7. Insira o disco de 3 1/2 polegadas que contém o arquivo Msgina.dll copiado do outro computador baseado no Windows 2000 SP2 para a unidade de disco do computador que tem o problema descrito na seção Sintomas.
  8. No prompt de comando do Console de recuperação, digite os comandos a seguir e pressione ENTER após cada linha:
    COPY a:\msgina.dll
    CD ..
    COPY a:\msgina.dll
    sair
  9. Reinicie o computador e aplique o hotfix.

Situação

A Microsoft confirmou que o problema existe nos produtos que estão listados no início deste artigo. Esse problema foi corrigido primeiro no Microsoft Windows 2000 Service Pack 4.

Mais Informações

Para obter informações adicionais sobre como obter um hotfix para o Windows 2000 Datacenter Server, clique no número abaixo para visualizar o artigo na Base de Dados de Conhecimento da Microsoft:
265173 Datacenter Program e Windows 2000 Datacenter Server
Para obter mais informações sobre a utilização do Console de recuperação, clique no número a seguir para consultar o artigo na Base de dados de conhecimento da Microsoft:
301645 PROCEDIMENTOS: Recuperar um servidor do Windows 2000 que não é iniciado

Propriedades

ID do artigo: 329316 - Última revisão: quinta-feira, 13 de abril de 2006 - Revisão: 4.0
A informação contida neste artigo aplica-se a:
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Service Pack 3
Palavras-chave: 
kbbug kbfix kbwin2000presp4fix kbqfe kbsecurity kbwin2ksp4fix kbhotfixserver KB329316

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com