DNS Name Resolution Does Not Work for Users Who Are Not Administrators

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Article ID: 329405 - View products that this article applies to.
This article was previously published under Q329405
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SYMPTOMS

After you install Windows 2000 Service Pack 3 (SP3), DNS name resolution may not work. For example, when you ping a host, you may receive an error message that is similar to:
Unknown host
If you type ipconfig /flushdns at a command prompt, you receive the following error message:
Could not flush the DNS Resolver Cache

CAUSE

The DNS resolver library uses Local Procedure Calls (LPCs) to the DNS Client service. The default security was changed in SP3for LPC ports. In some cases, this can prevent LPC calls to the DNS client for users who are not members of the Administrators group.

RESOLUTION

Service Pack Information

To resolve this problem, obtain the latest service pack for Microsoft Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
260910 How to Obtain the Latest Windows 2000 Service Pack

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size    File name
   -------------------------------------------------------
   01-Oct-2002  21:28  5.0.2195.6076  96,016  Dnsrslvr.dll
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Windows 2000 Service Pack 4.

MORE INFORMATION

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the article number below to view the article in the Microsoft Knowledge Base:
265173 The Datacenter Program and Windows 2000 Datacenter Server Product

Properties

Article ID: 329405 - Last Review: February 27, 2014 - Revision: 3.5
APPLIES TO
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Advanced Server SP3
Keywords: 
kbnosurvey kbarchive kbautohotfix kbhotfixserver kbqfe kbdirservices kbwin2ksp4fix kbbug kbfix kbwin2000presp4fix KB329405

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