OL2002: Outlook Appears to Stop Responding When You Choose an LDAP Server From the Address Book

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Article ID: 329458 - View products that this article applies to.
This article was previously published under Q329458
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IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
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SYMPTOMS

When you use your LDAP address book server from the Address Book dialog box, Outlook may appear to stop responding. However, if you wait several minutes, you may receive the following error messages:
Unable to contact the LDAP Server
The operation failed.

CAUSE

Outlook 2002 supports the Virtual List Views (VLV) LDAP extension. This LDAP extension makes it possible for Outlook to present LDAP query results in a more efficient way for most LDAP server implementations. When the VLV support is used against an LDAP server with a huge number of entries such as several hundred thousand, causes Outlook to be non-responsive. The fix in this article makes it possible for you to turn off the VLV support for Outlook 2002.

RESOLUTION

Service Pack Information

This problem is corrected in Office XP Service Pack 3.To resolve this problem, obtain the latest service pack for Microsoft Office XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
307841 How to obtain the latest Office XP Service Pack

Hotfix Information

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk. A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Part 1: Obtain and Install the Patch

English Version

The English version of this fix should have the following file attributes or later:

   Date         Time      Size       File name
   ------------------------------------------------------------------
   10-Jan-2003  10:37:34    185,856  Olkintl.msp    (Client Patch)
   10-Jan-2003  10:40:50  1,865,728  Olkintlff.msp  (Full File Patch)
After the hotfix is installed, the English version of this fix will have the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date           Time       Version       Size        File name
   ----------------------------------------------------------------
   09-Jan-2003    16:31:20   10.0.4907.0     113,224   Emablt32.dll
   14-Nov-2002    13:34:08   10.0.4712.0     192,512   Emsabp32.dll
   25-Nov-2002    12:49:58   10.0.4721.0     129,608   Emsui32.dll
   19-Dec-2002    18:40:40   10.0.4817.0     854,600   Msmapi32.dll
   12-Sept-2002   21:52:04   10.0.4510.0     531,016   Mspst32.dll
   25-Nov-2002    12:50:16   10.0.4721.0      55,880   Olkfstub.dll
   08-Aug-2002    21:21:22   10.0.4406.0     735,816   Outex.dll
   06-Sept-2002   16:18:32   10.0.4503.0   1,972,808   Outllibr.dll
   08-Nov-2002    15:46:56   10.0.4705.0     338,504   Pstprx32.dll

Korean Version

The Korean version of this fix should have the following file attributes or later:

   Date          Time       Size      File name
   -------------------------------------------------------------------
   15-Jan-2003   01:15:36    61,952   Olkintl.msp    (Client Patch)
   15-Jan-2003   01:18:06   502,784   Olkintlff.msp  (Full File Patch)
After the hotfix is installed, the Korean version of this fix will have the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date           Time       Version       Size      File name
   --------------------------------------------------------------
   09-Jan-2003    16:31:18   10.0.4907.0   113,224   Emablt32.dll
   26-Aug-2002    16:58:51   10.0.4420.0   834,120   Msmapi32.dll

Part 2: Activate The Patch

To activate the fix:
  1. Quit all Office programs.
  2. Click Start, and then click Run.
  3. In the Open box, type regedit, and then click OK.
  4. Click the following key:
    HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\10.0\Outlook\LDAP
  5. With the
    LDAP
    key selected, point to New on the Edit menu, and then click DWORD Value.
  6. Type DisableVLVBrowsing, and then press ENTER.
  7. With the DisableVLVBrowsing DWORD Value selected, click Modify on the Edit menu.
  8. In the Value data box, type 1 and then click OK.
  9. On the File menu, click Exit.
This fix is a post-Office XP Service Pack 2 (SP-2) fix. To install the fix, you must have Office XP SP-2 installed. For additional information about Office XP SP-2, click the following article number to see the article in the Microsoft Knowledge Base:
325671 OFFXP: Overview of the Office XP Service Pack 2
Additionally, you may have to install Windows Installer 2.0 to install this fix. For additional information about the Windows Installer requirement for post-Office XP SP-2 fixes, click the following article number to see the article in the Microsoft Knowledge Base:
330537 OFFXP: Office XP Updates and Patches Released After September 2002 May Require Windows Installer 2.0

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Office XP Service Pack 3.

Properties

Article ID: 329458 - Last Review: October 26, 2013 - Revision: 2.6
APPLIES TO
  • Microsoft Outlook 2002 Standard Edition
Keywords: 
kbnosurvey kbarchive kbautohotfix kbhotfixserver kbqfe kbenv kbprb kbbug kbfix KB329458

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