Padrão de fundo do ambiente de trabalho personalizado não pode ser apresentado depois de Bem-vindo ao Windows concluída

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Sintomas

Depois do utilizador visualizou o Bem-vindo ao Windows (também conhecido como "Out of Box Experience" ou OOBE), o utilizador não poderá ver o fundo personalizado de OEM padrão de fundo do ambiente de trabalho. O utilizador pode ver apenas um ambiente de trabalho simples com ícones apresentados.

Nota Este problema ocorre no Windows XP da seguinte forma:
  • Este problema ocorre no Windows XP Home Edition apenas se o fundo do padrão de fundo personalizada é um ficheiro JPEG (.jpg). Ficheiros padrão de fundo de mapa de bits (.bmp) não provocam este problema.
  • A este problema não ocorrer no Windows XP Professional Edition porque o mapa de bits convertido é armazenado no directório de perfil de administrador. Este directório não é eliminado pelo Bem-vindo ao Windows.

Causa

Quando o padrão de fundo do ambiente de trabalho é personalizado e se um JPEG ficheiro é utilizado, o sistema operativo converte o ficheiro para um ficheiro de mapa de bits (.bmp) e, em seguida, armazena o ficheiro de mapa de bits no directório de perfil do utilizador actual. O ficheiro de padrão de fundo sempre chama Wallpaper1.bmp.

No modo de auditoria do Windows XP Home Edition, o ficheiro é armazenado na seguinte localização:
%SystemDrive%\Documents and Settings\Owner\Local Settings\Application Data\Microsoft
Durante o Bem-vindo (OOBE do Windows), o conteúdo do proprietário original do directório de perfil são propagadas para um directório de perfil de proprietário recém-criado e o directório de perfil e de conta de proprietário original será eliminado. Isto ocorre por predefinição. No entanto, porque o registo ainda está a apontar para o original proprietário perfil directório que já não existe, não será apresentado o padrão de fundo.

Resolução

importante Esta secção, método ou tarefa contém passos que indicam como modificar o registo. No entanto, poderão ocorrer problemas graves se modificar o registo de forma incorrecta. Por conseguinte, certifique-se de que segue estes passos cuidadosamente. Criar uma para protecção adicional, cópia de segurança do registo antes de o modificar. Em seguida, pode restaurar o registo se ocorrer um problema. Para obter mais informações sobre como efectuar uma cópia de segurança e restaurar o registo, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
322756Como efectuar uma cópia de segurança e restaurar o registo no Windows

Para contornar este problema, utilize um dos seguintes métodos para modificar o registo:
  • Método 1: Utilize o Editor de registo.
  • Método 2: Utilize um ficheiro de registo (listado mais adiante nesta secção).

Método 1: Utilizar o Editor de registo

Depois de aplicar o padrão de fundo que pretende no modo de auditoria e antes de executar o Sysprep.exe no modo de reseal, modifique os valores de registo seguinte:
  1. Inicie o Editor de registo (Regedit.exe).
  2. Localize e clique em seguida, o valor padrão de fundo na seguinte chave no registo:
    HKEY_CURRENT_USER\Control Panel\Desktop
  3. No menu Editar , clique em Modificar , escreva o seguinte e, em seguida, clique em OK :
    %USERPROFILE% \Local Settings\Application Data\Microsoft\Wallpaper1.bmp
  4. Localizar e, em seguida, clique no valor OriginalWallpaper na seguinte chave no registo:
    HKEY_CURRENT_USER\Control Panel\Desktop
  5. No menu Editar , clique em Modificar , escreva o seguinte e, em seguida, clique em OK :
    %USERPROFILE% \Local Settings\Application Data\Microsoft\Wallpaper1.bmp
  6. Saia de edição do registo.

    Agora é possível executar Syspre.exe no modo de reseal.

Método 2: Utilizar um ficheiro de registo

Em alternativa, pode actualizar o registo utilizando o seguinte ficheiro de registo:

Editor de registo do Windows versão 5.00

[HKEY_CURRENT_USER\Control Panel\Desktop]
"Wallpaper"="%USERPROFILE%\\Local Settings\\Application Data\\Microsoft\\Wallpaper1.bmp"
"OriginalWallpaper"="%USERPROFILE%\\Local Settings\\Application Data\\Microsoft\\Wallpaper1.bmp"
Nota Guarde o ficheiro de registo como Fixwall.reg. Utilizando a variável de ambiente %USERPROFILE% em entradas de registo, pode tornar possível para o sistema operativo localizar o ficheiro avaliar a variável e, em seguida, fornecendo o caminho do directório perfil correcto do ficheiro de mapa de bits de padrão de fundo.

O ficheiro de registo pode ser importado sem intervenção do utilizador a partir de um ficheiro batch utilizando a sintaxe seguinte (partindo do princípio de que o ficheiro de registo nesta secção foi guardado como Fixwall.reg):
Regedit /s fixwall.reg

Ponto Da Situação

A Microsoft confirmou que este erro ocorre nos produtos do Microsoft listados na secção "Aplica-se a".

Mais Informação

Passos para reproduzir o comportamento

  1. Instale o Microsoft Windows XP Home Edition, utilizando o Kit de pré-instalação OEM (OPK). Depois de concluída a instalação, o sistema está em modo de auditoria (a caixa de diálogo Ferramenta de preparação do sistema aparece no canto superior direito do ecrã).
  2. Altere o padrão de fundo do ambiente de trabalho. O padrão de fundo que escolher tem ser um ficheiro JPEG (.jpg).
  3. Utilize a ferramenta de preparação de sistema Resselar botão para preparar o sistema e executar o Bem-vindo ao Windows (OOBE) da próxima vez que o computador é iniciado.
  4. Iniciar o computador e, em seguida, siga as instruções no Assistente do Bem-vindo ao Windows (OOBE).

    Depois do assistente estiver concluído, é apresentado o ambiente de trabalho. No entanto, não será apresentado o padrão de fundo seleccionado.

Propriedades

Artigo: 329677 - Última revisão: 19 de maio de 2005 - Revisão: 3.2
A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Home Edition SP1
  • Microsoft Windows XP Home Edition SP2
  • Kit de pré-instalação OEM Microsoft para Windows XP
Palavras-chave: 
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Tradução automática
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Clique aqui para ver a versão em Inglês deste artigo: 329677

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