Papel de parede da área de trabalho personalizada pode não ser exibida após a conclusão da tela de boas-vindas do Windows

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Sintomas

Depois que o usuário acessou o Windows Welcome (também conhecido como "do usuário" ou OOBE), o usuário não pode ver o plano de fundo personalizado de OEM papel de parede da área de trabalho. O usuário pode ver somente uma área de trabalho sem formatação com ícones exibidos.

Observação Esse problema ocorre no Windows XP da seguinte maneira:
  • Esse problema ocorre no Windows XP Home Edition somente se o plano de fundo personalizado de papel de parede é um arquivo JPEG (.jpg). Arquivos de papel de parede de bitmap (.bmp) não causam esse problema.
  • Faz esse problema não ocorrer no Windows XP Professional Edition porque o bitmap convertido é armazenado na pasta perfil administrador. Esta pasta não será excluída por tela de boas-vindas do Windows.

Causa

Quando o papel de parede da área de trabalho é personalizado e, se uma imagem JPEG arquivo é usado, o sistema operacional converte o arquivo em um arquivo de bitmap (.bmp) e, em seguida, armazena o arquivo de bitmap no diretório de perfil do usuário atual. O arquivo de papel de parede é sempre chamado Wallpaper1.bmp.

No modo de auditoria do Windows XP Home Edition, o arquivo está armazenado no seguinte local:
%SystemDrive%\Documents and Settings\Owner\Local Settings\Application Data\Microsoft
Durante o Windows Welcome (OOBE), o conteúdo do proprietário original da pasta de perfil são propagadas para um diretório de perfil do proprietário recém-criado e o diretório de conta e perfil de proprietário original será excluído. Isso ocorre por design. No entanto, porque o registro ainda está apontando para o original proprietário perfil diretório que não existe mais, o papel de parede não será exibida.

Resolução

importante Esta seção, método ou tarefa contém etapas que informam sobre como modificar o registro. No entanto, sérios problemas poderão ocorrer se você modificar o registro incorretamente. Por isso, certifique-se que você execute essas etapas cuidadosamente. Para proteção adicional, fazer backup do registro antes de modificá-lo. Em seguida, você pode restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup e restaurar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
322756Como fazer backup e restaurar o registro no Windows

Para contornar esse problema, use um dos seguintes métodos para modificar o registro:
  • Método 1: Use o Editor do Registro.
  • Método 2: Use um arquivo de registro (listado posteriormente nesta seção).

Método 1: Usar o Editor do registro

Após aplicar o papel de parede que você deseja no modo de auditoria e antes de executar o Sysprep.exe no modo de lacrar novamente, modificar os seguintes valores do Registro:
  1. Inicie o Editor do Registro (Regedit.exe).
  2. Localize e clique em seguida, o valor de papel de parede na seguinte chave no Registro:
    HKEY_CURRENT_USER\Painel Panel\Desktop
  3. No menu Editar , clique em Modificar , digite o seguinte e, em seguida, clique em OK :
    %USERPROFILE% \Local Settings\Application Data\Microsoft\Wallpaper1.bmp
  4. Localize e clique em valor OriginalWallpaper sob a seguinte chave no Registro:
    HKEY_CURRENT_USER\Painel Panel\Desktop
  5. No menu Editar , clique em Modificar , digite o seguinte e, em seguida, clique em OK :
    %USERPROFILE% \Local Settings\Application Data\Microsoft\Wallpaper1.bmp
  6. Feche a edição do Registro.

    Agora você pode executar Syspre.exe no modo de lacrar novamente.

Método 2: Usar um arquivo de registro

Como alternativa, você pode atualizar o registro usando o seguinte arquivo de registro:

Windows Registry Editor versão 5.00

[HKEY_CURRENT_USER\Control Panel\Desktop]
"Wallpaper"="%USERPROFILE%\\Local Settings\\Application Data\\Microsoft\\Wallpaper1.bmp"
"OriginalWallpaper"="%USERPROFILE%\\Local Settings\\Application Data\\Microsoft\\Wallpaper1.bmp"
Observação Salve o arquivo de registro como Fixwall.reg. Usando a variável de ambiente %USERPROFILE% nas entradas do Registro, você torna possível para o sistema operacional localizar o arquivo avaliando a variável e, em seguida, fornecendo o caminho de diretório de perfil correto do arquivo de bitmap de papel de parede.

O arquivo de registro pode ser importado sem intervenção do usuário de um arquivo em lotes, usando a seguinte sintaxe (supondo que o arquivo de registro nesta seção foi salvo como Fixwall.reg):
regedit /s fixwall.reg

Situação

A Microsoft confirmou que esse é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

Passos para reproduzir o problema

  1. Instale o Microsoft Windows XP Home Edition usando o Kit de pré-instalação OEM (OPK). Após a instalação completa, o sistema está no modo de auditoria (a caixa de diálogo Ferramenta de preparação do sistema aparece no canto superior direito da tela).
  2. Altere o papel de parede da área de trabalho. O papel de parede escolhido deve ser um arquivo JPEG (.jpg).
  3. Use a ferramenta de preparação do sistema Lacrar novamente botão para preparar o sistema e executar o Windows Welcome (OOBE) na próxima vez que o computador for iniciado.
  4. Inicie o computador e, em seguida, siga os prompts do Assistente de boas-vindas do Windows (OOBE).

    Após o assistente for concluído, aparece a área de trabalho. No entanto, o papel de parede selecionado não será exibido.

Propriedades

ID do artigo: 329677 - Última revisão: quinta-feira, 19 de maio de 2005 - Revisão: 3.2
A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Home Edition SP1
  • Microsoft Windows XP Home Edition SP2
  • Microsoft OEM Preinstall Kit para Windows XP
Palavras-chave: 
kbmt kbbug kbfix KB329677 KbMtpt
Tradução automática
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Clique aqui para ver a versão em Inglês deste artigo: 329677

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