Article ID: 329731 - Last Review: November 15, 2007 - Revision: 1.6

FIX: Search of Multiple Catalogs Simultaneously Produces Zero Results

Hotfix download is availableHotfix Download Available
View and request hotfix downloads
This article was previously published under Q329731

On This Page

Expand all | Collapse all

SYMPTOMS

When you use a search call that contains both a SQL clause and a Free Text phrase to search for a multilanguage property, the catalog manager search fails.

CAUSE

This problem occurs because the stored procedure that implements the search operation performs an incorrect join.

WORKAROUND

To work around this problem, do not use catalogue search operations for multilanguage properties.

RESOLUTION

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date          Time    Size      File name
   -------------------------------------------------
   25-Sep-2002   17:46   602,385   CatalogCreate.sql
				

STATUS

Microsoft has confirmed that this is a problem in Commerce Server 2002.

MORE INFORMATION

Steps to Reproduce the Behavior

To reproduce the problem, run a full text catalogue search that has the following options:
  • PropertySearch on a multilanguage property

    -and-
  • eClassTypesRequired contains the ProductFamilyForVariants bit set

APPLIES TO
  • Microsoft Commerce Server 2002 Service Pack 1
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbbug kbfix kbqfe KB329731
 

Article Translations

 

Related Support Centers